MT-32 emulation was working with 1.7; not working with 1.8

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
Posts: 1
Joined: Fri Sep 02, 2016 9:27 pm

MT-32 emulation was working with 1.7; not working with 1.8

Post by rrt »

I set up MT-32 emulation with ROM images according to the README instructions, and it was working with ScummVM 1.7.0. Recently I updated to 1.8.1, and I started getting the error "MT32emu Init error: Missing PCM ROM image".

I have not moved the ROM files (which are installed in my extras path), or changed the extras path.

I've searched on the forums and can't find any mention of this issue (though I could have overlooked something).

I note that some default paths have changed in 1.8.0, but I have the extras path explicitly set. I have moved my saved games and ini file to the new locations and tested them.

I tried copying the ROM images into the game directory (in this case, monkey2), but that didn't help: I got exactly the same error.

(Note again: it was working fine with 1.7.0; it stopped working, with identical settings, with 1.8.1.)

Posts: 6
Joined: Tue Aug 16, 2016 1:35 am

Post by lwbqnt »

As a test, have you tried moving the ROMs into the ScummVM executable program directory?

For example: C:\Program Files (x86)\ScummVM\

User avatar
Posts: 159
Joined: Mon Nov 01, 2010 9:17 am
Location: United States

Post by envisaged0ne »

I'm using the latest 1.9 dev build and it's working fine. I do have the ROM files in the ScummVM directory

User avatar
ScummVM Lead
Posts: 2058
Joined: Wed Sep 21, 2005 1:06 pm

Post by sev »

rrt, are you on Windows? We did not change much in Munt, the MT-32 emulator, so what you have must be problem with your path layout.


Post Reply