Steam In-Home Streaming and ScummVM

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
User avatar
QuestingHero
Posts: 17
Joined: Mon Oct 18, 2010 7:41 pm

Steam In-Home Streaming and ScummVM

Post by QuestingHero »

I have been putting ALL my games in Steam so that I can play them on my TV with the steam controller with my kids. it works GREAT for all apps that use directx (it may be Direct3D/OpenGL) for rendering, which unfortunately ScummVM appears to not. The Steam controller depends on the Steam overlay to be available for it to do it's custom key mapping thing, if it's NOT available, it defaults to a "Desktop" config. configuring the desktop config for ScummVM works OK as a work around, but it's not ideal.

One of the work arounds I have read about to get the Steam overlay to show is set the Game renderer to OpenGL. I have tried several games and have only been able to get this to work work on 1 game (Simon the Sorcerer 1 Android version). Every other game I have tried it on(Quest For Glory 1/3 GOG, Fate of Atlantis CD, and Comi CD) just show the streaming computers (or Server) desktop with the audio of the game playing. I have also tried setting "SDL_VIDEODRIVER=directx" in the windows environment variables (both system and user), and that doesn't seem to change anything.

I am running Windows 10 x64 with an ATI r270 as the Steam Streamer, and the "clients" are a Mac Book and the Steam Link. I have tried ScummVM 1.7.0, 1.7.0pre79-gbc237fc. This may be a limitation of ScummVM/SDL, but if it's not, I would love to be able to get this working.

Update 1: I have also tried the fix here (viewtopic.php?t=13862), setting compatibility mode to windows 7 and disable high DPI

Update 2: ScummVM 1.6.0 (July 9 2013) seems to work with the Steam overlay. in this version of ScummVM (for Windows) there are 3 OpenGL options. "OpenGL Normal" gives me the same broken desktop result as 1.7.0. "OpenGL Conserve" gives Full screen (no smoothing) with Steam overlay. "OpenGL Normal" makes it a postage stamp size screen (original game resolution), with steam overlay working. I do not have any games that require 1.7.0, so I will just use 1.6.0 with "OpenGL Conserve" Graphics mode. BTW, I had to google for the 1.6.0 binary as I couldn't find them on ScummVMs site.

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3330
Joined: Mon Oct 31, 2005 7:39 am

Re: Steam In-Home Streaming and ScummVM

Post by eriktorbjorn »

QuestingHero wrote:I do not have any games that require 1.7.0, so I will just use 1.6.0 with "OpenGL Conserve" Graphics mode. BTW, I had to google for the 1.6.0 binary as I couldn't find them on ScummVMs site.
I don't know anything about the original problem, but as long as you're looking for an official ScummVM build you should be able to find older versions on the SourceForge page.

User avatar
QuestingHero
Posts: 17
Joined: Mon Oct 18, 2010 7:41 pm

Post by QuestingHero »

Thanks for the official link to 1.6.0, I'll swap out the version I downloaded. as for my problem, It seems that the (Windows) OpenGL implementation in 1.7.0 is broken based upon my findings and the following posts:

viewtopic.php?t=13862
viewtopic.php?t=13788
viewtopic.php?t=13695
viewtopic.php?t=13718

User avatar
QuestingHero
Posts: 17
Joined: Mon Oct 18, 2010 7:41 pm

Post by QuestingHero »

Final update (maybe)

As of the Nov 1 Steam Client update, all of my steam purchased ScummVM games work. also, adding a non steam scummvm game work by adding the "--no-console" command line switch. I am currently using the latest windows x64 build.

EX: "C:\ScummVM\scummvm.exe" -c ./game-ini-file.ini --no-console gameid

The ini file should have the following set under the [scummvm] header
gfx_mode=opengl_nearest
I pulled that from a Steam purchased game.

hope this helps someone.

Post Reply