1.7.0 Supports Steam versions of SCUMM adventures?

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
Retrodude
Posts: 26
Joined: Sat May 08, 2010 11:10 pm
Location: N/A

1.7.0 Supports Steam versions of SCUMM adventures?

Post by Retrodude »

Looking at the release notes for 1.7 it says support was added for the Steam releases of The Dig, Loom, and the Indy adventures. Despite this, when I point ScummmVM to the datafiles it still doesn't recognize a game in there. Am I doing something wrong?
User avatar
criezy
ScummVM Developer
Posts: 765
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy »

Is this the Windows or Mac version of the steam games?
Both should work, but I can only confirm that it works with the Mac versions. For those, when adding the game to ScummVM you need to select the .app bundle (e.g. Loom.app, do not navigate inside the bundle to the Resource directory).

Otherwise do you get a message in the console when trying to add those games?

Note: the game executable from the steam version is necessary as one of the game data file is included in it. So you need more than just the data files.
Retrodude
Posts: 26
Joined: Sat May 08, 2010 11:10 pm
Location: N/A

Post by Retrodude »

It's the Windows version I was trying to play. I was finally able to make it show up by directing it to the Steam game folder rather than the folder containing the game's datafiles. I knew that some of the datafiles were missing from this release, but I didn't know until now that they packed the missing files into the game's EXE! Very tricky. Thanks for the help, anyways!
Post Reply