I Have no Mouth and I must scream

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
LoneKiller
Posts: 6
Joined: Wed Apr 14, 2021 1:20 pm

I Have no Mouth and I must scream

Post by LoneKiller »

Hello
sorry for this stupid question but I am a complete newbie with SCUMMVM.

I am trying to play IHNM on my Windows 10 machine but I have a lot of problems with sound. I successfully copied all needed files from the CD to Hard Disk and SCUMMVM correctly identified the game when I added it, but at the beginning, music, sfx and speech were not heard at all. After reading many guides and playing a bit with the different options, I was able to activate the music by changing the gm_device to "auto", but no matter what other option I change, no sfx or speech is heard. In addition, apparently any value in music_driver different from "auto" or "windows" will make the music disappear again. I checked if all file are present by checking the SCUMMVM wiki and I can confirm all files, including sound effects and speech, are present in the game folder.

Just to be sure I checked if any mute option was activated, but this is not the case. To be honest I am completely out of ideas, so now I have to ask for help to someone more skilled than me :)

Am I doing something wrong? Anyone has suggestions?

Thanks in advance.

Lone Killer
User avatar
Praetorian
ScummVM Developer
Posts: 362
Joined: Tue May 08, 2007 8:54 am
Location: Greece
Contact:

Re: I Have no Mouth and I must scream

Post by Praetorian »

LoneKiller wrote: Wed Apr 14, 2021 2:42 pm Hello
sorry for this stupid question but I am a complete newbie with SCUMMVM.

I am trying to play IHNM on my Windows 10 machine but I have a lot of problems with sound. I successfully copied all needed files from the CD to Hard Disk and SCUMMVM correctly identified the game when I added it, but at the beginning, music, sfx and speech were not heard at all. After reading many guides and playing a bit with the different options, I was able to activate the music by changing the gm_device to "auto", but no matter what other option I change, no sfx or speech is heard. In addition, apparently any value in music_driver different from "auto" or "windows" will make the music disappear again. I checked if all file are present by checking the SCUMMVM wiki and I can confirm all files, including sound effects and speech, are present in the game folder.

Just to be sure I checked if any mute option was activated, but this is not the case. To be honest I am completely out of ideas, so now I have to ask for help to someone more skilled than me :)

Am I doing something wrong? Anyone has suggestions?

Thanks in advance.

Lone Killer
Could you please write the version of ScummVM you are testing with?
Also could you share the contents of your ScummVM configuration file (scummvm.ini)? In Windows it should be under:

Code: Select all

%APPDATA%/ScummVM/scummvm.ini
In particular we're interested for the global section of the ini file (top most section, named "scummvm") and the section for the "I have no mouth" game ( a section named "ihnm" or similar).

Also, you could have a look in the ScummVM log to see if you can spot any outstanding messages about sound issues. ScummVM log should be under

Code: Select all

%APPDATA%/ScummVM/Logs/scummvm.log
I've just tested with latest ScummVM (developer build, 2.3.0git) and also with the version that the GOG release comes with (ScummVM 2.0.0) and I didn't notice any issues with speech sound or music.

You shouldn't really have to mess with the sound options at all. I have the "default" options in the Global "Options...", "Audio" Tab and also "Don't use General MIDI music" in the MIDI Tab and "Don't use Roland MT-32 music" in the MT-32 tab. And I have no special sound options set for the game to override those, and it works out of the box, so to speak.

So, I'm thinking it might be an issue with some bad configuration option.
LoneKiller
Posts: 6
Joined: Wed Apr 14, 2021 1:20 pm

Re: I Have no Mouth and I must scream

Post by LoneKiller »

Good Day Praetorian and thank you very much for quick reply.

At the moment I am trying to use the same version of GoG (2.0.0) since I read on the net that it was working very easily and I decided to use the same. Nonetheless I am experiencing this strange sound problem, but is possible to be related to my inexperience in using SCUMMVM.

I tried your suggestion below (putting all Midi as "not used" and "auto" in Global) but again in this way I got completely no audio. Only when I select a MIDI device, I can get music but nothing more. I also checked if any other sound device was receiving a signal while the game was running, but all was silent for all output devices (example, motherboard integrated sound card).

Here is the log, basically all seems OK:

[2021-04-14 19:29:30] ScummVM 2.0.0 (Dec 9 2017 07:14:40)
[2021-04-14 19:29:30] Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG
[2021-04-14 19:29:30] --- Log opened.
[2021-04-14 19:30:08] --- Log closed successfully.

And here is the configuration ini, to be honest I also edited this file changing some options manually, using this setup I have all mute:

[scummvm]
filtering=false
mute=false
speech_volume=192
native_mt32=false
mt32_device=null
kbdmouse_speed=3
talkspeed=60
midi_gain=100
subtitles=true
multi_midi=false
fullscreen=false
updates_check=0
gui_browser_show_hidden=true
browser_lastpath=D:\Giochi\I Have No Mouth\Dati\
gm_device=null
sfx_volume=192
music_volume=192
speech_mute=false
lastselectedgame=ihnm
music_driver=auto
opl_driver=auto
aspect_ratio=false
versioninfo=2.0.0
autosave_period=300
enable_gs=false

[ihnm]
description=I Have No Mouth and I Must Scream (DOS/English)
path=D:\Giochi\I Have No Mouth\Dati\
gameid=saga
language=en
gui_saveload_last_pos=0
platform=pc
guioptions=noAspect lang_English

If I change gm_device to "auto" or music_driver to "windows" (forcing MIDI) I get music, otherwise all is silent.

I am completely out of ideas so any suggestion is highly appreciated.

Lone Killer
User avatar
sev
ScummVM Lead
Posts: 2096
Joined: Wed Sep 21, 2005 1:06 pm
Contact:

Re: I Have no Mouth and I must scream

Post by sev »

I also need the full md5s of your game files, especially voices*.res and sfx.res. It may happen that you have an unknown version of the game. For example, ITE, a previous game from the same company, had 17 (!) distinct game releases, and the primarily difference is different file names or audio formats.


Eugene
User avatar
Praetorian
ScummVM Developer
Posts: 362
Joined: Tue May 08, 2007 8:54 am
Location: Greece
Contact:

Re: I Have no Mouth and I must scream

Post by Praetorian »

It could be an issue with the data files then, as sev mentioned.

Your configuration file works with my ScummVM 2.0.0 for me and plays sound in the game. Music and speech. The intro logo screens are silent -- but I think that is how it is supposed to be. This is tested with the GOG version of the game.

Also keep in mind, that the game has its own settings for Sound. Press "F5" while in-game and check volume levels there and that "Both" is set for Voices.

Image

Unfortunately, I'm noticing that those in-game settings don't synchronize well with the ScummVM settings (at least in ScummVM 2.0.0 where I'm now testing), so if you mess with those you have to make sure that the ScummVM settings will have the appropriate values too. Just press "Ctrl+F5" while in-game to bring up the ScummVM GMM, go to "Options", and make sure the volume levels and mute setting have the right values.
Image

For the record, my original configuration file for I Have no Mouth and I Must Scream looks like this (please, note that "path" and "savepath" are different since those use the paths for the game folder on my PC):

Code: Select all

[scummvm]
mute=false
speech_volume=192
native_mt32=false
midi_gain=100
talkspeed=60
subtitles=true
multi_midi=false
fullscreen=false
updates_check=0
sfx_volume=192
music_volume=192
autosave_period=300
lastselectedgame=ihnm
music_driver=auto
aspect_ratio=true
versioninfo=2.0.0
speech_mute=false
enable_gs=false

[ihnm]
description=I Have No Mouth and I Must Scream (DOS/English)
kbdmouse_speed=3
savepath=d:\games\i have no mouth\saves
path=d:\games\i have no mouth
gameid=saga
language=en
gui_saveload_last_pos=0
platform=pc
aspect_ratio=false
guioptions=noAspect lang_English
LoneKiller
Posts: 6
Joined: Wed Apr 14, 2021 1:20 pm

Re: I Have no Mouth and I must scream

Post by LoneKiller »

Thank you very much, I will try this ini as soon as I can.

In the meantime here the MD5, I hope I did all correctly since this is the first time I do so:

musicfm.res: fe63a88b8c49baa69a814fc15659b1df
musicgm.res: df2f4722f720780e3cb4abf330f1db2f
patch.re_: a88a9182abd95ed2af059ef28af9f470
scream.res: 0cf2947caaa466c16267b8284efa4617
scripts.res: 3f7b3743f9da12b81ff6afb870f2a580
sfx.res: 06fdca8d4ce9a971c35ec8e8a2a77100
voices1.res: 62e176e3198ce9c9472b8463faa55d7f
voices2.res: 29112e29055bc184fceae84f78c5c20e
voices3.res: 89a0b65d47faa26143c397c8dbfba963
voices4.res: 21b899a53dddec8d0b7cda39f4f40d0f
voices5.res: 8ec27386f71e28ffb63812e5a2b7ce5b
voices6.res: 5sa951d5ad40227b44a55753f531dc1c
voicess.res: d4da3081a739400d5894fe23aa0b6fbb
LoneKiller
Posts: 6
Joined: Wed Apr 14, 2021 1:20 pm

Re: I Have no Mouth and I must scream

Post by LoneKiller »

Ok now I am really confused.
I tried your ini all all is mute.
I also checked the CTRL+F5 and all is fine.
The ingame settings are ok too it was the first thing I checked.
Can the problem be connected to my sound device settings? This would be the first time, also other programs are perfect but running out of ideas and to be honest I did not touch anything there.
User avatar
Praetorian
ScummVM Developer
Posts: 362
Joined: Tue May 08, 2007 8:54 am
Location: Greece
Contact:

Re: I Have no Mouth and I must scream

Post by Praetorian »

LoneKiller wrote: Thu Apr 15, 2021 9:34 am Thank you very much, I will try this ini as soon as I can.

In the meantime here the MD5, I hope I did all correctly since this is the first time I do so:

musicfm.res: fe63a88b8c49baa69a814fc15659b1df
musicgm.res: df2f4722f720780e3cb4abf330f1db2f
patch.re_: a88a9182abd95ed2af059ef28af9f470
scream.res: 0cf2947caaa466c16267b8284efa4617
scripts.res: 3f7b3743f9da12b81ff6afb870f2a580
sfx.res: 06fdca8d4ce9a971c35ec8e8a2a77100
voices1.res: 62e176e3198ce9c9472b8463faa55d7f
voices2.res: 29112e29055bc184fceae84f78c5c20e
voices3.res: 89a0b65d47faa26143c397c8dbfba963
voices4.res: 21b899a53dddec8d0b7cda39f4f40d0f
voices5.res: 8ec27386f71e28ffb63812e5a2b7ce5b
voices6.res: 5sa951d5ad40227b44a55753f531dc1c
voicess.res: d4da3081a739400d5894fe23aa0b6fbb
Mine are:

Code: Select all

musicfm.res: FE63A88B8C49BAA69A814FC15659B1DF
musicgm.res: DF2F4722F720780E3CB4ABF330F1DB2F
patch.re_:     A88A9182ABD95ED2AF059EF28AF9F470
scream.res:  0CF2947CAAA466C16267B8284EFA4617
scripts.res:    3F7B3743F9DA12B81FF6AFB870F2A580
sfx.res:     06FDCA8D4CE9A971C35EC8E8A2A77100
voices1.res: 62E176E3198CE9C9472B8463FAA55D7F
voices2.res: 29112E29055BC184FCEAE84F78C5C20E
voices3.res: 89A0B65D47FAA26143C397C8DBFBA963
voices4.res: 21B899A53DDDEC8D0B7CDA39F4F40D0F
voices5.res: 8EC27386F71E28FFB63812E5A2B7CE5B
voices6.res: 55A951D5AD40227B44A55753F531DC1C
voicess.res: D4DA3081A739400D5894FE23AA0B6FBB
So, they are identical, except for voices6.res, which I am guessing it's a typo on your side (second character in the MD5 checksum is "5" not "S" for me.

I cannot think of any reason this is happening then, as of yet.
  • Do you have some special sound card set up?
  • Does the situation change if you use headphones?
  • Do other games that have non-midi music and have speech sound, play ok with ScummVM? Eg. Broken Sword 2.5 (which is freeware) or Blade Runner?
LoneKiller
Posts: 6
Joined: Wed Apr 14, 2021 1:20 pm

Re: I Have no Mouth and I must scream

Post by LoneKiller »

OK I found a solution but is... strange.

If I launch the game in a virtual machine with Windows XP, all is fine immediately. This is quite strange but probably connected to my sound configuration. I did not touch anything there but this seems the reason.

I have a Stix sound card and games, music and video work perfectly, this is the first time I have such issues. Even reverting options to default is not changing.

Only point I have - I am using SPDIF as out port, can this be the problem?
User avatar
Praetorian
ScummVM Developer
Posts: 362
Joined: Tue May 08, 2007 8:54 am
Location: Greece
Contact:

Re: I Have no Mouth and I must scream

Post by Praetorian »

LoneKiller wrote: Thu Apr 15, 2021 12:05 pm OK I found a solution but is... strange.

If I launch the game in a virtual machine with Windows XP, all is fine immediately. This is quite strange but probably connected to my sound configuration. I did not touch anything there but this seems the reason.

I have a Stix sound card and games, music and video work perfectly, this is the first time I have such issues. Even reverting options to default is not changing.

Only point I have - I am using SPDIF as out port, can this be the problem?
So this to me tells me that ScummVM, probably through the SDL layer, fails to find the correct way to output digitized sound like speech, for your specific sound configuration case.

What if you use the analog ports of your sound card, eg. with headphones, if that is an option. Does it work ok then?
LoneKiller
Posts: 6
Joined: Wed Apr 14, 2021 1:20 pm

Re: I Have no Mouth and I must scream

Post by LoneKiller »

This is getting more complicated.

I tried to use the headphone output port of my Strix card and again all is mute.
If I disable the Strix and force the output from the Realtek integrated audio device in my motherboard all is working perfectly, both digital and headset.
Even stranger, I did a test and I was able to have the Strix work too, but I have to:

1)Set the Realtek integrated digital as primary output device in the Sound Control Panel
2)Launch ScummVm but not the game
3)While ScummVm is active, select the Strix digital as primary output device in the Sound Control Panel
4)Launch the game

If I follow above procedure, the audio is correctly played - music, sfx and speech. If I close the game and launch again without the above procedure, all is mute again.

I have to admit this is getting too complicated for my skills so I have no idea if this can help or not, and cannot think of any other tests I can do. I think I can be happy since I found several ways to play the game in full (Virtual Machine or changing output device) but I would be glad if this situation can be of help to others. Please let me know if I have to try something.
Post Reply