ScummVM on 4k

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
User avatar
lazydays79
Posts: 6
Joined: Thu Oct 08, 2020 8:00 pm
Location: Germany

ScummVM on 4k

Post by lazydays79 »

Hi!

I just bought a notebook with 4k display (3840x2160). Most applications are scaling fine, except for ScummVM (or maybe I'm not smart enough ;) ).

So, is there any theme or something similar which is able to handle 4k?

If not, is it worth writing a 4k Theme (with bigger buttons, texts, etc)? If yes, I would dig into the documentation and try to write one...

Any other ideas about this topic?

Kind regards and stay healthy,
Michael
User avatar
lazydays79
Posts: 6
Joined: Thu Oct 08, 2020 8:00 pm
Location: Germany

Re: ScummVM on 4k

Post by lazydays79 »

Screenshot:

Image
User avatar
Praetorian
ScummVM Developer
Posts: 263
Joined: Tue May 08, 2007 8:54 am
Location: Greece
Contact:

Re: ScummVM on 4k

Post by Praetorian »

lazydays79 wrote: Thu Oct 08, 2020 8:30 pm Screenshot:

Image
I don't own any 4K display hardware to check myself:
- Can you upgrade and share a screenshot from the recent release of ScummVM (2.2.0)? Does it look the same?
- Also can you share a screenshot of your ScummVM settings in Options... -> Graphics (or your scummvm.ini)?
User avatar
lazydays79
Posts: 6
Joined: Thu Oct 08, 2020 8:00 pm
Location: Germany

Re: ScummVM on 4k

Post by lazydays79 »

Yes, it's still the same:

Image

This is my scummvm.ini:

Code: Select all

[scummvm]
last_fullscreen_mode_height=2160
filtering=false
opl_driver=auto
gfx_mode=opengl
mute=false
speech_volume=192
native_mt32=false
mt32_device=null
midi_gain=100
last_fullscreen_mode_width=3840
talkspeed=60
gui_use_game_language=false
tts_voice=0
subtitles=false
multi_midi=false
fullscreen=false
gm_device=null
sfx_volume=192
music_volume=192
speech_mute=false
music_driver=auto
stretch_mode=pixel-perfect
tts_enabled=false
aspect_ratio=false
versioninfo=2.1.1
autosave_period=300
enable_gs=false
There is no difference between the gfx modes opengl or "standard". All other settings are unchanged.

Thanks!
User avatar
Praetorian
ScummVM Developer
Posts: 263
Joined: Tue May 08, 2007 8:54 am
Location: Greece
Contact:

Re: ScummVM on 4k

Post by Praetorian »

lazydays79 wrote: Fri Oct 09, 2020 6:50 pm Yes, it's still the same:

Image

This is my scummvm.ini:

Code: Select all

[scummvm]
last_fullscreen_mode_height=2160
filtering=false
opl_driver=auto
gfx_mode=opengl
mute=false
speech_volume=192
native_mt32=false
mt32_device=null
midi_gain=100
last_fullscreen_mode_width=3840
talkspeed=60
gui_use_game_language=false
tts_voice=0
subtitles=false
multi_midi=false
fullscreen=false
gm_device=null
sfx_volume=192
music_volume=192
speech_mute=false
music_driver=auto
stretch_mode=pixel-perfect
tts_enabled=false
aspect_ratio=false
versioninfo=2.1.1
autosave_period=300
enable_gs=false
There is no difference between the gfx modes opengl or "standard". All other settings are unchanged.

Thanks!
In my experience the OpenGL setting in "Graphic mode" does have such issues on platforms where ScummVM does not have custom scaling settings or some form of automatic scaling.

However the SDL2 scaling options should provide at least some alternative options for UI scaling (like "no scaling", "2x", "3x"). Do you not see these options in the dropdown menu for "Options... -> Graphics -> Graphics mode"?

If not, maybe your build does not have SDL2 support. What Operating System is it you are testing on (Windows, Linux, Mac OSX etc)?

If SDL2 is missing for your platform, it might be better to open a ticket on our bug tracker for the proper developers to notice and track the issue.
https://bugs.scummvm.org/
User avatar
criezy
ScummVM Developer
Posts: 762
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Re: ScummVM on 4k

Post by criezy »

Also in fullscreen OpenGL mode you can use Ctrl-Alt and + or - to cycle through different resolutions.
User avatar
lazydays79
Posts: 6
Joined: Thu Oct 08, 2020 8:00 pm
Location: Germany

Re: ScummVM on 4k

Post by lazydays79 »

Praetorian wrote: Sat Oct 10, 2020 8:10 am
lazydays79 wrote: Fri Oct 09, 2020 6:50 pm Yes, it's still the same:

Image

This is my scummvm.ini:

Code: Select all

[scummvm]
last_fullscreen_mode_height=2160
filtering=false
opl_driver=auto
gfx_mode=opengl
mute=false
speech_volume=192
native_mt32=false
mt32_device=null
midi_gain=100
last_fullscreen_mode_width=3840
talkspeed=60
gui_use_game_language=false
tts_voice=0
subtitles=false
multi_midi=false
fullscreen=false
gm_device=null
sfx_volume=192
music_volume=192
speech_mute=false
music_driver=auto
stretch_mode=pixel-perfect
tts_enabled=false
aspect_ratio=false
versioninfo=2.1.1
autosave_period=300
enable_gs=false
There is no difference between the gfx modes opengl or "standard". All other settings are unchanged.

Thanks!
In my experience the OpenGL setting in "Graphic mode" does have such issues on platforms where ScummVM does not have custom scaling settings or some form of automatic scaling.

However the SDL2 scaling options should provide at least some alternative options for UI scaling (like "no scaling", "2x", "3x"). Do you not see these options in the dropdown menu for "Options... -> Graphics -> Graphics mode"?

If not, maybe your build does not have SDL2 support. What Operating System is it you are testing on (Windows, Linux, Mac OSX etc)?

If SDL2 is missing for your platform, it might be better to open a ticket on our bug tracker for the proper developers to notice and track the issue.
https://bugs.scummvm.org/
Yes, the 2x and 3x options are available, but they really lock odd. Like even worse than the games itself.

Don't get me wrong on that, of course I like the look of the old games. But 2x and 3x options are way worse in the menu of ScummVM.

I run ScummVM on Fedora Core 32.

Regards,
Michael
User avatar
lazydays79
Posts: 6
Joined: Thu Oct 08, 2020 8:00 pm
Location: Germany

Re: ScummVM on 4k

Post by lazydays79 »

criezy wrote: Sat Oct 10, 2020 1:22 pm Also in fullscreen OpenGL mode you can use Ctrl-Alt and + or - to cycle through different resolutions.
This doesn't have any affect at all. :(

Regards,
Michael
User avatar
Praetorian
ScummVM Developer
Posts: 263
Joined: Tue May 08, 2007 8:54 am
Location: Greece
Contact:

Re: ScummVM on 4k

Post by Praetorian »

lazydays79 wrote: Thu Oct 15, 2020 11:52 pm Yes, the 2x and 3x options are available, but they really lock odd. Like even worse than the games itself.

Don't get me wrong on that, of course I like the look of the old games. But 2x and 3x options are way worse in the menu of ScummVM.

I run ScummVM on Fedora Core 32.
Please provide screenshots. Is the UI bugged in 2x or 3x, is it too blurry or illegible?

However, this might be the issue that the direct OpenGL renderer is not offering multiple scaling options for the UI as the SDL library does. This cannot get resolved, as far as I know, until someone implements these options in ScummVM, and apart from that person itself we need to know what is wrong with the existing SDL based scaling.

In any case, it's best practice to open a ticket about this providing all the relevant information and screenshots in the thread, on our bug tracker
https://bugs.scummvm.org/
User avatar
lazydays79
Posts: 6
Joined: Thu Oct 08, 2020 8:00 pm
Location: Germany

Re: ScummVM on 4k

Post by lazydays79 »

Ok, thank you so far!

I will create a ticket.

Have a nice weekend!
User avatar
criezy
ScummVM Developer
Posts: 762
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Re: ScummVM on 4k

Post by criezy »

lazydays79 wrote: Thu Oct 15, 2020 11:52 pm
criezy wrote: Sat Oct 10, 2020 1:22 pm Also in fullscreen OpenGL mode you can use Ctrl-Alt and + or - to cycle through different resolutions.
This doesn't have any affect at all. :(
Strange. I just checked that it works both on macOS and Ubuntu for me.
The shortcuts I provided (Ctrl-Alt and + or -) are the default shortcuts to increase and decrease the scale factor, but you can also remap those to something else in the ScummVM options. For me, with a UK keyboard, the '+' key is accessed with 'Shift' and '=' for example, so I cannot generate the Ctrl-Alt and + shortcut and instead remapped the action to Ctrl-Alt and =.
Post Reply