[TouchMod] Touchpad like control-scheme

Subforum for discussion and help with ScummVM's Android port

Moderator: ScummVM Team

Posts: 29
Joined: Sun Jan 03, 2010 1:03 pm

Post by EowynCarter »

Finally : I haven't been able to load Lands of Lore ! I installed the Kyra engine pack that was in the archive, but when I select the directory of the game I get a "No game found". I tried every single directory, without success.
I know that the port of the engine isn't finished, But I managed to at least launch the game with another build of Scumm for the Android.
Oh, scumm vm is land of lore compatible now. Fancy :)

To be back on topic, there is definitly some need about alternative controls. My archos 5 should be able to do the job better than my tattoo, but the mess that is controling without the hardwares buttons kind of kills it.
And the new version shrinks to the lower end of the screen
Posts: 1
Joined: Fri Jan 07, 2011 7:27 pm

Post by stragulus »


I thought the peculiar mouse-movement controls were a bug, but after having spent a few hours on getting this to run in eclipse to debug it, I figured out that it was actually the desired touchpad feature :oops:

Well, at least as a side-effect I did get the code to compile in eclipse. The java-code, that is. I simply include libscummvm.so precompiled, so that it can be droppped in and replaced whenever a new version of it is availabe. Should you be interested in that, let me know :)
Posts: 1
Joined: Wed Jan 12, 2011 7:44 am

Post by dragonfire »


I'm unable to load Touche. Every time I try I get a "No game found". I've tried all your new compiled plugins as well as the oficial ones.
User avatar
Posts: 1
Joined: Fri Jan 14, 2011 11:16 pm

Re: [TouchMod] Touchpad like control-scheme

Post by BatteMan »

das_weezul wrote:I've compiled the scummvm.apk and (most) engine plugins
Hi das_weezul !

First of all, I want to say thank you for your work, it's a really good alternative control mode.

I'm a fan of Delphine Software's games and I want to know if you plan to compile the Cine and Cruise engines. You'll make a happy man ;)

Thank you again and keep it up the good work !

/me is a french gamer on a Nexus One and he couldn't play to "Cruise for a corpse"... but he wants to ! ;)
Posts: 1
Joined: Thu Jan 27, 2011 10:30 am

Post by Alex »

Great Work!

But, i have small problem too,with my galaxy i cant confirm the dialogues in Lure of tempress, dunno why.
Posts: 23
Joined: Thu Sep 09, 2010 9:02 pm

Long time no see

Post by das_weezul »

Hi guys!

I just wanted to proof that I'm not dead, though I'm feeling I have no life right now as exams and work keep on piling up fast :( I will definately come back to the TouchMod as soon as find time. In the meantime, have fun and keep on submitting your suggestions and thanks for all your feedback!


@stragulus: That sounds really handy, could you post some details?
Got a warning
Posts: 36
Joined: Thu Feb 19, 2009 6:09 pm

Post by sblaise84 »

hey i've got a coby kyros 7015 tablet. the current 1.2.1 build works for me but I don't have enough hardware buttons to utilize right clicking so most games are useless to me. I tried using this touchmod build but when the scummvm loading bar completes it closes back onto my home screen every time i run the app
Got a warning
Posts: 36
Joined: Thu Feb 19, 2009 6:09 pm

Post by sblaise84 »

oh, while browsing the forums i came upon this:


works great on my tablet it has amazing functionality check it out!
tick bite
Posts: 1
Joined: Sat Mar 05, 2011 1:03 pm

Post by tick bite »

First of all: this is a great mod!

But I have a problem similar to Alex. My device is a samsung galaxy, too.
Alex wrote:But, i have small problem too,with my galaxy i cant confirm the dialogues in Lure of tempress, dunno why.
I can run broken sword 2 (some had problems with mpeg? I have ogg, by the way). But when I trying to LOAD or SAVE the game, or trying to change ingame options (not ScummVM option, broken sword 2 options), I NOT abled to click anymore. I can move the cursor, but tab in center or tab bottom left does not work in these menues.


@Alex: You could try http://anddev.at.ua/load/1-6-0-7 , there is also a touchpad feature. I've tried it and I can use touchpad feature even in menues, right click is available, too. I've chosen volume-down-key for right click.

@sblaise84: Good link you found there!
Posts: 12
Joined: Sat Mar 19, 2011 11:17 am

Problems with Full Throttle on Xperia X8 without multitouch

Post by apa-sf »

Great mod - pointing out things on the screen is far more convenient in this mod than in original android scummvm.

Unfortunately I have a problem in Full Throttle on my Xperia X8 (no multitouch). When I hold down the left-mouse to bring the use/talk/kick menu I do not know how to choose any of these 3 options :/ as I cannot move cursor with my second finger and there is no option to continue hold-down left-mouse further and move the cursor around to select, finger-up and click selected option.

In standard scumm when I longer-pressed left-click the use/talk/kick menu stayed visible after finger up and I could select an option.

Or am I wrong and current version is usable without multitouch in Full Throttle?
User avatar
ScummVM Porter
Posts: 166
Joined: Wed Jun 04, 2008 8:41 pm

Post by dhewg »

this is indeed a nice control mechanism. i recently overhauled the input system, see here. that allows drag&drop next to a touchpad style mode. wanna try?
Posts: 9
Joined: Fri Oct 09, 2009 8:05 am

Post by Malcolm »

Such a cool mod, you are great dude!
Posts: 8
Joined: Thu Feb 21, 2008 5:07 am


Post by seth.feinberg »

First off, thanks for the great build.

Just thought I'd submit my feedback for the sake of furthering the cause. I installed the latest version on my rooted Nook Color. Everything seems to load fine (took me a sec to realize the "n" button was escape) but I can't seem to get anything but a left click to work. Nothing when clicking the corners and nothing when I hold down my finger. I usually have to double click really just to get it to Left click once.

Just FYI, thanks for the build!
Post Reply