Zooming during dialogue, disable?

Subforum for discussion and help with ScummVM's Android port

Moderator: ScummVM Team

Posts: 1
Joined: Thu Nov 04, 2010 12:07 pm

Zooming during dialogue, disable?

Post by Gismya »


I'm playing with the latest scummvm-1.2.0-monolithic.apk and had no problems installing it on my Froyo HTC Tatto. The game looks and works wonderfully, until I engage in dialogues when the game zooms in on the person speaking, making long sentences strech outside the screen so one can't see what they say.

Is there any way to fix that?

Kind regards
Lars "Gismya" Johansson
Posts: 3
Joined: Thu Nov 04, 2010 12:27 pm

Post by Biont »

I have the same problem on my HTC Wildfire. Is this due to screen resolution?

Other than that, it runs perfect. No more sound crackling :D
Posts: 1
Joined: Fri Nov 05, 2010 7:00 pm

Post by AnyDroid »

Same here, on Samsung Apollo (GT-i5801).

Also on Beneath a Steel Sky, game crashes in Intro.
Posts: 4
Joined: Mon Nov 08, 2010 3:03 pm

Post by dustyhayes »

Hi, im new and for years a scumm vm fan.

now im using and Android Phone with Scumm VM. But i have the same Problem with the zooming in text passages. This is really anoying, because i can´t read the text.
Is this zooming extra, because of the small text messages? On my small x10 mini pro the zooming makes it impossible to play.

On my old SE m600i with the same display resolution, works scumm vm really good, also the text passages. Only the Sound is to much for this phone and his ram.

My Phone is a SE X10 Mini Pro with Android 2.1

I hope someone can fix this zooming.

Thanks and greetings :wink:
Posts: 3
Joined: Thu Nov 04, 2010 12:27 pm

Post by Biont »

This version works perfect on my Wildfire. The Interface is difficult to handle though because everything is so small
Posts: 5
Joined: Mon Jan 18, 2010 6:55 pm

Post by ichich56 »

Is there a fix? I have the same problem, the zooming is very deranging.
The file for Biont is not available. Did this fixed the problem?

With Greatings
Posts: 10
Joined: Fri Dec 09, 2005 7:12 am

Post by Wolverine_DH »

Yes please disable dialog zooming!


Posts: 1
Joined: Tue Jan 04, 2011 5:47 pm
Location: Sweden

Post by LieMfB »

Same problem here, on my Sony Ericsson X10 Mini Pro. Makes Scummvm useless for Lucasarts games, among others.

This should be a top priority bugfix, IMHO.

Edit: I reported this as a bug on the Sourceforge bugtracker for ScummVM (also refering to this thread).
Posts: 1
Joined: Fri Jan 07, 2011 11:34 pm

Post by tripp »

Same problem on the HTC Wildfire. If anyone knows where I can get the version mentioned by Biont, it would be much appreciated. That link is dead.

Otherwise runs fantastic, props to the devs! Just hope this issue can get sorted at some point.

I'm going to take a look at the other ports mentioned on these forums, see if they have by chance fixed the issue.
Posts: 3
Joined: Thu Jan 13, 2011 9:30 am

Post by Strahlenpest »

I have the exact same problem, and just registered to let you know that there are quite many people with the same problem.
I'm using a Wildfire with firmware 2.1update1.
A friend of mine has the same problem with the same config.

Additional information: The problem occurs with versions 1.2.0 and 1.2.1 - 1.0 won't work at all (application ends itself right after the ScummVM-screen with the loading bar).

It wouldn't even be that much of a problem, if this bug(?) wouldn't cut off the dialogue text so often.
When playing Monkey Island 1, the images of faces of the pirates in the Scumm Bar are often broken, for instance, only a corner of the screen shows the image, the rest remains black.

Excuse ze bad english, I'm from Deutschland ;)
Posts: 3
Joined: Thu Jan 13, 2011 9:30 am

Post by Strahlenpest »

I just noticed that it's the Scumm-Engine causing the crash.
Without it installed, ScummVM starts and tells me it needs at least one engine installed. Once I install the Scumm-engine-plugin, ScummVM crashes on startup.
Posts: 1
Joined: Sun Jan 16, 2011 2:23 pm

Post by beccilini »

I have this problem aswell on my htc wildfire!
It is REALLY irritating, the subtitles gets cut off and you can't read it.

Also, I have a huge problem with curse of monkey island, when I play it I can't see a thing, because it is zoomed in on the upper left corner all the time!

I hope this will get fixed soon!
I have tried the unofficial port, but have not managed to get it installed an working properly.
Posts: 1
Joined: Mon Jan 17, 2011 8:46 pm

Post by silver18 »

Same here. It's quite impossible to read everything with the zoom.
Is it possible to set anything to avoid this?
Posts: 3
Joined: Mon Jan 24, 2011 11:00 pm
Location: San Diego

Post by eric-the-ded »

I just signed up to say I have the same issue on my 2.1 Eclair phone.
I'm using ScummVM 1.2.1 and it does this with Sam & Max and Day of the Tentacle.

Edit: In case it's useful info, I'm running this on a Samsung Intercept.
Posts: 3
Joined: Thu Jan 13, 2011 9:30 am

Post by Strahlenpest »

Oh wow, still no reply from someone with an idea on how to fix it. Meanwhile, I tried every last configuration in the options menu, but the zooming in dialogues won't stop. It's definetely unplayable this way, as most spoken texts get cut off at some point. :x

Edit: okay its been so many weeks now, guess nobody is interested in Wildfire users -.-
Post Reply