unofficial android 2.x port (based on SDL backend)

Subforum for discussion and help with ScummVM's Android port

Moderator: ScummVM Team

Posts: 13
Joined: Sun Sep 17, 2006 11:52 am

Post by jannar85 »

So no update to the v -2.0 people?
User avatar
Posts: 61
Joined: Mon Feb 11, 2008 10:00 pm
Location: Russia

Post by KainXVIII »

I can`t install it on Acer Liquid :?

How to enter the numbers

Post by ScummBoy »

Nexus One here, running Froyo... same issue with the Lame-o screen. The solution is as follows.

For the version with the black-and-green UI:
1. Long-press the Menu key (or whatever key you use to bring up the keyboard).

2. With the keyboard showing, just use your finger to press Resume on the game menu. The menu will still work even with the keyboard on the screen.

3. Now that the menu is gone, type in your numbers on the keyboard. Then press Back or the keyboard button again to hide it. Worked for me.

For the version with the yellow-and-red UI:
Okay, in this version it is different because they moved the resume button to the bottom, where the keyboard is covering it. But have no fear! It can still be done.

1. Press the Menu button to bring up the in-game menu.

2. Using the trackball/trackpad, move the mouse over the Resume button and leave it there.

3. Long-press the menu button (or whatever button your phone has) to bring up the android on-screen keyboard (I'm using Swype but it shouldn't matter).

4. The keyboard is now covering the Resume button, but your mouse pointer is still over it! So, click the trackball/trackpad and the on-screen menu will disappear.

5. Type in the numbers, then long-press Menu or press Back or press whatever you would to make the keyboard disappear, as normal.

I hope this helps you. Please don't email/pm. This is a temporary account because I am not a fan of compulsory registrations, but am still trying to help.
Posts: 4
Joined: Wed Mar 01, 2006 10:30 pm

Post by optimus$prime »

hey guys! great work so far!

my question: i've testet zak and dott so far and it seems that the whole screen is zooming in and out every time a character is speaking (voice or text). everything else runs fine so i thought it may only be a wrong set up. any ideas?

scummvm android version from main hp; android 2.1update1; i5800
Posts: 4
Joined: Wed Dec 29, 2010 11:12 pm

Post by el_jefe »

Can someone post a link to the apk file?
The link in the first post gives a file not found error...
User avatar
Posts: 97
Joined: Sun Oct 30, 2005 4:10 pm
Location: Germany

Post by frank_m24 »

Just use the base URL and pick the newest ScummVM entry.
Posts: 4
Joined: Wed Dec 29, 2010 11:12 pm

Post by el_jefe »

frank_m24 wrote:Just use the base URL and pick the newest ScummVM entry.
Installed it. But after I set the configuration of the controls, the app crashes every time I try to open it... :(
The error message disappears very quickly, but I think it is something like "the application ... closed unexpected"
It's a pitty because I was really looking forward to play The Secret of Monkey Island 3 on my Desire.

EDIT: Solved!! Found an apk that works!
Post Reply