ScummVM not working with Android N?

Subforum for discussion and help with ScummVM's Android port

Moderator: ScummVM Team

Posts: 28
Joined: Tue Jan 13, 2015 6:13 pm

Post by monkeymadness »

This is my ini file.


ScummVM is the folder I store all my games in. When you asked for the ini file I started fiddling with it again and I actually messed things up. It took me a while to get it working. From having it not work to working again I discovered that "/sdcard" is the android way of saying "/Internal shared storage" for windows. This means that in order to access your games, the path will have to be "/sdcard/+the path to get to the folder you want" I also confirmed that the data installation was in fact "SD card storage" and that the specified directory was "/storage/emulated/0/Android/data/org.scummvm.scummvm/files" which is where the ini file was located. Which means to me that if you can get ScummVM to not die the moment it tries to access the directory /storage/emulated/0/Android/data/org.scummvm.scummvm/files during startup, then the path from the ini file should fix the issue. Other than that I got nothing else. Hope this helps.

Posts: 16
Joined: Sun Apr 05, 2009 10:05 pm

Post by warpdesign »

I am having the same problem: when taping the "add game" button, the browser is set to "/storage" and I can see two entries: "self" and "emulated". Tapping either shows an empty directory, so I cannot add any games.

Yes, I have enabled Storage permissions for ScummVM and tried to disable and enable it again with no luck.

I also tried to edit the scummvm.ini file setting last_path but it didn't work either: this options seems to be ignored. Note that this option seems to be ignored: no matter what I enter here, the browser seems to open "/storage". Also, when opening scummvm.ini for the first time, I noticed it was empty.

Is there a way to enable some logs that could help to track down the problem?

I'm running Android O dev preview on a Nexus 5X but was having the same problem with Android N before.

Posts: 116
Joined: Fri Dec 09, 2005 10:11 am

Post by goetz »

Google seems to have changed the API for file system access recently and hopefully, they have not done that again on Android O, looks the same on my 5X.

Try setting the following path in the scummvm.ini file:


Then run Scummvm again and try "add game".

That works on my Nexus 5X with Android 7.1.2

Post Reply