A few problems with some games

Subforum for discussion and help with ScummVM's Nintendo Wii port

Moderator: ScummVM Team

Post Reply
Sohn_of_a_Gunn
Posts: 4
Joined: Fri Jul 04, 2008 3:46 am

A few problems with some games

Post by Sohn_of_a_Gunn » Fri Jul 04, 2008 3:54 am

Hi, I ma a new guy and I have some issues with some games on the wii port.

DOTT: I am using the CD version but the game crashes after the newspaper with the cow story shows up, is there any fix and does this happen on the floppy version?

Broken Sword: NO cutscenes and after I go into the pub with the police, the game crashes to the homebrew channel menu.

Are there any fixes for this?

User avatar
md5
ScummVM Developer
Posts: 2261
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 » Fri Jul 04, 2008 4:35 am

Do you get these issues with the PC version of ScummVM?

Sohn_of_a_Gunn
Posts: 4
Joined: Fri Jul 04, 2008 3:46 am

Post by Sohn_of_a_Gunn » Fri Jul 04, 2008 5:15 am

Not sure, when I used the PC version I usually used the floppy version of DOTT and I got pretty far, never tried Broken Sword, but I might try them on the PC.

matteo57
Posts: 2
Joined: Mon Jun 30, 2008 1:19 pm

Post by matteo57 » Fri Jul 04, 2008 7:31 am

hi,

i got the same issue with broken sword 1.
i can see the cutscenes, with the appropriate add-on pack, but my game too crashes when i exit the pub, with or without police, and it goes back to the homebrew channel.

tried it (same datafiles of course) on scummvm on pc, it works perfectly.

i've already opened a topic about that in the broken sword 1 topic on this forum, but it was of no use.

I think it must be a kind of bug, because i tried several different versions of the game, but always have this problem, but i don't know what causes it.

User avatar
chojin
Posts: 48
Joined: Tue May 27, 2008 7:51 pm
Location: Berlin, Germany

Post by chojin » Sat Jul 05, 2008 10:54 am

Which scummvm revision do you use? Which game language?

Do you have a savepoint right before the issue occurs?

LouKohley
Posts: 2
Joined: Mon Jul 07, 2008 1:54 am

DOTT Problem

Post by LouKohley » Mon Jul 07, 2008 1:57 am

I have the same issue. The game brings up the debugger terminal. I get an error code.

Error: Locking Illegal Glob type 0 (0) num 0

Thanks for ScummVM on my Wii. I miss all these old games.

LOU

P.S. I have a same game just before the crash happens all you have to do is exit the room.

Sohn_of_a_Gunn
Posts: 4
Joined: Fri Jul 04, 2008 3:46 am

Re: DOTT Problem

Post by Sohn_of_a_Gunn » Mon Jul 07, 2008 3:05 am

LouKohley wrote:I have the same issue. The game brings up the debugger terminal. I get an error code.

Error: Locking Illegal Glob type 0 (0) num 0

Thanks for ScummVM on my Wii. I miss all these old games.

LOU

P.S. I have a same game just before the crash happens all you have to do is exit the room.
Wait for DOTT, is this debugger terminal glitch occurring only on the CD version or does it happen on the floppy version too?

LouKohley
Posts: 2
Joined: Mon Jul 07, 2008 1:54 am

DOTT problem

Post by LouKohley » Mon Jul 07, 2008 8:47 pm

I only have the CD version.

I notice it happens any time there is a random cut-scene (spinning newspaper or random dialogue) sometimes it goes back to the game but from the last autosave point and not where I left off.

Thanks,
LOU

Sohn_of_a_Gunn
Posts: 4
Joined: Fri Jul 04, 2008 3:46 am

Re: DOTT problem

Post by Sohn_of_a_Gunn » Mon Jul 07, 2008 8:50 pm

LouKohley wrote:I only have the CD version.

I notice it happens any time there is a random cut-scene (spinning newspaper or random dialogue) sometimes it goes back to the game but from the last autosave point and not where I left off.

Thanks,
LOU
I was wondering since I have both versions, I should see if the floppy version still does the glitch.

Post Reply