Broken Sword II Problem

Subforum for discussion and help with ScummVM's Nintendo Wii port

Moderator: ScummVM Team

Post Reply
Topheee
Posts: 2
Joined: Sun Jun 15, 2008 5:17 pm

Broken Sword II Problem

Post by Topheee » Sun Jun 15, 2008 5:20 pm

I have a problem with playing Broken Sword II. Basically, it says that it can't find the game file, even though the same files work on the PC, and let me play.
I can play all the demos, and I've managed to get Sam and Max working.
Why won't this work? >:

clem
Posts: 2185
Joined: Mon Oct 31, 2005 11:14 am

Post by clem » Sun Jun 15, 2008 9:41 pm

Games working on one platform and not on another might have to do with the port lacking support for a specific engine (although I'd assume the Wii port to include all the engines). Does the Wii ScummVM list Broken Sword 2 if you click on "About" in the launcher?

Disclaimer: don't have a Wii, can't test

User avatar
chojin
Posts: 48
Joined: Tue May 27, 2008 7:51 pm
Location: Berlin, Germany

Post by chojin » Mon Jun 16, 2008 6:43 am

I experienced the same issue trying to add Broken Sword 2 (German, DXA+OGG) in R32565. It obviousely could not find the game files, because I used subfolders for CLUSTERS, VIDEOS and SWORD2. After moving CLUSTERS and INF files back into the main game directory, the game was recognized. The Videos work using a subfolder. So I guess the Wii port does not scan subfolders yet.

User avatar
Mr_Nick666
Posts: 146
Joined: Wed Apr 11, 2007 9:59 am
Location: Bideford, Devon, UK
Contact:

Post by Mr_Nick666 » Mon Jun 16, 2008 8:17 am

Broken Sword 2 seems to be working fine on my PAL Wii (saving and loading too)

Topheee
Posts: 2
Joined: Sun Jun 15, 2008 5:17 pm

Post by Topheee » Mon Jun 16, 2008 3:53 pm

I'll try putting them in one folder then, as they're all in the sub folders at the moment.
Thanks for your help!

User avatar
Vurtual
Posts: 11
Joined: Sat Sep 09, 2006 12:30 pm
Location: Germany

Post by Vurtual » Tue Jun 17, 2008 8:42 pm

The game works fine for me too when all files are in the same folder. Saving and loading included.. but does anyone else notice scrambled parts of the screen i.e. the parts holding the inventory at the bottom and the options on the upper part of the screen?

User avatar
chojin
Posts: 48
Joined: Tue May 27, 2008 7:51 pm
Location: Berlin, Germany

Post by chojin » Tue Jun 17, 2008 10:18 pm

Vurtual wrote:but does anyone else notice scrambled parts of the screen i.e. the parts holding the inventory at the bottom and the options on the upper part of the screen?
Yes, funny color bars in both broken sword 1 and 2.

User avatar
Mr_Nick666
Posts: 146
Joined: Wed Apr 11, 2007 9:59 am
Location: Bideford, Devon, UK
Contact:

Post by Mr_Nick666 » Wed Jun 18, 2008 1:09 pm

I get odd coloured bits in the bars too :shock:

Post Reply