Monkey Island 3

Subforum for discussion and help with ScummVM's Nintendo Wii port

Moderator: ScummVM Team

Badassbill
Posts: 2
Joined: Sat Jun 07, 2008 10:20 pm

Monkey Island 3

Post by Badassbill »

I played Monkey Island 3 on my Wii port of scummvm, and as soon as I destroy the boats with the cannon and attempt to return to the room the game ends and I get a few lines of code on screen. Any ideas on what I'm doing wrong, or what happened?

User avatar
MajinChibi
Posts: 91
Joined: Mon Sep 03, 2007 10:07 pm
Location: Berlin, Germany

Post by MajinChibi »

Are you sure your using the newest scummVM version? In a previous version i got this "error" too, but not in the newest version.

Newest version: http://www.wiibrew.org/wiki/Homebrew_apps/ScummVM

sry for my bad english

User avatar
dhewg
ScummVM Porter
Posts: 169
Joined: Wed Jun 04, 2008 8:41 pm

Post by dhewg »

i cannot confirm this crash.

i posted some hints here: viewtopic.php?t=5756

please try those

edit: what do you mean by "a few lines of code"? if thats an exception screen, you'll see some values in the middle of the screen. something like "0x80?????? -> 0x80?????? -> ...". if that happens, please post those values here, thanks

Badassbill
Posts: 2
Joined: Sat Jun 07, 2008 10:20 pm

Post by Badassbill »

I tried the newer version, and now get an error even earlier in the game.

code dump
error loading mutex 0x80bf67d0 (3)

User avatar
Ace2020Boyd
Posts: 49
Joined: Fri Jun 15, 2007 3:22 am

Post by Ace2020Boyd »

i just tried the game it works great but there are some hicups in the videos and audio problems in the cutscene but it was awsome on the wii. I hope they can get ScummVM update and fix bugs and become a Official port

User avatar
MajinChibi
Posts: 91
Joined: Mon Sep 03, 2007 10:07 pm
Location: Berlin, Germany

Post by MajinChibi »

the wii port IS an official port

User avatar
Ace2020Boyd
Posts: 49
Joined: Fri Jun 15, 2007 3:22 am

Post by Ace2020Boyd »

MajinChibi wrote:the wii port IS an official port
i did not know that cool. i hope they fix the the bugs in CMI

GuybrushsMonkey
Posts: 3
Joined: Fri May 02, 2008 12:18 am

Post by GuybrushsMonkey »

This long loadingtimes are killing, and it hang up when i go to blondbeard`s

User avatar
dhewg
ScummVM Porter
Posts: 169
Joined: Wed Jun 04, 2008 8:41 pm

Post by dhewg »

the poor SD read performance is actually the biggest problem for this port atm. unfortunately, there isnt much i can do about it. every wii homebrew suffers from this, but you'll only notice it on applications that require a certain throughput.

niuus
Posts: 4
Joined: Sun Mar 02, 2008 5:55 pm

Post by niuus »

dhewg wrote:the poor SD read performance is actually the biggest problem for this port atm. unfortunately, there isnt much i can do about it. every wii homebrew suffers from this, but you'll only notice it on applications that require a certain throughput.
Hope it reaches the performance exhibited in the unofficial GC port (the one that used linux), which was perfect (maybe something can be studied in the SD front from that port). The only problem with it in CMI was that if you compressed the audio, there was a delay in the audio-video sync. Original audio played completely normal.

superfighter
Posts: 115
Joined: Fri Jul 04, 2008 5:34 pm
Location: England

Post by superfighter »

i found that compressing the music files in CMI meant it ran even better....

Paperman
Posts: 30
Joined: Sun Sep 21, 2008 9:27 am

Post by Paperman »

CMI runs better with compressed Music Files.
(CMI abaout 450MB size).

But I have a very strange problem.
If I want to take the map (from the backside of the very very very very extremly very pale man on the beach) ScummVM will jump back to the loader without any message.

I also tried to skip the scene (with success).
But than, if i go to the Island map the same problem will happen.

I dunno what to do. -.-

Edit:
Okay. Now I know the problem.
It's the second LeChuck Movie (and the burning skin movie).
I tried to complete the crew before getting the map. And the same thing will happen (return to loader). So the problem must be the second LeChuck movie (I saw the first, after getting the ship). I hope this can be fixed with the next update.^^
Last edited by Paperman on Sun Sep 21, 2008 1:09 pm, edited 3 times in total.

superfighter
Posts: 115
Joined: Fri Jul 04, 2008 5:34 pm
Location: England

Post by superfighter »

hmmmmmmm strange

the only glitch ive ever had, and it only happened once, The pirrate that you hit with the glove, so you can start the banjo duelling, tried talking to him once and i got lines of code, its never happened again though.
:? i havnt had the Map problem though works everytime

Paperman
Posts: 30
Joined: Sun Sep 21, 2008 9:27 am

Post by Paperman »

superfighter wrote:hmmmmmmm strange

the only glitch ive ever had, and it only happened once, The pirrate that you hit with the glove, so you can start the banjo duelling, tried talking to him once and i got lines of code, its never happened again though.
:? i havnt had the Map problem though works everytime
Yes, it's really strange. -.-
But your glitch is also funny (although it happend just one time). ^^

So, I tried the Savestate and the Version of CMI on the PC (the savestates of all ScummVM versions are compatible togehter, which is a great thing =))
No glitches or problems on the PC.
I watched the second LeChuck Movie and saved.
Now I am going on on the Wii.

But, as I said, the failure must be the second LeChuck Event (and the burning skin scene).
I tried it very often (also in different ways).
And if I got the map or if I collected the crew the game will hang up and return to the loader.

superfighter
Posts: 115
Joined: Fri Jul 04, 2008 5:34 pm
Location: England

Post by superfighter »

how are your files organised? are they all in one folder?

Post Reply