Broken Sword 2.5 will not start

Subforum for discussion and help with ScummVM's Nintendo Wii port

Moderator: ScummVM Team

Post Reply
GeorgeStobbert
Posts: 1
Joined: Sat Dec 12, 2020 8:40 pm

Broken Sword 2.5 will not start

Post by GeorgeStobbert »

Hello,

today we wanted to play Broken Sword 2.5 on a Wii using ScummVM 2.2.0.
Unfortunately, we could not get it to work properly (in contrast with Broken Sword 1 and 2 which were running like a charm!).

The following error is output:
startup as 'sd:/apps/ScummVM/boot.elf'
initSize 320*200*8 (000 -> 000 match: 1)
window caption: ScummVM 2.2.0 (Sep 22 2020 10:11:34)
Virtual keyboard pack 'vkeybd_default' loaded successfully
WARNING: No hardware input were defined, using defaults!
User picked target 'sword25' (engine ID 'sword25', game ID 'sword25')...
Looking for a plugin supporting this target... Broken Sword 2.5
window caption: Broken Sword 2.5 (Latest version)
assertion "(new Width <= 640) && (newHeight <= 480)" failed: file "backends/platform/wii/osystem_gfx.cpp", line 256, function: virtual void OSystem_Wii::initSize(u int, uint, const Graphics::PixelFormat*)
Abort called.
ScummVM exited abnormally (-127).
Press any key to continue.
I tried reinstalling ScummVM as well as the game which I downloaded from https://downloads.scummvm.org/frs/scumm ... .0-wii.zip.
The old Broken Sword work fine. Only 2.5 does not :-(

Could anybody give us kindly a useful hint?

Thanks in Advance!

(Wrongly spelled) George!
User avatar
sev
ScummVM Lead
Posts: 2100
Joined: Wed Sep 21, 2005 1:06 pm
Contact:

Re: Broken Sword 2.5 will not start

Post by sev »

Broken Sword 2.5 has 800x600 resolution. The assertion you got shows that Wii port is working only for 640x480 or less. Thus, I think, the game will not work until the port is updated.


Eugene
Post Reply