iPhone 2G 3.1.3 problem with ScummVM 1.2.0

Subforum for discussion and help with ScummVM's iPhone port

Moderator: ScummVM Team

Miyamoto
Posts: 3
Joined: Sun Nov 14, 2010 10:15 pm

Post by Miyamoto »

Same problem here. This is what syslog has to say about it:

Code: Select all

Nov 14 23:20:43 Iphone-3G com.apple.launchd[1] (UIKitApplication:org.scummvm.scummvm[0x3341][280]):(UIKitApplication:org.scummvm.scummvm[0x3341]) Exited: Killed
Nov 14 23:20:43 Iphone-3G com.apple.launchd[1] (UIKitApplication:org.scummvm.scummvm[0x3341]):(UIKitApplication:org.scummvm.scummvm[0x3341]) Throttling respawn: Will start in 2147483647 seconds
Nov 14 23:20:43 Iphone-3G SpringBoard[140]: Application 'ScummVM' exited abnormally with signal 9: Killed
Using an Iphone 3G with iOS 4.1 (8B117) and ScummVM 1.2.0. ScummVM 1.1.1 works fine.

Pls tell me if I can be of some help to trace this down.

Miyamoto
Posts: 3
Joined: Sun Nov 14, 2010 10:15 pm

Post by Miyamoto »

OK, some more info:
Installing 1.2.0 and copying Info.plist from 1.1.1 just kills one line in the syslog output:

Code: Select all

Nov 15 11:35:49 Iphone-3G com.apple.launchd[1] (UIKitApplication:org.scummvm.scummvm[0xefa0][589]): (UIKitApplication:org.scummvm.scummvm[0xefa0]) Exited: Killed
Nov 15 11:35:49 Iphone-3G com.apple.launchd[1] (UIKitApplication:org.scummvm.scummvm[0xefa0]): (UIKitApplication:org.scummvm.scummvm[0xefa0]) Throttling respawn: Will start in 2147483647 seconds
Reinstalling 1.1.1 effectively restores functionality.
Syslog tells me this:

Code: Select all

Nov 15 11:38:22 Iphone-3G ScummVM[600]: MS:Notice: Installing: org.scummvm.scummvm [ScummVM] (550.38)
Nov 15 11:38:22 Iphone-3G ScummVM[600]: MS:Notice: Loading: /Library/MobileSubstrate/DynamicLibraries/Activator.dylib
Nov 15 11:38:23 Iphone-3G ScummVM[600]: MS:Notice: Loading: /Library/MobileSubstrate/DynamicLibraries/FiveIRows.dylib
Nov 15 11:38:23 Iphone-3G ScummVM[600]: MS:Notice: Loading: /Library/MobileSubstrate/DynamicLibraries/WinterBoard.dylib
Nov 15 11:38:23 Iphone-3G ScummVM[600]: WB:Notice: WinterBoard
Nov 15 11&#58;38&#58;26 Iphone-3G ScummVM&#91;600&#93;&#58; <CAEAGLLayer&#58; 0xe73400>&#58; calling -display has no effect.
Nov 15 11&#58;39&#58;10 Iphone-3G sandboxd&#91;603&#93;&#58; CommCenter&#40;34&#41; deny file-write-data /dev/console
Hope this helps...

synoptic
Posts: 2
Joined: Fri Nov 12, 2010 8:06 pm

Post by synoptic »

Aftera fresh restore. Scummvm now works. I have a feeling it cause by some software screwing things around.

g-man36
Posts: 3
Joined: Tue Nov 23, 2010 4:40 pm

IOS 4.2.1

Post by g-man36 »

It crashes on start.

INFO:
model: itouch 3rd generation 32gb
IOS: 4.2.1


as a side note, I did have it running on 4.0 without problem. (I didn't test on 4.1)

True1666
Posts: 2
Joined: Fri Dec 03, 2010 5:33 pm

Post by True1666 »

Hi, I wonder if u can help. I am trying to get scummvm to run on my iPad 4.2.1. I have managed to install Cydia and scummvm but when I press the app to start up scummvm it looks as though it try's to start it. The screen flicks for half a second and then nothing. Tried reinstalling it but still no joy. Any surjestions? Thanks in advance.

Also is there anyway I can install version 1.1 of scummvm instead of 1.2 going through Cydia?

User avatar
Vinterstum
ScummVM Developer
Posts: 585
Joined: Sun Oct 16, 2005 6:59 am

Post by Vinterstum »

Let me know if 1.2.1 works better :).

Miyamoto
Posts: 3
Joined: Sun Nov 14, 2010 10:15 pm

Post by Miyamoto »

Didn't have time to _play_ - but at least it starts through to the game-selection screen.
Thx!!! :D 8) :mrgreen:

kolokbmk
Posts: 5
Joined: Wed Nov 03, 2010 3:45 pm

Post by kolokbmk »

Hi !

Yeapppp ! 1.2.1 has solved the problem for me !!!
Great !

Thanks a lot !

(3GS + 3.1.2)

SuperBaobab
Posts: 4
Joined: Sat Oct 23, 2010 8:54 pm

Post by SuperBaobab »

Yes !
My iPod Touch 2G now works fine with ScummVM 1.2.1 !
Thanks a lot ! :D

Illuminerdi
Posts: 20
Joined: Thu Sep 27, 2007 10:32 pm

Post by Illuminerdi »

I've been rocking 1.2.1 on my iPad for a few days, and it's been pretty good so far.

My biggest complaint is inconsistent behavior of the interface. The "menu" command (one finger plus second finger swipe down) doesn't always bring up a menu, sometimes just bringing up the save interface - (mostly non-Scumm games, such as Kyra, BASS, Discworld).

Also, the inability to just click the "save" button in these games in the same menu is mildly annoying. I play in landscape mode, so having to switch to portrait, click return on the keyboard, just to save a game where I'm not retyping the name seems a bit pointless.

The BASS menu system is also pretty broken - you have to turn on click-n-drag mode to click the menu buttons. Would love to see this fixed.

So far no crashes or showstoppers, and thanks for all the hard work - I'm *loving* playing ScummVM on my iPad, this is the true ScummVM portable experience I've been waiting years for!

Illuminerdi
Posts: 20
Joined: Thu Sep 27, 2007 10:32 pm

Post by Illuminerdi »

Any chance we'll see GOB engine fixes soon? Pretty much all of them are broken ATM on IOS and I'd love to replay them! I've been waiting years to replay Lost In Time, as it never worked right even on my old DOS PC when it was a *new* game.

Post Reply