ScummVM 0.13 prerelease binary

Subforum for discussion and help with ScummVM's iPhone port

Moderator: ScummVM Team

User avatar
Vinterstum
ScummVM Developer
Posts: 580
Joined: Sun Oct 16, 2005 6:59 am

ScummVM 0.13 prerelease binary

Post by Vinterstum »

EDIT: No longer relevant, since 0.13 has been released on Cydia.

Installation:
* SFTP this file to your iPhone/iPod (see the stickied installation thread for details)
* SSH to your phone
* 'dpkg -i scummvm-iphone-0.13.0-rc1.deb'

Enjoy :).


iPhone specific changelog:
* Touchpad mode is now the default mode.
* Whenever you switch on click-and-drag mode, touchpad mode will switch off (though you can reenable it afterwards if you want). This is due to COMI/FT being very tricky to control if both modes on at the same time.
Last edited by Vinterstum on Sun Mar 01, 2009 9:29 am, edited 2 times in total.
bsauvage
Posts: 76
Joined: Sat Jan 03, 2009 9:44 am

Post by bsauvage »

Nice !!!

Quick question that I can't seem to find the answer to: can I simply upload the .deb it in var/mobile or do i need to go into the apps directory?

Thank you!
User avatar
Vinterstum
ScummVM Developer
Posts: 580
Joined: Sun Oct 16, 2005 6:59 am

Post by Vinterstum »

bsauvage wrote:Nice !!!

Quick question that I can't seem to find the answer to: can I simply upload the .deb it in var/mobile or do i need to go into the apps directory?

Thank you!
You can upload it anywhere, it's just needed for dpkg to actually install the app. You can safely delete it afterwards.
bsauvage
Posts: 76
Joined: Sat Jan 03, 2009 9:44 am

Post by bsauvage »

Thank you very much!
bsauvage
Posts: 76
Joined: Sat Jan 03, 2009 9:44 am

Post by bsauvage »

I tried!
I notice a very strange effect: the cursor doesn't position itself below the finger (it is off centered by quite a bit everytime i touch the screen)
But when I move the finger the cursor moves actually faster than my finger.

One good thing though: I tried on Lost in Time which is now working (before, in v. 0.12 it was crashing at the title screen)
User avatar
Vinterstum
ScummVM Developer
Posts: 580
Joined: Sun Oct 16, 2005 6:59 am

Post by Vinterstum »

bsauvage wrote:I tried!
I notice a very strange effect: the cursor doesn't position itself below the finger (it is off centered by quite a bit everytime i touch the screen)
But when I move the finger the cursor moves actually faster than my finger.

One good thing though: I tried on Lost in Time which is now working (before, in v. 0.12 it was crashing at the title screen)
That's the touchpad mode, which is now default (it's what most people were using, anyway). Think of the touchscreen as a laptop touchpad :). It makes for a lot more accurate cursor positioning (and you can actually see what the cursor is hovering over).

You can toggle it off (back to direct pointing) by holding down one finger and swiping another from left to right.


Thanks for testing :). Good news about Lost in Time! I don't have it myself, so I've been unable to test it.
bsauvage
Posts: 76
Joined: Sat Jan 03, 2009 9:44 am

Post by bsauvage »

:)
Very nice!
bobablob
Posts: 101
Joined: Thu May 25, 2006 9:05 pm

Post by bobablob »

It appears that backspace is broken on this version of ScummVM. I posted a bug about it in the tracker. Anyone else experiencing this behavior?
User avatar
Vinterstum
ScummVM Developer
Posts: 580
Joined: Sun Oct 16, 2005 6:59 am

Post by Vinterstum »

bobablob wrote:It appears that backspace is broken on this version of ScummVM. I posted a bug about it in the tracker. Anyone else experiencing this behavior?
Yep, and fixed it now :). Thanks!

EDIT: Too late for 0.13 release though, most likely. Might have to wait until 0.13.1.
bsauvage
Posts: 76
Joined: Sat Jan 03, 2009 9:44 am

Post by bsauvage »

Hello! Could you please make the old pre available again. Or a new one ideally.
Lost in time worked in the Pre but not in the final release.
Thanks!!
User avatar
Vinterstum
ScummVM Developer
Posts: 580
Joined: Sun Oct 16, 2005 6:59 am

Post by Vinterstum »

bsauvage wrote:Hello! Could you please make the old pre available again. Or a new one ideally.
Lost in time worked in the Pre but not in the final release.
Thanks!!
Not sure what the buildbot status is.

I uploaded a new one, however (0.13.1 prerelease).

http://worldsmainorganization.org/scumm ... 1-pre1.deb
bsauvage
Posts: 76
Joined: Sat Jan 03, 2009 9:44 am

Post by bsauvage »

Thanks. Just installed it and it is not working anymore. Somewhere between the last 0.13 rc and this one Lost in Time is broken and doesn't pass the intro screen.
User avatar
Vinterstum
ScummVM Developer
Posts: 580
Joined: Sun Oct 16, 2005 6:59 am

Post by Vinterstum »

bsauvage wrote:Thanks. Just installed it and it is not working anymore. Somewhere between the last 0.13 rc and this one Lost in Time is broken and doesn't pass the intro screen.
Found and fixed, will be working in 0.13.1.
bsauvage
Posts: 76
Joined: Sat Jan 03, 2009 9:44 am

Post by bsauvage »

can i just try the 0.13.1 pre link you have above to see the fix, or do i need another link ?
User avatar
Vinterstum
ScummVM Developer
Posts: 580
Joined: Sun Oct 16, 2005 6:59 am

Post by Vinterstum »

bsauvage wrote:can i just try the 0.13.1 pre link you have above to see the fix, or do i need another link ?
0.13.1 will be released within days, just wait for that :).
Post Reply