Any news for a 1.6.0 version on iOS?

Subforum for discussion and help with ScummVM's iPhone port

Moderator: ScummVM Team

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto »

digitall wrote:Lordhoto: I tried compiling this with the older toolchain and this failed with the following error:
scummvm/backends/platform/iphone/iphone_video.mm:167: error: cannot convert ‘objc_object*’ to ‘float’ in assignment

Can you see if you can fix this so we can keep the builds working with the older toolchain for now please?
Despite the fact my nick is LordHoto and not Lordhoto ;-): It seems this suggests to use "objc_msgSend_fpret". However, that doesn't seem to be declared for iOS... There is "objc_msgSend_stret" in there, which we can be used for anything apart i386/amd64 and thus should be fine for us, but it uses a different declaration than here. The one available actually returns an "id", i.e. "objc_object*" again. So, I'll need to look a bit more at this to find anyway to fix it...

But since it seems it doesn't work anyway, let's just try to fix it first ;-).

digitall
ScummVM Developer
Posts: 1015
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

Apologies _LordHoto_ :)

joanthedark: LordHoto has updated his branch with an amended source code. Will remove the broken build and rebuild from this newer code in a few mins. Please test the newer build when I link it! :)

joanthedark
Posts: 29
Joined: Thu Apr 25, 2013 7:22 pm

Post by joanthedark »

Will do!

digitall
ScummVM Developer
Posts: 1015
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

New builds for testing here:
http://buildbot.scummvm.org/snapshots/o ... fa.tar.bz2
http://buildbot.scummvm.org/snapshots/o ... fa.tar.bz2

The second one is with the older toolchain as LordHoto's changes fixed the build with that as well.

Source code for this can be found here:
https://github.com/lordhoto/scummvm/com ... tina-input

joanthedark
Posts: 29
Joined: Thu Apr 25, 2013 7:22 pm

Post by joanthedark »

They both work! Click-and-drag mode seems very accurate. Although they are a bit slow (for example, opening options takes a few seconds before the window appears) for some reason, I don't know if its some memory problem or what (it didn't do this in the older versions)

But still, I'm glad to know the problem has been spotted (and fixed)!

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto »

joanthedark wrote:They both work! Click-and-drag mode seems very accurate. Although they are a bit slow (for example, opening options takes a few seconds before the window appears) for some reason, I don't know if its some memory problem or what (it didn't do this in the older versions)
It probably only takes that long because rendering in our GUI isn't really that fast for such high resolutions like you are using.

Thanks for testing!

digitall
ScummVM Developer
Posts: 1015
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

LordHoto: Is this solution good enough to merge? Or at least open as a Pull Request?

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto »

digitall wrote:LordHoto: Is this solution good enough to merge? Or at least open as a Pull Request?
It's already in-tree now.. ;-)

digitall
ScummVM Developer
Posts: 1015
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

Excellent! :)

Veda: Please can you test with those last two "special" builds and see if they fix your mouse input problem and if the font problem has also been fixed please?

Veda
Posts: 15
Joined: Fri Feb 24, 2006 7:46 pm

Post by Veda »

Done: input is ok on both builds :D

I too noticed the delay in opening the menu.

However, now for both builds the aspect is like in the second picture of my latest post, i.e. with the "small fonts" :?:

digitall
ScummVM Developer
Posts: 1015
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

Veda: Thanks for checking.

LordHoto: Any ideas on possible cause of the font size issue Veda is seeing? It wasn't occuring with the older toolchain, but now is with your fix... Does that tell you anything? Any ideas on how we get more information to debug this, or if Veda needs to open a bug and/or provide further information / screenshots?

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto »

digitall wrote:Veda: Thanks for checking.

LordHoto: Any ideas on possible cause of the font size issue Veda is seeing? It wasn't occuring with the older toolchain, but now is with your fix... Does that tell you anything? Any ideas on how we get more information to debug this, or if Veda needs to open a bug and/or provide further information / screenshots?
Well, I think it's simply that the port started to use native resolution in the GUI for Retina displays since Retina support. This means, since they have such a high resolution, that everything is pretty small on them. Maybe I'll just limit the overlay/GUI resolution for now...

Urtoroth
Posts: 3
Joined: Thu Jul 03, 2014 1:14 pm

Post by Urtoroth »

Bump!

Hello! I'm checking this forum regularly, searching for a version of ScummVM that works with an iPhone/iPad on a jailbroken 7.1.2 iOS.

Any comments on this issue?

Actually, the app is correctly installed but won't launch at all (tested on iPhone 5s and iPad Air with the same results).

Or maybe I'm losing something on the way...

Thank you so much.
U.

digitall
ScummVM Developer
Posts: 1015
Joined: Thu Aug 02, 2012 1:40 pm

Post by digitall »

Urtoroth: You have not even indicated what version and build type of ScummVM you have installed...

Remove your current ScummVM install and use the v1.8.0git nightly build with the latest toolchain from buildbot:
http://buildbot.scummvm.org/snapshots/m ... st.tar.bz2

If this fails to work, you can try the older toolchain builds:
http://buildbot.scummvm.org/snapshots/m ... st.tar.bz2

However, you will need copy the scummvm-iph5 binary to scummvm on your device if using IPad / IPhone 5+ as the standard binary only works on IPhone4 and earlier.

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto »

digitall wrote:However, you will need copy the scummvm-iph5 binary to scummvm on your device if using IPad / IPhone 5+ as the standard binary only works on IPhone4 and earlier.
Just to avoid confusion: You only need to do that for the older toolchain builds (i.e. second link).

Post Reply