Scumm 1.5.0 on iPad 4 iOS 6

Subforum for discussion and help with ScummVM's iPhone port

Moderator: ScummVM Team

Post Reply
Ravippe
Posts: 24
Joined: Tue Feb 05, 2013 9:06 am

Scumm 1.5.0 on iPad 4 iOS 6

Post by Ravippe » Tue Feb 05, 2013 9:11 am

This version doesnt work on my new iPad after jb. It crashes after a second. Anyone else have that problem with new evasion jb?

Garbera
Posts: 1
Joined: Mon Feb 04, 2013 11:01 pm

Post by Garbera » Tue Feb 05, 2013 11:16 am

I'm having the exact same problem on iPad 4.

octopus
Posts: 10
Joined: Mon Feb 04, 2013 6:14 pm

Post by octopus » Tue Feb 05, 2013 2:14 pm

Sure. Posted it after 15 minutes after the release of JB and my post was considered spam. Admin said I was not reading the rules. Total ignorance.

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto » Tue Feb 05, 2013 2:31 pm

octopus wrote:Sure. Posted it after 15 minutes after the release of JB and my post was considered spam. Admin said I was not reading the rules. Total ignorance.
Did you try to post a link in that post? You're a new user, which means you are not allowed to post links in your first few posts. This is spam protection. Also there's our forum rules which say:
[b]Forum Rules. READ BEFORE POST.[/b] wrote: 3b) No discussions of softmods, hardmods or jailbreaks. It is assumed that you know how to run homebrew software on some consoles. Discussions on how to break the protection are not tolerated.
.
Ravippe wrote: This version doesnt work on my new iPad
Did you try to reboot your iPad after you installed ScummVM?

octopus
Posts: 10
Joined: Mon Feb 04, 2013 6:14 pm

Post by octopus » Tue Feb 05, 2013 2:37 pm

ScummVM is not working on jailbroken iOS 6.1 iPad 4.

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto » Tue Feb 05, 2013 2:48 pm

octopus wrote:ScummVM is not working on jailbroken iOS 6.1 iPad 4.
If you want to be of help you could post the contents of "/var/mobile/.scummvm.log" from your iPad.

calium
Posts: 3
Joined: Tue Feb 05, 2013 2:58 pm

Post by calium » Tue Feb 05, 2013 3:00 pm

scummvm 1.5.0 crashes on iphone 5 ios6.1 directly after start and goes back to springboard

octopus
Posts: 10
Joined: Mon Feb 04, 2013 6:14 pm

Post by octopus » Tue Feb 05, 2013 3:04 pm

LordHoto wrote:If you want to be of help you could post the contents of "/var/mobile/.scummvm.log" from your iPad.
Well, I’ve tried both builds (the one in the repo and the development one (gave 755 rights)) none of them does launch at all. So, there are no logs created either.

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto » Tue Feb 05, 2013 3:56 pm

octopus wrote:
LordHoto wrote:If you want to be of help you could post the contents of "/var/mobile/.scummvm.log" from your iPad.
Well, I’ve tried both builds (the one in the repo and the development one (gave 755 rights)) none of them does launch at all. So, there are no logs created either.
Did you check whether no logs were created or do you assume there are no logs created?

octopus
Posts: 10
Joined: Mon Feb 04, 2013 6:14 pm

Post by octopus » Tue Feb 05, 2013 4:02 pm

I checked.

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto » Tue Feb 05, 2013 4:07 pm

octopus wrote:I checked.
In this case I have no idea what could be wrong and I don't have any iOS 6 compatible device to check for myself.

Ravippe
Posts: 24
Joined: Tue Feb 05, 2013 9:06 am

I also checked for log

Post by Ravippe » Tue Feb 05, 2013 4:16 pm

I also checked in the var/mobile for scumm log, I also looked in the main scumm directory for any logs nothing at all. It's odd the yellow screen loads up then quits. Any other way we can get the data you need?

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Re: I also checked for log

Post by LordHoto » Tue Feb 05, 2013 4:20 pm

Ravippe wrote:I also checked in the var/mobile for scumm log, I also looked in the main scumm directory for any logs nothing at all. It's odd the yellow screen loads up then quits. Any other way we can get the data you need?
When there's no log file, it's hard to say anything. For what's worth it's a hidden file (as you can see by the "." at the start of the filename).

There's also crash logs, but those are really unhelpful for the release and nightly builds, since they are not made with an official toolchain and so far I don't know how you can symbolicate them. I also can't remember out of my head where those were saved.

Saikobooru
Posts: 2
Joined: Tue Feb 05, 2013 4:52 pm

Post by Saikobooru » Tue Feb 05, 2013 5:00 pm

Hey, I have the same problem, but I managed to locate the crash info by Xcode. Here's what the plist contains:

pastebin(dot)com(slash)zbvMfd8k

(sorry for the crude link, but the 3 post limit demands it, and posting the raw data marks the message as spam)

greenroot
Posts: 1
Joined: Tue Feb 05, 2013 6:17 pm

Post by greenroot » Tue Feb 05, 2013 6:19 pm

Also having this problem on iPad 4. It starts up and crashes in about 2 seconds.

Post Reply