Whats wrong with the new ScummVM Version?

Subforum for discussion and help with ScummVM's iPhone port

Moderator: ScummVM Team

User avatar
Vinterstum
ScummVM Developer
Posts: 585
Joined: Sun Oct 16, 2005 6:59 am

Post by Vinterstum »

I uploaded yet another build which forcibly disables Timidity and mt32emu, which should take care of anyone else who's preferences have gotten messed up (Possibly the trunk versions did this for a time?).

I also verified that the 16bit support is indeed disabled. So if it's the case that the new FM-TOWNS graphics doesn't support 8bit at all anymore, there may not be anything I can do here except adding 16bit support (which I'll do, but that probably wouldn't be in until at least the next point release).

User avatar
Vinterstum
ScummVM Developer
Posts: 585
Joined: Sun Oct 16, 2005 6:59 am

Post by Vinterstum »

fingolfin wrote:
Vinterstum wrote:
fingolfin wrote:True :). Anyway, thanks for the reports, much appreciated. I have once more contacted the iPhone porter by email, too (pointing him to this thread). I had written him previously due to some other bug reports, but sadly so far haven't got a reply.
The last email I got from you was on the 30th of last month, about the buildbot. Previous one was with Sev CC'ed, about the remaining tasks on the tracker, which I replied to. So it looks like once again we have issues with emails reaching each other...
Indeed. Well, the last one I emailed you was last night. And there was another one on the 16th where I once more (for the 3rd or 4th time :), but indeed emails from me to you seem to be eaten 50% somewhere; maybe me or my ISP is on some kind of blacklist?) sent you a link listing all our iPhone bugs, some of them quite old by now. And begging you to at least comment on each them. Even if you can't work on a fix (resp. in one case, you'd have to verify that a fix I implemented actually works).

Hopefully communication over the forums will be more reliable than email :).
Mails from me to you have gotten lost as well, I suspect our mail ISPs just hate each other :P.

I commented on the bugs; they're all reasonably minor, but valid.

kennyk
Posts: 4
Joined: Wed Jan 24, 2007 1:33 am

Post by kennyk »

Thanks for your quick released fix, Vinterstum :) . I just got the new version from Cydia, and it has fixed all of my issues. I can bug test for new versions on my iPad, if someone can provide me with a details or a link, as I am a bit new to this.

Thanks again!

User avatar
Vinterstum
ScummVM Developer
Posts: 585
Joined: Sun Oct 16, 2005 6:59 am

Post by Vinterstum »

Glad to hear it! :)

Damien
Posts: 6
Joined: Thu Jul 08, 2010 6:53 am

Post by Damien »

Are the Elvira Games working now? :-\

athrxx
ScummVM Developer
Posts: 18
Joined: Thu Feb 14, 2008 8:26 pm

Post by athrxx »

Vinterstum wrote:I uploaded yet another build which forcibly disables Timidity and mt32emu, which should take care of anyone else who's preferences have gotten messed up (Possibly the trunk versions did this for a time?).

I also verified that the 16bit support is indeed disabled. So if it's the case that the new FM-TOWNS graphics doesn't support 8bit at all anymore, there may not be anything I can do here except adding 16bit support (which I'll do, but that probably wouldn't be in until at least the next point release).

Actually, 8bit is still supported for the FM-TOWNS versions of SCUMM3 games (Zak, Indy 3, Loom). It still works for me in 8-bit mode on PC (USE_RGB_COLORS disabled, with or without DISABLE_TOWNS_DUAL_LAYER_MODE).

That screen shot seems very strange. There is no FM-TOWNS version with German text. Colors are also wrong (brown instead of green). IMHO it would make more sense to discuss a "normal" FM-TOWNS version.

You could try a build with DISABLE_TOWNS_DUAL_LAYER_MODE. But that was added mainly for memory saving reasons (NDS). I doubt that it will help here.

EDIT: You might actually give DISABLE_TOWNS_DUAL_LAYER_MODE a try, since it disables most of the new FM-TOWNS graphics code.

athrxx
ScummVM Developer
Posts: 18
Joined: Thu Feb 14, 2008 8:26 pm

Post by athrxx »

Could someone please test whether the issue is still present in the latest daily builds?

http://buildbot.scummvm.org/snapshots/m ... st.tar.bz2


EDIT: There has been an important update. We have found and fixed a general issue with ARM devices (Android, iPhone, etc.). You can test it as soon as buildbot picks it up...

User avatar
MajinChibi
Posts: 91
Joined: Mon Sep 03, 2007 10:07 pm
Location: Berlin, Germany

Post by MajinChibi »

i wasnt home recently so i couldn test, sorry :(

(isnt it possible to put every new version @cydia?)

Post Reply