iOS 14 build needed urgently

Subforum for discussion and help with ScummVM's iPhone port

Moderator: ScummVM Team

Post Reply
duckygillies7018
Posts: 4
Joined: Fri Oct 04, 2019 10:21 pm

iOS 14 build needed urgently

Post by duckygillies7018 »

Gday guys , anyone have an ipa of Scumm for iOS 14 , I updated my iPhone and now I can’t use my previously installed scummvm ipa , I’m roughly half way through the dig and need to get back playing

Cheers
Shaun
User avatar
criezy
ScummVM Developer
Posts: 810
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Re: iOS 14 build needed urgently

Post by criezy »

Doesn't the one available on our download page for iOS8 and above work? My device is too old and I am stuck with iOS 12, so I cannot confirm it works with iOS14, but I would expect it to work.

Otherwise your best bet is to compile it yourself. We have instructions on the wiki on how to do so.
duckygillies7018
Posts: 4
Joined: Fri Oct 04, 2019 10:21 pm

Re: iOS 14 build needed urgently

Post by duckygillies7018 »

Nah doesn’t seem to work ,
It certainly worked before on 12 ,
But maybe there’s something on 14 stopping it , it sure if anyone’s had luck,

I’ll have a go at compiling on my Mac and let everyone know how I got

Cheers
donkthemagicllama
Posts: 5
Joined: Wed Nov 15, 2017 9:13 pm

Re: iOS 14 build needed urgently

Post by donkthemagicllama »

I just complied with latest Xcode and it seems to run great on iPad OS 14...

So, it’s definitely possible...

Let me know is you run into issues, perhaps I can help.
eyebrush
Posts: 1
Joined: Sun Nov 29, 2020 12:27 pm

Re: iOS 14 build needed urgently

Post by eyebrush »

I think the OPs trouble is because a popular IPA signing app (AppSync Unified) is not working on iOS 14. It is possible however to just download the latest offical stable build as .deb-file, installing with dpkg and running uicache afterwards. Works fine for me on a jailbroken device.
Al3x
Posts: 1
Joined: Tue Aug 20, 2019 1:49 am

Re: iOS 14 build needed urgently

Post by Al3x »

donkthemagicllama wrote: Tue Nov 24, 2020 5:38 am I just complied with latest Xcode and it seems to run great on iPad OS 14...

So, it’s definitely possible...

Let me know is you run into issues, perhaps I can help.
Can you please share the .ipa or .deb of your compiled version, sir?
Thanks in advance!
Binubin
Posts: 1
Joined: Wed May 12, 2021 1:03 pm

Re: iOS 14 build needed urgently

Post by Binubin »

Has anyone had any luck making this work on 14.3? The application just crashes when I attempt to start it.
Post Reply