R4 updated to kernel 1.24b (and above) freezes ScummVM

Subforum for discussion and help with ScummVM's Nintendo DS port

Moderator: ScummVM Team

Post Reply
Posts: 3
Joined: Sat Sep 04, 2010 8:09 am

R4 updated to kernel 1.24b (and above) freezes ScummVM

Post by ZakMcKracken »


I have Nintendo DS lite, with R4 (Revolution for DS) with kernel updated to latest (1.25b - august 2010).

I updated also ScummVM to the latest 1.1.0

When I start ScummVM, in the upper screen appears the initialization text:

Code: Select all

DLDI Device:
'DEMON  IO Library         '
DLDI Driver Initialised OK!
But the bottom screen remain black, and everything is freezed.

I played regularly ScummVM in the past, I think it freezes starting from a certain kernel update, can't be sure, but I think with kernel 1.24 of july 2010.

Do you think this could be resolved with a workaround?

Thank you.

User avatar
Posts: 785
Joined: Tue Sep 30, 2008 10:33 pm
Location: The Bar Of Gold, Upper Swandam Lane.

Post by Red_Breast »

There are a number of threads I notice on the DS forum which seem to ask questions that are related to the flash card that's being used.
There are no hard rules but basically I think you will get better support from other users of the card. Maybe the card has a forum or irc.
I don't want to put people off and sometimes I've noticed some questions about specific cards are answered here but I'm just saying I think you'll be able to get help quicker elsewhere.
Sometimes I can also appreciate that you can't work out if it could be the card or ScummVM.
I have a look in this forum now and again for new posts but personally I only have a CycloDS Evo and never tried any other on my DS Lite.
Generally if the DLDI driver is working then I believe your problem Zak is the card. Although I wouldn't like to say 100%!

Posts: 3
Joined: Sat Sep 04, 2010 8:09 am

Post by ZakMcKracken »

Hello Red_Breast,

thank you for your answer.

In fact, I am still figuring out where the problem is. I can say that about 2 months ago, I used ScummVM on my NDS (same R4 card of course, but with previous kernel). I think the problem is that kernel update.

Unfortunately, on the site of the card, previous kernel is not available anymore.. and I don't have previous version.

Thank you anyway,


another world
Posts: 117
Joined: Sat Feb 23, 2008 4:05 am

Post by another world »

The R4 has not been officially produced since 2008 due to a very ugly lawsuit with R4DS vs. Nintendo (and about 144 software companies). The last official firwmare update for the R4 was v1.18. The R4 you are using is most probably a clone, which were based on an OEM design sold from Team Acekard towards the end of 2008. The problems with clones is that they are usually running a hacked version of the Wood R.P.G/Wood R4 opensource software. To be perfectly honest with you, if you prefer to stick with the R4 I would recommend you purchase the 1:1 exact hardware copy. A few original R4 team members continue to produce the v2 design of the card (the one with the black shell) but no longer offer kernel updates. For software you would want to run the Wood R4 menu. Wood R4 is a port of Wood R.P.G. which is now a fork of the Gelu opensource Ackeard firmware.

For more information check the following links.
Purchase the R4 1:1 copy for $6 from this trusted site: HERE

Here is information on Wood R4: HERE

Good luck!

-Another World

Posts: 1
Joined: Wed Oct 19, 2011 2:16 am

Post by Kasperski »

I'm currently using the latest R4 card with my DS lite, but I can't seem to get past the loading.. page.

I've downloaded the recent kernal (1.18 ) and the scummvm for ds lite, unzipped and on the R4 ready to be used. Also both monkey island 1 & 2 files are on there as well.

Is there anything I'm doing wrong or what should I be doing to fix the problem?? I've looked on both wiki and youtube videos and they both pretty much say same thing that I've been doing.

Posts: 1
Joined: Thu Oct 20, 2011 3:44 am

Post by WillisFabros »

What loading page where? The R4 kernel doesn't load? What?

If the R4 isn't loading you may have a fake, where did you download the kernel from? The only official R4DS website is r4ds.cn (previously .com) and you should only download the kernel from there.

Where did you buy the R4 from? All the R4s on sites like Amazon appear to be fakes now. The only real R4 is advertised as the R4 Revolution For DS and the company is the R4DS Team.

Posts: 3
Joined: Sat Oct 07, 2006 9:52 pm

Post by infernogott »

I've got the R4i Gold for the 3DS and have the same problem.

When starting ScummVM the bottom screen remains black.

I've tried all versions from 1.0.0 onwards.

What should I do to make it work?

Post Reply