SCUMMVM-F build won't boot!

Subforum for discussion and help with ScummVM's Nintendo DS port

Moderator: ScummVM Team

Post Reply
Posts: 2
Joined: Wed Jun 24, 2009 4:00 am

SCUMMVM-F build won't boot!

Post by ArmorSword »

First off I have to say I absolutely love SCUMMVM for the NDS and the work you guys put into it. Thanks a ton! I just stumbled upon this amazing project last night... anywho.

Trying to get Kyrandia 1-3 to work. But I can't even get the SCUMMVM-F build to boot properly on my DS to begin to search for the games....

I use a M3 lite/Passcard/SD with current firware and current scummvm 0.13.1. And I can load any other build and have ran everything from Monkey Island to Full throttle with no problems!

I have tried F-build with both DLDI patching... the one given for the M3 and the one Agentq posted to work for Full Throttle and Dig specifically for the M3 lite DRM problems mentioned.

Both patching processes lead to a failed boot, without the option to find the game folder to load.
After loading SCUMMVM-F i get a lower black screem and an upper screen that reads .....

----stuff cut off----

"ta abort!
pc:02037e06 Addr:2Bd9f4c2

r0: 2bd9f4c2 R8:02138E80
r1:000000Eb R9:00000001
. a bunch of numbers
r7: 0000000 pc:02037E0E

10 rows of 2 columns of more numbers mostly 0

Free: 2700K , Largest 2720k"

if detail is needed on the #s let me know; don't know if it is relevant.
The patched scummvm-f file is 1,163 kb...

Anyother info needed please let me know...

User avatar
Posts: 785
Joined: Tue Sep 30, 2008 10:33 pm
Location: The Bar Of Gold, Upper Swandam Lane.

Post by Red_Breast »

Not having any of the Kyrandia games means that build F is one of those builds that I've never had reason to fire up.
I noticed the downloads page has some Kyrandia demos so I thought I'd give them a try. Build F is starting for me.

I'm relatively new to nDS homebrew and I've only owned a CycloDS Evo. Automatic DLDI. Does the M3 need DLDI patching?

To understand that console output you put up you'll have to wait/hope agentq sees it.
Did you try the obvious like delete build F from your card and then copy build F from your PC to the card again. Or maybe a format of the SD card.
Good luck.

Posts: 2
Joined: Wed Jun 24, 2009 4:00 am

Post by ArmorSword »

Thanks for the reply Red,

Well I don't know if M3 'needs' DLDI (as I am brand new to the Homebrew ds stuff as well) but there is a DLDI listed for M3 and Agentq has listed a DLDI patch for the M3 lite in particular... so I've tried them both... meaning I have completely removed build F from my SD card... many times.

Oddly enough I dug way back into the forums and found alt. builds, I tried the build F found here....

forum link

viewtopic.php?t=6533&postdays=0&postord ... mb&start=0

and that actually boots... after a few tries... about 1 out of 4 attempts.

Along with the kyrand.dat files from that forum to match the date of the build and it boots! a little tinkering here and there to get the sound to work for Kyrandia 1,2 and 3 but everything seems to work. Save for Kyrandia 3 crashes when moving more than 2 screens after a very long boot process into the game.

I find this to be a temporary lucky fix i suppose. But I am still curious if anyone else is having problems with Build-F or why I am having difficulty with the newest one.


another world
Posts: 117
Joined: Sat Feb 23, 2008 4:05 am

Post by another world »

all modern flash linkers that read/write from the msd require dldi. dldi was developed for these needs, and is a common library. this means that homebrew apps can include dldi support, and the app will run correctly on a variety of kits. in the past the homebrew had to be developed and compiled for a specific linker.

you will find more information as well as tools and dldi files here:

the m3 lite does require dldi to run nds stuff via passme. i have not used mine for almost 2 years for nds. i can not recall if it auto patches. for now manually patch your file. never patch the same file twice, always patch a clean rom. make sure the patching app you use blocks the ability for the dldi to rewrite, incase the m3 lite does auto patch.

on the old F build kyrandia will take 5-10 seconds to boot, perhaps longer. keep that in mind when testing.

i hope you figure it out.

-another world

ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq »

Hi ArmorSword,

Actually I think I know what's causing your problems. I found an issue recently which could explain what you're seeing. If you have another DS around (or could borrow one) you'll probably find it works ok there.

I hope to fix this in the next version.

- agentq

Post Reply