ScummVM DS 0.12.0 beta2 [obsolete]

Subforum for discussion and help with ScummVM's Nintendo DS port

Moderator: ScummVM Team

User avatar
chrisis
Posts: 132
Joined: Sun Oct 30, 2005 4:06 pm
Location: Innsbruck, Austria

Test with Woodruff

Post by chrisis » Sun Aug 17, 2008 10:51 am

Hello agentq, earlier than thought, i just tried Woodruff on my DS.
I've tried it on a DS Lite with a R4 card, and while the game gets recognized correctly with Build D, unfortunately, as soon as I try to start the game, I get two black screens and the DS freezes (I let it stay like that for a few minutes, just to be sure, if it isn't loading in this time).
I guess the reason is that Woodruff runs on a resolution of 640x480 (and it runs in this resolution, if I start it on my PC version of ScummVM, even if I override my graphics settings to native).
Didn't you say, the DS wasn't able to run games that have this high native resolution because of memory constraints?

Scandal_UK
Posts: 26
Joined: Fri Oct 06, 2006 6:51 pm
Location: UK

Post by Scandal_UK » Sun Aug 17, 2008 11:37 am

Re: Lure of Temptress

Actually I can only reproduce the first bug on ScummVM-DS, if I put the DS in sleep mode around the time of cutting Ratpouch free. Which I did both times that I tried it at first.. doh!

The second problem has only happened to me the first time and seems OK at that point now.

I should have tested a bit more thoroughly before reporting those. So no real problems after all, if I avoid sleep mode then all runs OK.

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Sun Aug 17, 2008 12:32 pm

@chrisis: yes, 640x480 games won't work. I didn't realise it was one of those. I'll remove it from the compatibility list.

@scandal_uk: thanks for testing that. Normally I would like to fix the bug with suspend mode, if that was the cause, but I think since I'm very close to the deadline I'll accept that bug for now and look at fixing it for the next release.

Scandal_UK
Posts: 26
Joined: Fri Oct 06, 2006 6:51 pm
Location: UK

Post by Scandal_UK » Sun Aug 17, 2008 1:59 pm

Cool - I don't think it's going to be a problem that many people encounter. Here are some saves that demonstrate the problem;

http://scandal.uk.googlepages.com/lott-saves.rar

I'm gonna play it through anyway 'cuz I've got a true feeling of nostalgia with this game. When I first bought the original on the Amiga, the last disk was corrupt and I never did get around to sending it back or completing it!

Thanks again for this project, the best DS homebrew yet if you ask me.

Scandal_UK
Posts: 26
Joined: Fri Oct 06, 2006 6:51 pm
Location: UK

Post by Scandal_UK » Mon Aug 18, 2008 7:40 pm

A little update on my progress - it is playable but crashes randomly. (The previous bug with Ratpouch also happens sometimes if I don't use sleep mode so I don't know what causes it.)

Sometimes when you enter a room, sometimes when you press start (I think it could be when a sprite is moving in this case) and sometimes when you haven't done anything for a few moments.

Unfortunately I can find nothing consistent enough to say what causes it, one time it crashes and on the next load it's OK in the same place - but I can't play for more than 5 minutes without a crash so it's a bit too frustrating to carry on.

I'm pretty crap at testing usually - I code for a living but always leave the testing to others..! :)

Edit: You're probably aware of this but the icon also shows "F" instead of "G"

Garcimak
Posts: 12
Joined: Tue Jul 17, 2007 6:04 pm

Post by Garcimak » Tue Aug 19, 2008 9:24 pm

Inherit the earth + speech
on R4 : no major problems except Bad colors at intro screen.
on Acekard 2: just got two blacks screens (even after 5').

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Tue Aug 19, 2008 10:40 pm

@Scandal_uk: I played Lure for a while, did everything I could in the first few rooms and encountered no problems. Have you run the other ScummVM games ok? What card reader are you using?

Scandal_UK
Posts: 26
Joined: Fri Oct 06, 2006 6:51 pm
Location: UK

Post by Scandal_UK » Fri Aug 22, 2008 1:46 pm

The crashing only happens after you get to the village, the first few screens are always fine. Let me know if you want more save files.

I have always been able to run games fine on Scummvm-ds, such as the lucasarts ones and the Simon ones. I've been using Scummvm-ds since you started the project (even back when the zip file method worked for gba carts).

I use both a G6 Lite and a G6DS Real.

evilronald
Posts: 1
Joined: Wed Apr 08, 2009 1:58 pm
Location: united kingdom

Post by evilronald » Wed Apr 08, 2009 2:13 pm

lure of the temptress still freezes, early on too :( :x

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Wed Apr 08, 2009 8:18 pm

Why are you using this old build? It's been obsolete for a while.

Try here: viewtopic.php?t=7016

Post Reply