ScummVM 1.1 does not Boot on PS 2 V9 Pal

Subforum for discussion and help with ScummVM's PlayStation 2 port

Moderator: ScummVM Team

Post Reply
Posts: 3
Joined: Mon Apr 05, 2010 10:20 am

ScummVM 1.1 does not Boot on PS 2 V9 Pal

Post by maxpowerman » Mon Apr 05, 2010 11:06 am

Hi everyone,

I have been reading here for a few days, but i didn't find a solution for my problem.

I own a pal PS2 V9 (50004 Aqua Blue Limited) wit a DMS 4 Pro Chip and ToxicOS 0.41. The PS2 has a Networkadapter with a 200GB Maxtor HDD. It is Formated in APA+Extend an i am launching ScummVM with uLauncherELF 4.40.

The ScummVM is stored in hdd0/+APPS/ScummVM/

When i start ScummVM with network and HDD support, all i get is the helix on the right side of the screen but the programm does not boot.

When i start ScummVM without network and hdd support it starts.

I tried other Versions of ScummVM. V 1.0 and 0.13.1 causing the same problem. V 0.11.1 starts normaly, i can add a game (tested dott) but when i start the game it freezes with a black screen.

In my opinion, the problem could be the APA+Extend format of the HDD or the game partitions on the HDD which are made by the Toxic loader.

No other program has that problem. Is that problem known or am I the only person with that? Maybe a fix for that is already known and didn't find it. Different HDD driver or something like that.

I hope someone has an idea to fix it. ScummVM would make my PS2 perfect. I hope you excuse my english.

Posts: 1
Joined: Fri Apr 09, 2010 10:59 pm

Post by juanluisps » Fri Apr 09, 2010 11:17 pm

Same problem while trying to load "SCUMMVM-N.ELF" with uLauchElf from +ScummVM partition of internal HDD. Solved with this.

After booting "Add game..." doesn't find HARDDISK, so I am blocked again... :cry:

(It's my first time I try to use ScummVM for PS2 so I am not an expert)

Posts: 3
Joined: Mon Apr 05, 2010 10:20 am

Post by maxpowerman » Tue Apr 13, 2010 11:53 am

Ok that sounds good. I will test it soon. Thank you for the link.

Posts: 14
Joined: Sun Jul 12, 2009 10:35 pm

Post by sunmax » Sun Apr 25, 2010 4:07 pm

Hi there,

I have a PS2 V9 with the same identical configuration
(with the exception of the HD formatting) and it does
work fine here...

You should have a partition dedicated to ScummVM:


Since that it's where it will be looking for the games,
if you create it you should be able to see you hard-disk.

Once it's in place, could you please let us know if any
of the suggestions listed at:


are still needed to start ScummVM or access games?

Thanks for the feedback!

Posts: 3
Joined: Mon Apr 05, 2010 10:20 am

Post by maxpowerman » Tue Apr 27, 2010 4:52 pm


Sorry that my answer took so long, but I didn't find the time.
The problem is definatly the format of the hdd. I testet it with another hdd (80gb Samsung) and it works fine.

When I use my ps2 with the old 200gb maxtor hdd and start the program I see the helix on the right side. For a very short moment you can see the game selection window (maybe 1/10 of a second) but then the hdd starts working, the window vanishes, the system stucks and I only see the helix on the right side.

That means i have to format my hdd in the standard way if i want to use ScummVM.

Post Reply