Step by step - Guide

Subforum for discussion and help with ScummVM's PlayStation 2 port

Moderator: ScummVM Team

Post Reply
Guybrush the Mad
Posts: 1
Joined: Fri Aug 07, 2009 8:58 am

Step by step - Guide

Post by Guybrush the Mad » Fri Aug 07, 2009 9:02 am

Hi, I'm new to ScummVM.
I really do miss a step by step guide which tells me what exactly i have to do. Can anyone tell me how can I play Monkey Island 1+2 on my regular PS2???
Can I save during gameplay?


Posts: 17
Joined: Sun May 17, 2009 8:23 pm

Post by Damonfeuer » Wed Sep 09, 2009 2:37 pm

Using ScummVM on the PS2 is very similar to using it on a normal computer, the biggest problem is that you must find a way of booting homebrew on your PS2. There are many ways of booting homebrew on a PS2 - FMCB, modchip, swap magic, hdloader, etc. If you don't currently have a method of using homebrew, search for FMCB (Free Memory Card Boot), you'll even find people who will install it for free on your MC. Nearly all PS2s can use FMCB.

ScummVM can be run in many ways e.g. from USB, HDD, MC, CD, DVD and network. Probably the easiest way is from USB with FMCB, so I'll describe that:-

Download the PS2 version from

Make a folder on your USB device e.g. "ScummVM", unpack the PS2 files in that folder

Make a folder for your games as well e.g. "ScummVM_Games", make a subfolder for whatever game e.g. "Monkey1", copy the required files from your CD/DVDs to the subfolder. Check what's required at

On PS2:-
When the console has booted up, run UlaunchELF, browse files, goto mass:, find the folder you made earlier, run SCUMMVM.ELF, configure ScummVM as you would on a computer, play game.

ScummVM Ps2 saves and loads fine, for more info have a read of the documents included with ScummVM PS2.

Posts: 18
Joined: Sun Jul 27, 2008 11:25 am


Post by Demophobie » Wed Jan 05, 2011 9:16 am


i tried this method and it worked great. The only problem i have is: I cant save games (for example in Maniac Mansion 1)

It says: Failed to save game state to file: xy. Any idea? I tried a different usb media too - same error.

Btw: i did not have a keyboard so i pressed L1 und R1 to get letters to the save state. "ny" - but that should not be the problem right?

Posts: 3
Joined: Mon Sep 06, 2010 3:13 pm

Post by Mr.Broken » Fri May 13, 2011 8:40 am

tried it this way and it didnt work, it just froze again right after the start of scummvm elf, the helix appears and twists for a second and then the screen freezes.
it has been the same for all the methods i tried, burned it to a dvd and got the same problem, started it from different usb sticks and external hdd.
Could it be that scummvm on playstation 2 does only work with certain modchips or do i have to use a specific version of ulaunch elf ?

u have to love the playstation 2 section of this forum....anyway thanks for any advice

Post Reply