Broken Sword 1 & The Dig problems

Subforum for discussion and help with ScummVM's PlayStation 2 port

Moderator: ScummVM Team

Post Reply
Posts: 3
Joined: Tue Dec 27, 2005 4:42 pm

Broken Sword 1 & The Dig problems

Post by neko »

Hello. I have problems running Broken Sword 1 and The Dig. I'm using ScummVM hd partition and those are the only games that doesn't work. When I run them, I get a black screen.

In Broken Sword, I have all files stored in SWORD folder except music files, which are in MUSIC folder inside the SWORD folder. All filenames are uppercase and files have ben compressed to MP2/OGG and MP3. SPEECH1.CLU and SPEECH2.CLU were also compressed. All this works perfectly for PC version.

In The Dig, I have the BUN files compressed and SAN files without compression in the VIDEO folder inside the DIG folder. For some strange reason, some of the video files don't appear in the file list (I'm using execftps v0.69 as ftp server and flashfxp as ftp client). I've tried to copy them a lot of times, checking there's enough space in the partition, and it seemed to work but the files remain without appearing in the list. Also, all filenames are uppercase. This may be some problem with Execftps or flashfxp. Any ideas?
User avatar
ScummVM Developer
Posts: 91
Joined: Wed Nov 02, 2005 9:22 pm
Location: Dortmund, Germany

Post by lavosspawn »

I had a similar problem. But I can't really remember how exactly it happened....
I was trying to upload The Dig to my PS2's HDD using some tool, I think it was execftps. It always crashed at the same file, thereby fubaring the FS in a way that I couldn't delete the files or directory anymore. I tried it several times, and each time I had to delete the partition afterwards.
I suppose it's got a problem with the FTP when you have too many files in the same directory... But I don't really know, sorry. Anyways, I seriously doubt it's scummvm's fault.
Posts: 12
Joined: Wed Nov 30, 2005 1:02 pm

Post by SilverBlade »

This may be some problem with Execftps or flashfxp. Any ideas?
If you use LaunchElf as your elf launcher (which IMO is the best elf launcher available) there's a version available with ftp support, and it has worked flawlessly for me so far. (Fire up "PS2Net" from the launcher)

I've tried using FlashFXP, but it seemed very unstable. Instead I use good old LeechFTP (google for it, it's free, and remember to set threads to 2 when working with PS2 partitions), and that combination iwth launchelf and leechfpt works wonders. I've installed all my Scumm Games (including The Dig) this way, and they all work perfectly.

Hope it helps
Post Reply