A new engine. One for the Christopher Lloyd fans.

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

User avatar
Vorph
Posts: 91
Joined: Sat Nov 19, 2005 4:58 pm
Location: Germany

Post by Vorph » Tue Oct 12, 2010 6:36 pm

Hello

after checking the file, and trying it on different machines, I used the current buildbot version... everything is fine, must have been a compilation error with VS2010... :roll:

Thanks to all of you for the fast replies

Vorph

dodnet
Posts: 1
Joined: Mon Oct 25, 2010 8:46 pm

Post by dodnet » Mon Oct 25, 2010 8:53 pm

Hello,

I get the same error with version 1.2.0 64-bit on Windows 7 64 when playing Broken Sword 1 (german version) during the moviesequences. When I keep clicking ignore it continues.
---------------------------
Microsoft Visual C++ Runtime Library
---------------------------
Assertion failed!

Program: D:\Games\scummvm-win64\scummvm.exe
File: ..\..\graphics\video\smk_decoder.cpp
Line: 115

Expression: _buf < _end

For information on how your program can cause an assertion
failure, see the Visual C++ documentation on asserts

(Press Retry to debug the application - JIT must be enabled)
With version 1.1.1 everything runs just fine.

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto » Mon Oct 25, 2010 9:42 pm

dodnet wrote:Hello,

I get the same error with version 1.2.0 64-bit on Windows 7 64 when playing Broken Sword 1 (german version) during the moviesequences. When I keep clicking ignore it continues.
---------------------------
Microsoft Visual C++ Runtime Library
---------------------------
Assertion failed!

Program: D:\Games\scummvm-win64\scummvm.exe
File: ..\..\graphics\video\smk_decoder.cpp
Line: 115

Expression: _buf < _end

For information on how your program can cause an assertion
failure, see the Visual C++ documentation on asserts

(Press Retry to debug the application - JIT must be enabled)
With version 1.1.1 everything runs just fine.
You might want to try this development snapshot: http://buildbot.scummvm.org/snapshots/t ... 84.tar.bz2 It's a Win64 build with MinGW64 instead of MSVC, BUT it is no official release, you should IMHO just use it to test this.

gos
Posts: 2
Joined: Sun Nov 21, 2010 10:14 pm

Post by gos » Sun Nov 21, 2010 10:16 pm

the game is crashing...when bric-a-brac find his glasses.
anyone else is having this problem? i am playing the english version.

it doesn't give any message, or error, it just kick me out of the game.
damn i was happy seeing toonstruck on scummvm but now i am sad

User avatar
raina
Posts: 233
Joined: Thu Jan 12, 2006 12:31 pm
Location: Oulu, Finland
Contact:

Post by raina » Mon Nov 22, 2010 2:19 pm

gos wrote:the game is crashing...when bric-a-brac find his glasses.
anyone else is having this problem? i am playing the english version.
The engine only appears in the in-development version of ScummVM. Anything and everything like this is to be expected.
gos wrote:it doesn't give any message, or error, it just kick me out of the game.
Assuming you're on Windows, there probably is something in the console but unless you run ScummVM from the command line, the console window disappears as soon as ScummVM exits.
gos wrote:damn i was happy seeing toonstruck on scummvm but now i am sad
If you're not interested in finding and reporting bugs in the in-development version, wait for a ScummVM release where Toonstruck support is officially announced.

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3316
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Sun Nov 28, 2010 11:02 pm

Since the engine maintainer is busy, I've made an attempt to fix the crash. I don't know if it's the correct fix (it avoids the crash, but there may be more to it), but at least I don't see how it could make things worse...

mintfresh
Posts: 7
Joined: Wed Nov 24, 2010 10:23 am

Post by mintfresh » Tue Nov 30, 2010 11:38 am

I have been unable to add the game, I have ensure the toon.dat file is in the scummvm folder.
I am using version mingw-w32-1.2.0-r54448 and also 1.3.0svn54565...:(

OreWaUsopp
Posts: 1
Joined: Sat Dec 04, 2010 2:05 am
Contact:

Tnstrk

Post by OreWaUsopp » Sat Dec 04, 2010 2:37 pm

I have the newest ScummVM engine, but, it lacks the Toon build. I tried DL-ing the daily build, but got some odd file I am not sure how to work. Please tell me what I am doing wrong?

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3316
Joined: Mon Oct 31, 2005 7:39 am

Re: Tnstrk

Post by eriktorbjorn » Sat Dec 04, 2010 3:06 pm

OreWaUsopp wrote:I tried DL-ing the daily build, but got some odd file I am not sure how to work. Please tell me what I am doing wrong?
Well, one thing you're doing wrong is that you're being needlessly cryptic. ;) What do you mean by "odd file"? Without at least knowing the name (and optionally the approximate size) of it, it's hard to tell.

User avatar
Strangerke
ScummVM Developer
Posts: 333
Joined: Wed Sep 06, 2006 8:39 am
Location: Belgium

Post by Strangerke » Sat Dec 04, 2010 3:10 pm

I tested the daily build 1.3.0svn54759 (win32) and Toonstruck was detected properly. There's something important with toonstruck: you have to copy both CD content on you HDD, in the same directory. Did you do that? You should also check the content of you console window, just in case something useful is displayed.

Additionally, in order to verify if the engine is enabled in the build, you should look in the About Box. If the engine is mentioned, then it's enabled.

I hope it'll help!

User avatar
md5
ScummVM Developer
Posts: 2261
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 » Sat Dec 04, 2010 3:11 pm

mintfresh wrote:I have been unable to add the game, I have ensure the toon.dat file is in the scummvm folder.
I am using version mingw-w32-1.2.0-r54448 and also 1.3.0svn54565...:(
Toonstruck has been added in the 1.3.0 SVN version. It is not available in 1.3.0. You also need to copy both CDs in a folder, using just the first CD won't work

Edit: Strangerke beat me to it :P

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto » Sat Dec 04, 2010 4:16 pm

md5 wrote:
mintfresh wrote:I have been unable to add the game, I have ensure the toon.dat file is in the scummvm folder.
I am using version mingw-w32-1.2.0-r54448 and also 1.3.0svn54565...:(
Toonstruck has been added in the 1.3.0 SVN version. It is not available in 1.3.0. You also need to copy both CDs in a folder, using just the first CD won't work

Edit: Strangerke beat me to it :P
I guess that should read: "It is not available in 1.2.0." though. We can't say yet whether it will be available in an official 1.3.0 release or not, that depends on how the engine is progressing and when 1.3.0 will be released ;-).

Wizard Of Odd
Posts: 30
Joined: Mon Aug 07, 2006 3:42 pm

Post by Wizard Of Odd » Mon Jan 03, 2011 8:59 pm

Can anyone help with getting this to run? I've copied everything from my two Toonstruck discs to a directory called 'Toonstruck' on my computer. I literally just copied everything from both discs. I have the four directories 'Act 1' 'Act 2' 'Burst' and 'Misc' as well as a bunch of random other files.

When I run ScummVM though, and try to find the game, no matter where I point it towards I just keep getting an error saying it can't find the game in the specified directory.

Any ideas? Thanks.

User avatar
McKnallski
Posts: 68
Joined: Tue Dec 08, 2009 2:32 pm

Post by McKnallski » Mon Jan 03, 2011 9:33 pm

Download and use the latest daily Subversion Build (trunk, not 1.2.x branch).

Download here for your system (they are generated daily with the latest Changes):
http://buildbot.scummvm.org/builds.html

Wizard Of Odd
Posts: 30
Joined: Mon Aug 07, 2006 3:42 pm

Post by Wizard Of Odd » Tue Jan 04, 2011 8:40 pm

Hmm thanks for the link, but I've got absolutely no idea what to do with that now I've downloaded it! I'm just left with one file after extraction : "mingw-w32-trunk-latest.tar.bz2.tar.out"

Cheers, I think I'll wait till it's officially supported I guess.

:)

EDIT : No matter, sorted it now! Just needed extracting again, ha. All working nicely! That's awesome, I didn't think I'd be playing this one again. I think this was the first adventure game I ever played on the PC (after playing most the Lucas ones on the Amiga)

:D :D

Post Reply