LOL support in official build ?

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

warpdesign
Posts: 16
Joined: Sun Apr 05, 2009 10:05 pm

LOL support in official build ?

Post by warpdesign » Mon Feb 22, 2010 11:39 am

Any idea when LOL support will be included in official builds ?

I know it's been in the trunk for some time now and it seems to be quite complete/stable...

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Re: LOL support in official build ?

Post by LordHoto » Mon Feb 22, 2010 12:27 pm

warpdesign wrote:Any idea when LOL support will be included in official builds ?

I know it's been in the trunk for some time now and it seems to be quite complete/stable...
Probably it will be supported from ScummVM 1.2.0 on. (At least there had been talks about a 1.1.0 release cycle start recently and it's too late to get Lands of Lore into that one, apart there's still some bits to tackle).

quackshot
Posts: 12
Joined: Mon Aug 27, 2007 10:01 pm
Location: france

Post by quackshot » Mon Feb 22, 2010 1:51 pm

I finish it with scummvm and I don't see any bug. (french version : text FR and english voices)

User avatar
MeddlingMonk
Posts: 132
Joined: Wed Jan 21, 2009 10:06 pm

Post by MeddlingMonk » Wed Feb 24, 2010 2:07 am

quackshot wrote:I finish it with scummvm and I don't see any bug. (french version : text FR and english voices)
That you noticed. On your computer. Playing the French version. Things could be very, very different with, say, the German version with Fedora on a computer with a PPC processor for all you or I know. I'm not just trying to be difficult, just pointing out facts. As a concrete example, there was a time not long ago when Discworld II would only work with little-endian processors. It would have been absurd to have let it be supported in a stable version only to tick off everyone with big-endian processors who wouldn't have been able to play the game.

fischkopf
Posts: 91
Joined: Sun Mar 22, 2009 1:08 pm
Location: germany

Post by fischkopf » Sun Mar 07, 2010 4:49 pm

can you clear me up what is "LOL"?

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3315
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Sun Mar 07, 2010 5:33 pm

fischkopf wrote:can you clear me up what is "LOL"?
Lands of Lore: The Throne of Chaos. A somewhat surprising game for ScummVM to support, but apparently it uses a modified version of the game engine used by the Legend of Kyrandia games.

Lomius
Posts: 7
Joined: Thu Apr 15, 2010 1:00 am
Location: Dallas, TX

So how do I get it to work?

Post by Lomius » Thu Apr 15, 2010 1:02 am

I have the CD version and the nonCD version. But I cant seem to get any version of ScummVM to find it. Ive used official and daily beta builds. Please explain how to get it working as I love this game!

User avatar
bobdevis
Posts: 563
Joined: Fri Jan 16, 2009 10:52 am

Post by bobdevis » Thu Apr 15, 2010 1:27 am

You have 2 options.

- Wait until LOL is enabled in the SVN builds.
- Arrange an unofficial build that has it enabled from somewhere.

If you are on Linux x86-64, I'd love to toss you the build. I don't have the setup for a Windows or Mac compile however....

User avatar
clone2727
Retired
Posts: 1592
Joined: Fri Jun 09, 2006 8:23 pm
Location: NJ, USA

Post by clone2727 » Thu Apr 15, 2010 2:30 am

There are always SVN builds available from here. They should all have Lands of Lore enabled.

Lomius
Posts: 7
Joined: Thu Apr 15, 2010 1:00 am
Location: Dallas, TX

sorry in my lingo svn=beta build

Post by Lomius » Thu Apr 15, 2010 4:48 pm

ive tried many of the SVN builds to no avail. what steps need to be taken with the LOL files themselves i guess is what i am asking... i have used the svn builds to play some sci gmes. when i hear LOL was playable i was ecstatic. but i cannot figure out how to get it running....

User avatar
LordHoto
ScummVM Developer
Posts: 1030
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto » Thu Apr 15, 2010 4:54 pm

For the CD version you need to copy all *.pak and *.tlk files into one directory. An exception make the files in the directories "eng", "fre" and "ger" there, those directories need to be copied as is.

Apart make sure that your SVN build says "1.2.0svn".

Lomius
Posts: 7
Joined: Thu Apr 15, 2010 1:00 am
Location: Dallas, TX

Still no luck :(

Post by Lomius » Fri Apr 16, 2010 1:56 am

Image

using 1.2.0 as suggested. says cant find game in specified directory :(

User avatar
Raziel
ScummVM Porter
Posts: 1114
Joined: Tue Oct 25, 2005 8:27 am
Location: a story that hasn't been written yet

Post by Raziel » Fri Apr 16, 2010 5:33 am

See if the console prints something like "Unsupported version / Report this to the devs" and well, do that :-)

KuroShiro
Posts: 455
Joined: Thu May 15, 2008 7:42 am
Location: Miyazaki, Japan

Post by KuroShiro » Fri Apr 16, 2010 5:52 am

I don't know if it's the problem, but some of those files in the main directory should be in one of the subdirectories (like /eng). The game works on the version I just compiled.

Lomius
Posts: 7
Joined: Thu Apr 15, 2010 1:00 am
Location: Dallas, TX

Post by Lomius » Fri Apr 16, 2010 6:44 pm

i tried as you initially instructed. then i copied all files from the three directories into the root as well. didntmove just copied. neither way has worked ;( ive always been able to follow the game install instructions from your wiki. is there such instructions for LoL. or what about the noncd version. thats fine too

Post Reply