t7gre - Groovie Engine

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

mac_es
Posts: 124
Joined: Mon Oct 31, 2005 9:37 am

Post by mac_es »

sev wrote:
mac_es wrote:
sev wrote: knakos never was involved with Pocket PC port. And yes, he is not active anymore.


Eugene
Ops, I thought so... who is the official porter then? I thought he was because he had posted in the sub-forum and he was assigned bugs in the Wince platform...
Ahem. My fault. Somehow I mixed Kostas with khalek. knakos' usual nick is Jubanka. And yes, knakos is our WinCE porter and he is active, just is not frequent on the forums.


Eugene
Ok, thanks

User avatar
pncFreak
Posts: 146
Joined: Sun Nov 02, 2008 3:33 pm

Post by pncFreak »

I'm glad that there is someone toiling and sweating over the CE port version. I like the fact that he is working on the port rather than chatting in the forum :)

Thanks for the info, sev

User avatar
gamin
Posts: 27
Joined: Wed Mar 15, 2006 2:50 pm
Location: Belgium

Post by gamin »

just completed the whole game with subversion build november 23rd. everything was working great (except the already know AI problem in the labo). just retried the end of the game with latest build, and track2.ogg is working like a charm during the whole ending sequence and the credits. good job guys !!! :D

can't wait to try 11th Hour and Clandestiny

PS: will try the labo again with latest build as I've seen AI has been improved.

EDIT : just tried the labo again... lost 3 times... I guess AI problem has been solved :P

User avatar
DonutSafari
Posts: 2
Joined: Sat Dec 06, 2008 11:30 am

Post by DonutSafari »

Greetings. This site came up in a google search whilst trying find solutions to playing T7G in Windows XP. Hoping someone can assist me?

1.) I have tried T7G in Win95 within VMware - sound issues due to emulation.

2.) Tried DOSbox however performance and sound issues due to emulation. Also would not play the audio track on CD1.

3.) Tried installing it just within WinXP using the custom setup application and v1.30 patch which bypasses the groovie.ini and uses your windows video/sound drivers. There were many graphic artifacts and the game would constantly crash at various puzzles.

Would love to try this using your ScummVM however it appears I need to do a number of things to get it working which I can not find instructions how to do this.

clem
Posts: 2185
Joined: Mon Oct 31, 2005 11:14 am

Post by clem »

DonutSafari wrote: Would love to try this using your ScummVM however it appears I need to do a number of things to get it working which I can not find instructions how to do this.
First you will need the "Win32 ScummVM Daily snapshot" from here. The stable 0.12.0 release won't work.

Then you will need to copy the data from both CDs to the harddisk - the list of files can be found here; if in doubt just copy all files from both CDs into one folder on your harddisk.

Then start ScummVM, and add the game folder to the list of games (instructions to do that can be found here although the GUI might look slightly different nowadays).

(You are lucky, this game has only been working in ScummVM for ~3 weeks now)

edit: you'll also need to rip the audio tracks to mp3/ogg/flac files to be able to listen to all of the music - however even though ScummVM complains about lack of music if the files aren't there the game will play fine (even with music) since the CD audio is only needed quite late in the game

User avatar
DonutSafari
Posts: 2
Joined: Sat Dec 06, 2008 11:30 am

Post by DonutSafari »

clem Thank you for your quick response, I am in the process of doing as you have written now. May I ask which is the most compatible/preferred Audio format for ScummVM mp3/ogg/flac or will they all play the same?

UPDATE: I copied all files from CD1/CD2 to a folder called T7G and then copied the v1.30 update files. I then ripped the audio from both CD's as track1.mp3 (intro) and track2.mp3 (ending) which I believe will both need to be named track1.mp3 for the moment? and copied them to the same location. I installed the ScummVM v0.13.0svn and added the game folder. The game started perfectly, the track1.mp3 was a little out of sync with the intro and think this is due to game running a little slower than designed to be played. So far have not seen any graphic/audio disruptions and no crashes at the regular spots! Will continue playing and let you know if anything weird occurs.

User avatar
marticus
Posts: 75
Joined: Sat Nov 26, 2005 11:32 am

Post by marticus »

looking at the files in the 1.30 patch, it seems that it's not needed at all, because it's mostly a driver update, and the 2 duplicated filed (fat.ad & sphinx.fnt) are no different to the originals.

User avatar
mredfield
Posts: 7
Joined: Tue Dec 16, 2008 11:40 am
Location: São Paulo - Brazil
Contact:

Post by mredfield »

I've been playing it and haven't encountered any bugs or anything out of the ordinary so far.

Excellent! That's a great game to be supported and I can't wait for a 11th Hour working version.

Thank you so much! :)

Post Reply