Mouse interface for Grim Fandango (Fan made mod)

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

Post Reply
Posts: 33
Joined: Sat Feb 08, 2014 3:50 am

Mouse interface for Grim Fandango (Fan made mod)

Post by tobiaspfaff »

---- Updated June 13th, 2014 ------

Hi all,

I got annoyed by the Grim Fandango's tank controls, so I made a classical point&click interface. The game is now 100% playable with mouse only (bugs to be expected, though).
Here is a preview:

The mod is now available for you to trying out!
Be aware that you may run into a bug at some point which might prevent you from finishing the game.

The most recent version for Windows and Mac, together with installation instruction, can be found here:

Source code is available at

--- Changelog -----
v0.7 (June 2014)
- fixed beaverdam intro (#40)
- included new changes from ResidualVM master

v0.6 (June 2014)
- hotspot fixes #35, #36 (Toto, cat photo)
- poem dialog (#34)

v0.5 (May 2014)
- Variable resolution (thanks to momomomo888!)
- In-game menu now has mouse support
- Fixed credits (#27), Beaver dam cut scene (#30)
- Hotspot fixes #25, #26, #29 (Florist, Brennis, Sewers)

v0.4 (Apr. 2014)
- Fixed height check (issue #16,#22)
- Inventory bug fix (#10, thanks to Sparkash!)
- Hotspot fixes #14,#15,#18,#19,#20,#21,#23,#24,#28
(Lighthouse, Sewers, Boobytrapped wagon, Beach, Chepito, Toto, Rag, Pumping tree)

v0.3 (Mar. 2014)
- Fixed savegame bug (#3), this time for real (thanks Botje!)
- Several Hotspot fixes: #5,#6,#7,#8
Rubacava circle, alley door, rooftop ladder, Maximino's office

v0.2 (Mar. 2014)
- Fixed wheelbarrow bug
- (Hopefully) fixed savegame bug
- Mac build should now run without additional libraries
- Reorganized patches

v0.1 (Feb. 2014)
- Initial Release
Last edited by Guest on Fri Jun 27, 2014 12:31 am, edited 15 times in total.
User avatar
Posts: 37
Joined: Wed May 18, 2011 8:10 am

Post by YakBizzarro »

Impressive work, even if I'm scared by the amount of the hacks required ;)

Personally I don't like the inventory interface, I still prefer the old one, maybe with a click on the left/right of the current object to change it.

For the copyright, IANAL I think that PatchR is a safe way to distribute modifications of the scripts. It's usage is quite tricky, basically because there is no manual (sorry, my fault). If you need some advice feel free to contact me.

Modifications of ResidualVM are ok, it's mostly under GPL and others free licenses.
User avatar
ScummVM Developer
Posts: 372
Joined: Thu Apr 21, 2011 7:31 pm
Location: Trondheim, NO

Post by somaen »

First of all, this does indeed look cool. I always thought the scenes would make this impossible (i.e. not everything is easily clickable), so if you've solved that... well done.

Like YakBizarro, I can't say anything about the script patcher (IANAL either).

As he says, the ResidualVM-changes are ok, as long as you comply with the GPL (i.e. have the sources available for any binary you distribute).

AlsoIf you distribute your own builds with these changes, we would be gratefull if you marked them clearly as not being the official release (helps when people want to post bug reports).

That said, I must really say, great job.
User avatar
Posts: 453
Joined: Sat Sep 13, 2008 2:24 pm
Location: Scotland

Post by Graxer »

This looks fantastic! It is a great achievement to make Grim Fandango work with with a point and click interface. I really look forward to giving this a go when you release the patches! :D
Posts: 33
Joined: Sat Feb 08, 2014 3:50 am

Post by tobiaspfaff »

Ok, I think the mod is now ready for first test use. If you want to try it out, and know your way around building ResidualVM from source, this is for you. I'll try post builds for Windows (and maybe Mac ?) later. (Does anyone have specifics on how to build ResidualVM for Windows so it runs on the average non-developer machine, i.e. statically linking all the required libraries ? I'm more of a Mac/Linux person.)

1. Clone my repository
2. Build
3. Copy dists/engine-data/mouse.lab into your game file directory (where data001.lab is located)
4. Setup Grim Fandango like you would normally
5. Play
6. Run into a brazillion annoying bugs, and report them :)

* New controls *
- Left-click : Walk and use
If you left-click on an object, it is used. If Manny is holding an inventory object, it is used on the scene object.
- Double-click : Run and use
Same as single-click, except Manny will run to the object.
- Right-click : Look at / Use inventory object on its own
Same as left-click, except Manny will look at an object instead of using it. If Manny is holding an inventory object, right-click will use it on its own (e.g. deck of cards, or fire extinguisher in Beaver Dam)
- Middle-click (or I key) : Open Inventory
If Manny is holding an object, he will put it away. Left-click within the inventory selects an object, right-click will make Manny look at it.
- Space key : Show all hotspots in the scene

Oh, and of course a cautious word of advice:
It is pretty likely that you'll run into a bug that will prevent you from completing the game. So use at your own risk; so save often, and if you actually want to play the game to complete it, use the original build instead.
Posts: 145
Joined: Mon Oct 31, 2005 9:37 am

Post by mac_es »

Here you have a Windows x86 version: [deleted, view the next post]

This is the configure

Code: Select all

Checking whether building plugins was requested... no
Checking for Ogg Vorbis... yes
Checking for Tremor... no (Ogg Vorbis/Tremor support is mutually exclusive)
Checking for FLAC >= 1.0.1... yes
Checking for MAD... yes
Checking for ALSA >= 0.9... no
Checking for libjpeg >= v6b... yes
Checking for PNG >= 1.2.8... yes
Checking for libtheoradec >= 1.0... yes
Checking for libfaad... yes
Checking for SEQ MIDI... no
Checking for sndio... no
Checking for TiMidity... no
Checking for zlib... yes
Checking for libmpeg2 >= 0.4.0... yes
Checking for Sparkle... no
Checking for libfluidsynth... yes
Checking for readline... skipping (text console disabled)
Checking for libunity... no
Looking for freetype-config... /mingw/bin/freetype-config
Checking for FreeType2... yes
Checking for OpenGL... yes
Checking for nasm... /mingw/bin/nasm
Building translation support... no
Building taskbar integration support... win32
Building Bink video support... yes
Building SafeDisc decryption support... yes
Building updates support... yes
Backend... sdl (1.2.14), assembly routines, savegame timestamp, MT-32 emu

Engines (builtin):
    Grim [all games]
    Myst 3
DON'T USE their downloadmanager as it installs crap/spyware...

If this download is against/rules or break some license feel free to modify the post.

I have tried adding Grim Fandango, running it and press space bar to show hotspots...
Last edited by trin on Wed Feb 12, 2014 3:13 pm, edited 1 time in total.
Posts: 33
Joined: Sat Feb 08, 2014 3:50 am

Post by tobiaspfaff »

Ok, I built some binaries for v0.1 on Mac and Windows:
Grim Mouse v0.1 - Windows zip
Grim Mouse v0.1 - Mac dmg

These should work like the regular version of ResidualVM, so no copying of stuff needed. They include a Readme with the mouse/key shortcuts and other information.

Have fun testing!

@mac_es: thanks for the build! I think I also figured out the Windows build process now; let me know if my zip works or if I need to include some other files.
Posts: 145
Joined: Mon Oct 31, 2005 9:37 am

Post by mac_es »

It looks correct!
Posts: 95
Joined: Fri Sep 17, 2010 5:22 am

Post by JenniBee »

Nice job! I'm up to the end of year one, and I've been able to play just fine with the mouse up to now, but I can't get the mouse to cooperate.

I'm at the scene in the petrified forest with the creepy key. Manny won't go right on the path to get back to the main forest, he just goes straight up, but there doesn't seem to be any clickable areas to make him turn right. I have to use the keyboard here in order to make him move. If I turn him right, I'm able to click on the screen to make him move to the right.


Also, less pressing of an issue is at the DOD garage. I'm able to enter it OK, but the clickable hotspot is really small so it was really confusing to find the right spot to get in and took me a few minutes before I got it right.

EDIT: I just tried the creepy key scene with the Bone Wagon, and you can get past that part perfectly with a mouse when you're riding it out. So the hotspot only seems to be wonky when you're on foot.

I'm also having trouble with the wheelbarrow scene. I can't find any hotspots to move the wheelbarrow forward or backward.

I filed bug reports of the most pressing issues at the Grim Mouse bug tracker.
Posts: 2
Joined: Sat Feb 15, 2014 8:24 pm

Post by Tea23 »

Unsurprisingly it works on Linux, if anyone is interested. I have created an Arch PKGBUILD for it. At the moment it prompts on install to grab the mouse.lab from the Windows zip because unless I'm blind I can't find it anywhere else.
User avatar
Posts: 126
Joined: Mon Oct 31, 2005 3:08 pm

Post by noize »

First of all: amazing initiative!

However, I get the following error with your mac build:

dyld: Library not loaded: /usr/local/lib/libpng15.15.dylib
Referenced from: /Applications/Games/
Reason: image not found
Trace/BPT trap: 5

libpng15.15.dylib is located in /usr/lib/libpng15.15.dylib, but I don't think it is supposed to link to that file anyhow?

Posts: 33
Joined: Sat Feb 08, 2014 3:50 am

Post by tobiaspfaff »

Thanks for the feedback, everyone!

@JenniBee: I found the bug in the wheelbarrow scene, it's fixed now (I'll release an updated version soon). I tried to reproduce the creepy key bug, but couldn't. you've got Manny in a position where clicking the exit hotspot doesn't work anymore, right? Can you send me a savegame where this happens? Also, what do you mean by the garage hotspot -- the hotspot for the elevator down to the garage, or the big door in the alley?

@noize: oh yeah, I haven't checked for shared library dependencies. I'll try to remove as many as possible in the next update.

@Tea23: Thanks! By the way, mouse.lab is in dists/engine-data in the git repository.
User avatar
ScummVM Developer
Posts: 372
Joined: Thu Apr 21, 2011 7:31 pm
Location: Trondheim, NO

Post by somaen »

As a side note, you probably don't need all the possible libraries:
* libPNG isn't used in Grim Fandango afaik.
* Nor is JPEG (it _IS_ used in Myst 3 though)
* OGG/FLAC isn't used in Grim Fandango
* I _think_ libmad isn't used in GrimE, unless you want to play EFMI.

It is however critical that you have zlib, otherwise you won't get videos.
Posts: 1
Joined: Tue Feb 18, 2014 8:28 pm

Post by marpieters84 »

I have the problem that I have to reload savegames several times in order to get the hotspots right.

So the hotspots are at the wrong locations.
Once loaded correctly, they are correct for the whole time playing.

--> leaving the game, getting back into --> hotspots are wrong.

I could do some screenshots if you need them, but I am not at home at the moment to do so.

But thanks for the awesome work so far. How much better the game is as point & click!!! Why the hell didn't they do that in the first place, whyyyy.? :D
Posts: 2
Joined: Sat Feb 15, 2014 8:24 pm

Post by Tea23 »

tobiaspfaff wrote: @Tea23: Thanks! By the way, mouse.lab is in dists/engine-data in the git repository.
You're right and I'm dumb. I've updated the package and it installs the file properly now.
Post Reply