Infrastructure updates

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

mataniko
ScummVM Developer
Posts: 5
Joined: Mon Dec 25, 2017 8:03 pm

Infrastructure updates

Post by mataniko » Wed Oct 24, 2018 5:06 pm

Over the last few days the ScummVM team has been working hard on upgrading our infrastructure. During the process all of the supporting sites have been updated, cleaned up and secured with SSL support.

If you run into any problems with the Forums, Wiki, Translations, Bug Tracker, or any other website related issues please let us know. For minor issues feel free to post on this thread. For major problems use the bug tracker using the Web component to let us know.

User avatar
Longcat
Posts: 981
Joined: Sat Sep 23, 2006 3:15 pm

Re: Infrastructure updates

Post by Longcat » Thu Oct 25, 2018 8:32 am

What happened to the 'View all unread posts' button in the forum? It was really useful.

User avatar
criezy
ScummVM Developer
Posts: 546
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Re: Infrastructure updates

Post by criezy » Thu Oct 25, 2018 11:33 am

Click on Quick links on the top left of the page and select Unread posts?

User avatar
MusicallyInspired
Posts: 984
Joined: Fri Mar 02, 2007 8:03 am
Location: Manitoba, Canada
Contact:

Re: Infrastructure updates

Post by MusicallyInspired » Thu Oct 25, 2018 12:12 pm

Well it's about time. Nice work.

Ack. Don't like avatars on the right side, though. Never did like designs that took that approach. Oh well. Still an improvement.

Collector
Posts: 542
Joined: Sun Oct 30, 2005 6:58 pm
Contact:

Re: Infrastructure updates

Post by Collector » Thu Oct 25, 2018 12:56 pm

MusicallyInspired wrote:
Thu Oct 25, 2018 12:12 pm
Ack. Don't like avatars on the right side, though. Never did like designs that took that approach. Oh well. Still an improvement.
Nor I, but it is just a couple of CSS changes to fix.

BTW, I just noticed a missed element. The options tab at the bottom of the full post editor still has the original Prosilver blue.

mataniko
ScummVM Developer
Posts: 5
Joined: Mon Dec 25, 2017 8:03 pm

Re: Infrastructure updates

Post by mataniko » Thu Oct 25, 2018 2:16 pm

Thanks for the feedback everyone, the style has been updated to fix the avatars and unstyled elements.

GateKeeper
Posts: 13
Joined: Thu Dec 14, 2017 10:40 am

Re: Infrastructure updates

Post by GateKeeper » Fri Oct 26, 2018 7:43 am

Looks good, but what is missing is a link to the main ScummVM site.
Not that it's too difficult to manually change the URL, but the old forum design had that link up there, and at least I used it sometimes.

User avatar
rootfather
ScummVM Team Member
Posts: 35
Joined: Tue Mar 31, 2015 11:59 am
Location: Germany
Contact:

Re: Infrastructure updates

Post by rootfather » Fri Oct 26, 2018 9:36 am

Thanks mataniko for improving the forums!

One question, can you add me to the ScummVM Team group in the forums as well so I don't have to have seperate moderator privileges and just be a member of the team group?

User avatar
MusicallyInspired
Posts: 984
Joined: Fri Mar 02, 2007 8:03 am
Location: Manitoba, Canada
Contact:

Re: Infrastructure updates

Post by MusicallyInspired » Sat Oct 27, 2018 4:37 am

mataniko wrote:
Thu Oct 25, 2018 2:16 pm
Thanks for the feedback everyone, the style has been updated to fix the avatars and unstyled elements.
Oh, nice. Thanks for that!

User avatar
Dark-Star
Posts: 135
Joined: Sun Oct 30, 2005 9:36 pm
Location: Reutlingen, GERMANY

Re: Infrastructure updates

Post by Dark-Star » Sun Oct 28, 2018 11:03 pm

The difference between "new posts" and "no new posts" is hardly noticeable anymore. it's just the slight color change on the border around the circle. This makes those two icons very hard to differentiate.

mataniko
ScummVM Developer
Posts: 5
Joined: Mon Dec 25, 2017 8:03 pm

Re: Infrastructure updates

Post by mataniko » Mon Oct 29, 2018 5:32 am

Dark-Star wrote:
Sun Oct 28, 2018 11:03 pm
The difference between "new posts" and "no new posts" is hardly noticeable anymore. it's just the slight color change on the border around the circle. This makes those two icons very hard to differentiate.
The base theme icons loaded instead of the new icons. I just pushed a fix that loads the icons correctly. Thanks!

User avatar
criezy
ScummVM Developer
Posts: 546
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Re: Infrastructure updates

Post by criezy » Mon Oct 29, 2018 9:39 am

The image and logo on the top left of the forum pages appears to be broken. Now instead of the image I see the "Maniac Mansion kids" text in light orange.

User avatar
LogicDeLuxe
Posts: 392
Joined: Thu Nov 10, 2005 9:54 pm

Re: Infrastructure updates

Post by LogicDeLuxe » Mon Oct 29, 2018 11:09 am

Oddly enough, some minutes ago, I still had the logo, and now I get that text too.

mataniko
ScummVM Developer
Posts: 5
Joined: Mon Dec 25, 2017 8:03 pm

Re: Infrastructure updates

Post by mataniko » Mon Oct 29, 2018 12:46 pm

I fixed the logo, you may need to refresh with cache disabled to see changes if you're not seeing them yet.

Kurufinwe
Posts: 20
Joined: Tue Nov 29, 2005 10:22 pm

Re: Infrastructure updates

Post by Kurufinwe » Tue Oct 30, 2018 6:35 am

Should the forums display a favicon? They seem to have stopped doing that since the update.

On an unrelated note, is there a chance someone could clean up the announcements and pinned topics in General Discussion? You currently have to scroll through 15 (!) of those, many of which haven't seen any activity in months or years, before you get to the active topics.

Post Reply