Soltys under real DOS (or dosbox)

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

Post Reply
Posts: 2
Joined: Mon Apr 09, 2018 9:40 pm

Soltys under real DOS (or dosbox)

Post by mgo » Tue Apr 10, 2018 10:35 am

Hello guys,
I lost my hope so I am asking you. As some of you implemented in ScummVM CGE engine for sphinx and Sołtys games you'll probably know answer.

I am trying to run Sołtys on old machine under real DOS. But everytime it crash and get out to dos after few minutes to play.
To reproduce error you need to:

1) Start game using Cge.exe or soltys.bat
2) Start game, take bone and put bone in metal plate to unlock 9 more locations.
3) And know magic happens, you just start randomly changing location. After few tries it will probably go out to DOS with
Bad VBM [xx] message. Where in place of xx could be some string or digits.

I checked 8-9 versions on game with various language variants, on dosbox and 3 real dos machines and result is same. I tried to disable sound but still the same.

I even tried to reverse engineer cge.exe to find reason why it happens but I'm not good enough to reveng dos applications. I just suppose it could be some reading data problem. It happens randomly. Maybe someone who implement that engine in ScummVM know answer what is going on?

User avatar
ScummVM Porter
Posts: 1114
Joined: Tue Oct 25, 2005 8:27 am
Location: a story that hasn't been written yet

Post by Raziel » Wed Apr 11, 2018 10:24 am

Just curious...did you try your versions with ScummVM too?
Does it crash there aswell?

Posts: 2
Joined: Mon Apr 09, 2018 9:40 pm

Post by mgo » Thu Apr 12, 2018 8:14 am

Yes. I tried. However versions from scummvm homepage are solely data files without .exe file so I just copied that file from other version. Result is the same. As I wrote, tested on 3 machines with dos 6.22, 3 machines with dosbox (windows and mac) around 8-9 versions of game (polish, english and spanish versions). All ends with same result.

Post Reply