Tech assistance needed

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

Post Reply
Peter Piers
Posts: 6
Joined: Thu Jul 13, 2017 11:58 am

Tech assistance needed

Post by Peter Piers » Thu Jul 13, 2017 2:17 pm

Hello, and greetings to everyone. I've been an avid fan of adventure games for a very, very long time now, and so of course I've been using ScummVM for years, along with other retro-gaming emulators and tools like DOSBox, VMWare and the like.

I've recently (past few months - maybe six? Seven? Ok, not so recently) unearthed a problem in my computer. It is NOT related to ScummVM, but it DOES affect it. It affects only very specific and very recent programs, of which ScummVM 1.9.0 happens to be one. It does not affect 1.8.1, which I'm still using.

The reason I've come here is that, this place being full of technically minded people, I thought someone could help me track this issue down and resolve it. ScummVM 1.9.0 is my benchmark, and I'm surely in the right place to find out what changed between 1.8.1 and 1.9.0 that could cause it. :)

The problem is an application error, code 0xc0000142. I have done some google-research, and although I'm not too technically minded, I've grasped the general gist: dll trouble, possibly connected to .NET or Visual C++ or something that some Malware did or... well, hard to track, really. The following links have been helpful in understanding the problem and trying to sort it: ... xc0000005/ ... xc0000142/ ... ion-error/

The programs that I have noticed to be affected by this issue are:

Latest version of ScummVM (duh);
Latest version of PCSX2 (a PS2 emulator);
NVIDIA's "GeForce Experience" program

I'm not one for modern games, but I have a feeling that if I were I'd be getting this error a lot more often.

The various methods which I have tried and which have failed to sort the issue are:

- Completely uninstall, restart, and reinstall Visual C and the .NET framework (at first I let Windows Update install them for me, and when that didn't work I tried to also install some older versions, linked to in the "troubleshooter" and "freewisdom" links I pasted above).

- Search for malware and run the modern equivalent of ScanDisk. In fact, I had done this just a few weeks ago, before I bought myself some extra RAM memory: Spybot, Malwarebytes and AVAST all running full throttle, followed by a scandisk of EVERY drive and defragmenting every drive that needed it. The problem was already there before I did all of this, and persisted afterwards.

- Uninstall unknown programs. Funny thing, I was just in the process of uninstalling a lot of crap yesterday when I realised it was high time I got this problem sorted; that's when I went at this full-on.

- Change the value of LoadAppInit_DLLs, from 1 to 0 and/or vice-versa. I did this with some trepidation, but it didn't do anything one way or the other.

- Update my NVIDIA card. I did, and right after the update "GeForce Experience" got installed (I didn't have it before). When I tried to run it and got the same error, I kinda new it hadn't worked.

- I wish I could uninstall and reinstall DirectX11, but apparently with Windows 7 (Ultimate, SP1) that's not so easily done. I had to leave Dx11 alone; if someone knows how I can reinstall or repair it, please let me know!

- Run the affected programs in compatibility and/or ADMIN mode. No joy.

- Used "Autoruns for Windows" to detect broken DLL libraries. Fortunately or UNfortunately, it detected no broken DLL libraries.

- Check for specific spyware which is known to cause these issues. Like I said before, I cleaned up thoroughly, so I haven't got it (but, who's to say it wasn't there before and did its damage before I cleaned up? But if so, how can I hope to undo the damage?).

- Use sfc /scannow. It cheerfully informed me it could see nothing wrong.


So... I was hoping I could get some specific help here because, although the problem is definitely with my system, this is something that DIDN't happen with ScummVM 1.8.1 (which I'm still using) and DOES with 1.9.0. Therefore, you guys and ScummVM may be my key to sorting this out:

Does anyone have any idea of what 1.9.0 might use, need, and rely on that 1.8.1 didn't? Something that I could reinstall/repair to finally get this sorted?


On an unrelated note, I also have some issues with a .dll, and simply replacing it hasn't helped. The problem is...

Entry Point Not Found
The procedure entry point TerminateProcess could not be located in
the dynamic link library api-ms-win-core-processthreads-l1-1-1.dll

...and although this does NOT affect ScummVM, and even the programs that it DOES affect still load and run normally after the error is displayed, I was just wondering whether anyone had any ideas. This issue has also been vexing me for quite a while. The following link is to another user experiencing this, and they seem to have pretty much the same issue. ... e-located/


Oh, and by the way... ScummVM is simply the best, but I'm sure you all know that. :)

Last edited by Peter Piers on Thu Jul 13, 2017 4:16 pm, edited 1 time in total.

Peter Piers
Posts: 6
Joined: Thu Jul 13, 2017 11:58 am

Post by Peter Piers » Thu Jul 13, 2017 2:19 pm

(unintended double-posting!)
Last edited by Peter Piers on Thu Jul 13, 2017 4:16 pm, edited 1 time in total.

Posts: 127
Joined: Mon Nov 06, 2006 2:04 pm

Post by MrPunchy » Thu Jul 13, 2017 2:37 pm

You should fix your computer, not the programs.

Peter Piers
Posts: 6
Joined: Thu Jul 13, 2017 11:58 am

Post by Peter Piers » Thu Jul 13, 2017 4:20 pm

Very true, and that's what I'm trying to do. ScummVM 1.9.0 suffers from this problem in my computer, and 1.8.1 doesn't. Therefore, having exhausted all other avenues (except format/reinstalled Windows, which you'll appreciate I'm not keen on doing), I thought I'd pop in here, because:

1) The people who maintain ScummVM might help me by pointing me towards what has been changed in ScummVM 1.9.0 that would need new dependancies, so I could focus on that;

2) I'm sure this place is full of technically minded people who would at least give me a few pointers, if I provide all the necessary information and if they have the time;

3) From experience, forums related to adventure gaming have always impressed me as being full of polite, helpful, technical individuals.

4) I tried, it seems, everything else. Otherwise I would not, of course, be bothering you with this.

I know it's not a ScummVM issue. It is, however, an issue with which, I hope, some developer of ScummVM might assist, or someone with the required knowledge of the 1.8.1 --> 1.9.0 shift.

TL;DR: I am indeed trying to fix my computer, not the program. For various reasons, this post was the logical next step.

EDIT - Naturally, if this is entirely out of scope for this forum, I won't insist.

User avatar
ScummVM Developer
Posts: 640
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy » Thu Jul 13, 2017 9:49 pm

Unfortunately it might not be so easy to use ScummVM to try to find out what is wrong. I don't know the details but I think there are quite a lot of differences between the 1.8.1 and 1.9.0 builds for Windows as the person who built it changed between those two versions, which probably means the tools used to build it also changed (for example the compiler version is probably different, and the Windows devkit used might be different). I think another change is the added dependency to the WinSparkle DLL (for the optional update availability check). Also the SDL version used might be different (version 1.8.1 probably uses SDL 1.2, but version 1.9.0 might use SDL2 - I am not sure about that; SDL2 is now used on some systems but I am not sure it is the case for Windows yet).

Note: I assume you are using version There were some issues with the initial 1.9.0, and then releases, but I don't remember what they were.

Peter Piers
Posts: 6
Joined: Thu Jul 13, 2017 11:58 am

Post by Peter Piers » Thu Jul 13, 2017 10:57 pm

Ok, thanks for that info. I knew going in that this was going to be a long shot, but it's still the most promising one I had left.

Yes, I meant Lazy writing on my part, sorry.

Peter Piers
Posts: 6
Joined: Thu Jul 13, 2017 11:58 am

Post by Peter Piers » Fri Jul 14, 2017 10:27 pm

Sorry to disturb again, I just have a thought that may be helpful. Maybe this would be easier to answer.

Let's imagine a totally clean Windows 7 environment. I mean totally clean. No Visual C++, no .NET. Not even Adobe Flash Player, or audio/video codecs, or Quicktime. Not even DirectX (since it's built-in with Win7 and it can't be uninstalled this seems highly unlikely, but bear with me). A working but gutted Windows 7.

I am assuming that ScummVM (let me just shorten it to 1.9 for the moment) will not work in that environment. I am basing that assumption on the fact that installing it, using the provided installer, gives me that error I mentioned. This means that the installer doesn't provide EVERYTHING ScummVM needs because there are some things which WILL be present in every system except a purposefully gutted one.

So the question is, and maybe this is easier to answer and will help me more - what will have to be installed to get ScummVM 1.9 to run in that hypothetical gutted system?

Or, if it helps, I could ask the question backwards. What would I have to methodically REMOVE from a normal Win7 system in order for ScummVM 1.9 to stop working?


I just thought of something I haven't tried yet - running ScummVM 1.9 on XPMode (virtual machine). It's not a solution, won't even help me sort my issue, but I guess if I want to run it then I can - I'm fairly confident it'll work. :) But this is only a ScummVM patch which doesn't address my problem, so if anyone could help me by answering either or both of the questions in the previous two paragraphs, I'd be very very thankful!

ScummVM Developer
Posts: 417
Joined: Wed Sep 21, 2005 12:15 pm
Location: Melbourne, Victoria, Australia

Post by Kirben » Fri Jul 14, 2017 11:18 pm

Try the Windows Daily Snapshots I provide, which should hopefully provide a recent working ScummVM version.

Unfortunately ScummVM 1.9.x used a different build system, and I'm not sure what extra requirements that caused.

Peter Piers
Posts: 6
Joined: Thu Jul 13, 2017 11:58 am

Post by Peter Piers » Tue Jul 18, 2017 6:56 pm

Well, it was worth a try. :) Thanks anyway!

Post Reply