Blade Runner WIP

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

peterkohaut
Posts: 7
Joined: Tue Sep 13, 2016 4:51 pm

Re: Blade Runner WIP

Post by peterkohaut » Fri Jan 04, 2019 10:35 pm

That was my goal, to have it released in scummvm in November 2019 :)
To my knowledge, pathfinding is the last major part missing but it is being worked on. Then there are some minor features as autosave or proper manual video skipping. Also are still few issues which we know about like - characters refuse to die properly :P and on top of that, there is plenty of bugs which we don't know about yet...
I don't have any experience with scummvm project playtesting, but I guess it will help and it will be welcomed. Mainly for issues with game logic (not engine features) as the game is randomized on each run.

WienerWuerstel
Posts: 2
Joined: Tue Jul 10, 2018 12:33 pm

Re: Blade Runner WIP

Post by WienerWuerstel » Sun Jan 27, 2019 7:24 pm

peterkohaut wrote:
Fri Jan 04, 2019 10:35 pm
That was my goal, to have it released in scummvm in November 2019 :)
To my knowledge, pathfinding is the last major part missing but it is being worked on. Then there are some minor features as autosave or proper manual video skipping. Also are still few issues which we know about like - characters refuse to die properly :P and on top of that, there is plenty of bugs which we don't know about yet...
I don't have any experience with scummvm project playtesting, but I guess it will help and it will be welcomed. Mainly for issues with game logic (not engine features) as the game is randomized on each run.
A release in 2019 would be quite the achievement :D
Thanks for all the work and progress on this Engine. Especially in the last couple weeks. Hope you get enough sleep :wink:
I am currently playtesting the game (This is the first time playing this game btw and I didn't watch the movie) and it works quite well so far, except for the obvious pathfinding issues. Now I have to restart my playthrough though, because it seems that me starting a new game (to watch the Intro I skipped at first) or some of the recent changes seem to have broke my save data. I'm able to load just fine but poor Ray can't move anymore.
The terminal output just states that I click on nothing.

EDIT: Nope, it seems that save files break for me even when I don't start a new game or update ScummVM.

peterkohaut
Posts: 7
Joined: Tue Sep 13, 2016 4:51 pm

Re: Blade Runner WIP

Post by peterkohaut » Mon Jan 28, 2019 8:24 am

I'm sleeping enough & well, thanks:)
There are many issues in scripts which i'm trying to fix, for example it was impossible to start 3rd act... so i recommend to use everyday nightly when there are any commits to bladerunner on github.
About your issue I experienced that only once, please, try opening debug console via CTRL+D and typing "goal 0 0" and "anim 0 0" without quotes, that should reset mccoy character.
If there are any bugs before official playtesting (like this) I recommend to contact me on irc at #scummvm channel

WienerWuerstel
Posts: 2
Joined: Tue Jul 10, 2018 12:33 pm

Re: Blade Runner WIP

Post by WienerWuerstel » Mon Jan 28, 2019 10:25 am

Thanks for the response and good to hear that you sleep well. Sadly the commands didn't work but maybe I'll figure out somehow how to get him moving again (without having to start a new game again). I'm going to report any bugs that I encounter in the future on IRC, like you suggested.

Praetorian
Posts: 43
Joined: Tue May 08, 2007 8:54 am

Re: Blade Runner WIP

Post by Praetorian » Mon Jan 28, 2019 1:43 pm

WienerWuerstel wrote:
Mon Jan 28, 2019 10:25 am
Thanks for the response and good to hear that you sleep well. Sadly the commands didn't work but maybe I'll figure out somehow how to get him moving again (without having to start a new game again). I'm going to report any bugs that I encounter in the future on IRC, like you suggested.
As a temporary workaround, try to wait for a bit without clicking on anything, after loading a savegame with this particular issue. McCoy gets "unfrozen" (the other actors too along with him) on his own after a while.

Edit: I think I may have found a possible reason for this issue. There's a count-down timer before actor animations start to get updated and that counter is currently not reset after loading a save-game. Reseting it seems to fix the issue (hopefully it doesn't break anything else).

peterkohaut
Posts: 7
Joined: Tue Sep 13, 2016 4:51 pm

Re: Blade Runner WIP

Post by peterkohaut » Thu Jan 31, 2019 8:55 am

in newer nightly builds, this timer can be reset in debugger console by command "timer 0 5 10", it means set timer for actor 0 (mccoy), timerid 5 (animation update) , timeleft = 10 (setting it to 0 will stop the timer altogether)

Post Reply