Search found 301 matches

by marzipan
Fri Nov 25, 2005 4:23 pm
Forum: General Discussion
Topic: Feeble Files and Simon the Sorcerer 1/2 md5 details required
Replies: 48
Views: 53816

Newbie alert! =P Although I was actually part of the old forums anyway So this is why I get a "cracked versions aren't supported!" message when trying to use the data files from my copy of Simon 1 Floppy that I had backed up on media a while back? =( I remember when trying to use it originally (afte...