Search found 697 matches

by criezy
Mon Nov 04, 2019 1:41 pm
Forum: Android Port
Topic: strange problem with the android version
Replies: 7
Views: 1915

Re: strange problem with the android version

pako14 wrote:
Mon Nov 04, 2019 1:24 pm
... sorry, what mieans ETA?
ETA = Estimated Time of Arrival. So in this case it indicates the release date for the ScummVM 2.1 version on Android (and "no ETA" means we don't know yet when it will be released).
by criezy
Mon Oct 28, 2019 11:25 pm
Forum: iPhone Port
Topic: Compiling 2.2.0 - Crashes upon launch of game
Replies: 5
Views: 1989

Re: Compiling 2.2.0 - Crashes upon launch of game

I have added a comment in the build instructions on the wiki about the need to disable bitcode generation in the build settings. As far as I know this is only needed when you build for a Generic iOS Device as when you build specifically for your device this should be disabled by default (unless this...
by criezy
Wed Oct 23, 2019 11:13 pm
Forum: iPhone Port
Topic: please someone provide a working scummvm ios 11 64bit build
Replies: 35
Views: 11756

Re: please someone provide a working scummvm ios 11 64bit build

I have now recompiled the iOS packages for the 2.1.0 release to enable MT-32. So you may want to give it a go.

And good point for buildbot. We might want to build a 64 bit iOS version instead of 32 bit.
by criezy
Tue Oct 22, 2019 8:36 pm
Forum: iPhone Port
Topic: Compiling 2.2.0 - Crashes upon launch of game
Replies: 5
Views: 1989

Re: Compiling 2.2.0 - Crashes upon launch of game

See https://wiki.scummvm.org/index.php?title=Compiling_ScummVM/iPhone for up to date build instructions. In particular It has a link to a newer lib package that contains the libcurl and sdlnet libraries needed to enable cloud and LAN support (and then you no longer need to disable those). It indicat...
by criezy
Tue Oct 22, 2019 8:05 pm
Forum: Help and Support
Topic: Cloud support for game files?
Replies: 3
Views: 1323

Re: Cloud support for game files?

Something like that, except that the download from the cloud of the game data is not automatic. And also it apparently doesn't work with Google Drive. See the User Manual for details.
by criezy
Mon Oct 21, 2019 2:04 pm
Forum: Help and Support
Topic: Installation snapshot question
Replies: 8
Views: 1484

Re: Installation snapshot question

I suspect the substitution is done when writing the line to the file. For the $i it needs to be done when running the script. I don't know how your system handles this, but you would need to escape the $ of $i, which is typically done using a backslash, to avoid the substitution happening when writi...
by criezy
Sun Oct 20, 2019 5:37 am
Forum: Help and Support
Topic: ScummVM 2.1 - macOS crashes
Replies: 16
Views: 2558

Re: ScummVM 2.1 - macOS crashes

I am wondering if with the software getting bigger with each release we might have hit some kind of limits in the executable size or stack memory usage on PPC macs. One thing you could try is to compile ScummVM with just one (or a few engines) and see if the application then opens properly (for exam...
by criezy
Fri Oct 18, 2019 10:05 pm
Forum: iPhone Port
Topic: please someone provide a working scummvm ios 11 64bit build
Replies: 35
Views: 11756

Re: please someone provide a working scummvm ios 11 64bit build

Indeed the MT-32 emulator is not enabled in this build. This is mostly an oversight from myself as it used to be too power hungry for iPhones and iPads and was thus disabled, and I never updated my build instructions despite MT-32 working quite well now on those (I have now update my build script, s...
by criezy
Wed Oct 16, 2019 11:25 pm
Forum: Help and Support
Topic: ScummVM 2.1 - macOS crashes
Replies: 16
Views: 2558

Re: ScummVM 2.1 - macOS crashes

The PPC version becomes harder to generate with each release, at least for me, and I almost didn't make one for this release. The only system I have to test it is a Mac OS X 10.6 intel iMac, which means it uses Rosetta to run the PPC executable. This is far from ideal. This latest release works prop...
by criezy
Sat Oct 12, 2019 8:29 pm
Forum: Help and Support
Topic: VS1.HLZ missing?
Replies: 5
Views: 1504

Re: VS1.HLZ missing?

This file is one of the game file from Versailles 1685. It is used for fallback detection of the game (checking if you might have an unknown version of the game) and the message you see is a debug message. You can ignore it.
by criezy
Sat Oct 12, 2019 8:22 pm
Forum: Help and Support
Topic: MacOS Catalina support?
Replies: 30
Views: 6577

Re: MacOS Catalina support?

I'm glad it's all fixed!
And thank you for all the tests you have done in the past few days.
by criezy
Sat Oct 12, 2019 2:49 pm
Forum: Help and Support
Topic: ScummVM 2.1 - macOS crashes
Replies: 16
Views: 2558

Re: ScummVM 2.1 - macOS crashes

There was an issue with the original 2.1.0 macOS release which has now been fixed. You can see some details on https://bugs.scummvm.org/ticket/11197. If you download again from https://www.scummvm.org/downloads/#stable it should now work.
by criezy
Sat Oct 12, 2019 2:24 pm
Forum: Help and Support
Topic: MacOS Catalina support?
Replies: 30
Views: 6577

Re: MacOS Catalina support?

And I think we found the issue with the official release. I have updated the 2.1.0 release package, and if you download it again this one will hopefully work for you now.
by criezy
Sat Oct 12, 2019 11:09 am
Forum: Help and Support
Topic: MacOS Catalina support?
Replies: 30
Views: 6577

Re: MacOS Catalina support?

Great. So at least there is one source of recent builds that you can use :-)
This also rules out the SDL library being the issue since I rolled out the same one on buildbot as I am using for the official release.
by criezy
Fri Oct 11, 2019 1:18 am
Forum: Help and Support
Topic: MacOS Catalina support?
Replies: 30
Views: 6577

Re: MacOS Catalina support?

Thank you. This last crash report makes a lot more sense. From what I can see iIt seems to point to a bug in macOS Catalina when it customize the touch bar when an application starts.This is probably triggered by something we do in ScummVM and that changed between version 2.0.0 and 2.1.0, but I can'...