Search found 16 matches

by waltervn
Fri Jan 04, 2019 11:25 am
Forum: General Discussion
Topic: Mystery House - how to play ?
Replies: 2
Views: 1242

Re: Mystery House - how to play ?

I don't know if there's anything different about the Mac port, but normally you should select the directory that contains the mysthous.dsk file, not the file itself. Does that work?
by waltervn
Thu Feb 08, 2018 9:29 am
Forum: General Discussion
Topic: Sierra Hi-Res adventures - availability on modern media
Replies: 9
Views: 3920

Were the Apple II versions of Ulysses and Cranston Manor ever re-released in such a way? No, at least not as far I know. Perhaps GOG might consider releasing all the Hi-Res titles in a compilation package (once ScummVM supports them all). We do support them all now, at least the Apple II versions. ...
by waltervn
Mon Mar 27, 2017 8:18 am
Forum: Help and Support
Topic: Macintosh music in SCI games
Replies: 7
Views: 3150

So the sci_sound branch worked great for the following 256 color games currently supported in ScummVM: - King's Quest V - Space Quest IV Great. :) error: uninitialized read for temp 1 from method : : export 0 (room 155, script 175, localCall ffffffff)! This error does not occur in ScummVM 1.9 but o...
by waltervn
Mon Mar 13, 2017 10:39 pm
Forum: Help and Support
Topic: Real OPL3 Support?
Replies: 3
Views: 2323

Sorry for the late reply. Playback through real hardware is currently only supported on ALSA (Linux). Windows support might be added at a later date (most likely using inpout32).
by waltervn
Mon Mar 13, 2017 10:08 pm
Forum: Help and Support
Topic: Macintosh music in SCI games
Replies: 7
Views: 3150

I wrote new sound code for SCI0 and SCI1 Mac games a few years ago, but it's not available in master yet. If you're feeling adventurous, you can try it out by compiling the 'sci_sound' branch at https://github.com/waltervn/scummvm/tree/sci_sound
by waltervn
Fri Sep 30, 2016 1:01 pm
Forum: General Discussion
Topic: Adventure History in the Mystery House (ADL testing)
Replies: 16
Views: 9432

albadross wrote:Same complaint about congratulations message disappearing too quickly.
Could you file a bug report for this?
by waltervn
Sun Dec 26, 2010 11:45 am
Forum: Help and Support
Topic: Kings Quest VI Problems W/Video
Replies: 4
Views: 3065

Re: Kings Quest VI Problems W/Video

1) The Windows version and the DOS version play the same music, where the Windows version should play the (or at least be given an option to pick) "extended level midi" that was exclusive to the Windows version of the game. "Extended level MIDI" is less capable than General MIDI. I don't know how t...
by waltervn
Wed Dec 15, 2010 1:05 pm
Forum: General Discussion
Topic: Weird Quest For Glory 3 issues
Replies: 18
Views: 14626

Just to clear this up a bit (sorry for the late reply)... For technical reasons we had to split up several categories. Currently SCI01 refers only to the S.old.* series of interpreters.
by waltervn
Fri Nov 26, 2010 3:16 pm
Forum: Help and Support
Topic: King's Quest 4 SCI MT-32 problem
Replies: 42
Views: 16696

In SCI0, reverb is always reset before every song. Okay, that's interesting. May I point out that ScummVM currently does not do that? I guess a call to setReverb should be inserted into some place like sendInitCommands after all? We are aware of this. The code is still work-in-progress. I'll let yo...
by waltervn
Fri Nov 26, 2010 3:06 pm
Forum: Help and Support
Topic: King's Quest 4 SCI MT-32 problem
Replies: 42
Views: 16696

Based on that, I might surmise that B1 50 could mean "change the reverb for this song, but change it back afterwards". But that's just an educated guess, someone more familiar with the inner workings of SCI should look at this. In SCI0, reverb is always reset before every song. I will look into the...
by waltervn
Thu Nov 25, 2010 12:43 pm
Forum: Help and Support
Topic: King's Quest 4 SCI MT-32 problem
Replies: 42
Views: 16696

I still can't reproduce Raziel's missing music issue, though. I commented on Hubert's bug report. The things he describes in his last comment all seem normal to me. Thanks for finding the checksum bug, it should now be fixed. Regarding the reverb issue. This is missing functionality and it cannot b...
by waltervn
Wed Nov 24, 2010 4:55 pm
Forum: Help and Support
Topic: King's Quest 4 SCI MT-32 problem
Replies: 42
Views: 16696

Thanks!
by waltervn
Wed Nov 24, 2010 4:13 pm
Forum: Help and Support
Topic: King's Quest 4 SCI MT-32 problem
Replies: 42
Views: 16696

Sven, in ScummVM, start up KQ5. Then press CTRL-D to enter the debugger, and type "diskdump patch 1". I think it's written to the current directory (not sure...). Put that file into the KQ5 directory. Then edit it with a hex editor and change the byte that indicates the default reverb. I don't know ...
by waltervn
Wed Nov 24, 2010 3:37 pm
Forum: Help and Support
Topic: King's Quest 4 SCI MT-32 problem
Replies: 42
Views: 16696

Sven, could you try changing the default reverb setting in the KQ5 patch.1, and see if you actually get the corresponding sysex anywhere? (In DOSBox, that is). My initial impression is that in SCI1 the default is always reverb 0, no matter what the patch says. But I might be missing something somewh...
by waltervn
Wed Nov 24, 2010 2:27 pm
Forum: Help and Support
Topic: King's Quest 4 SCI MT-32 problem
Replies: 42
Views: 16696

Sven, current findings are as follows: The default reverb setting in the MT-32 patch is not handled the same in all versions of SCI, even for the versions that have the same MT-32 patch format. An old comment of mine in the code suggests that SCI1 doesn't use the default reverb setting at all. I wil...