Search found 36 matches

by AReim1982
Mon Mar 12, 2018 8:53 am
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

@cecilmax:
-> /backends/platform/wii/osystem_events.cpp
by AReim1982
Fri Mar 09, 2018 4:03 pm
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

Sure... :)
by AReim1982
Fri Mar 09, 2018 1:47 pm
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

@cecilmax: this toolchain is only for Linux. There are Windows variants of devkitPPC built with MinGW. But I do not know if it's possible to compile ScummVM in this way. You also have to compile all dependencies youself.
by AReim1982
Fri Mar 09, 2018 11:57 am
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

@cecilmax: I made some changes on the toolchain, please download it again. Tutorial (Linux) 1. Download the toolchain -> https://github.com/AReim1982/binaries/tree/master/Toolchains 2. Extract the toolchain to the path: /opt/devkitpro 3. Open a terminal and work with admin privileges -> su 4. Instal...
by AReim1982
Tue Mar 06, 2018 10:09 am
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

@cecilmax:
you can download the sources from GitHub:
-> https://github.com/scummvm/scummvm

If you want to use my toolchain, you can download it here:
-> https://github.com/AReim1982/binaries/t ... Toolchains
by AReim1982
Wed Feb 14, 2018 9:09 am
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

@Dusemir: You and seanf101 described 2 different problems. Seanf101 wrote that the gamefiles of the two Zork games are not detected by ScummVM. The reason is that may a ScummVM version is used, where the Z-Vision engine is not compiled in. Now your problem... ;-) Several games needs minutes to start...
by AReim1982
Sat Feb 10, 2018 9:48 am
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

@seanf101:
The official downloads from the Buildbot doesn‘t support the Z-Vision engine. If you use the „Test-Candidate v2.0.0“ the Z-Vision engine works.
by AReim1982
Wed Jan 10, 2018 3:28 pm
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

@msSeven:
I never tried it, but it should already work:
-> https://bugs.scummvm.org/ticket/6262
by AReim1982
Thu Dec 28, 2017 4:28 pm
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

Currently I don‘t own that game.
Can you post a screenshot of the code dump please?
by AReim1982
Wed Dec 27, 2017 9:43 am
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

Update!
-> http://www.mediafire.com/file/4dyerl33k ... wii-b2.zip

News:
- Sherlock Holmes - Case Of The Rose Tattoo: Fix "Out Of Memory" errors during the intro and the gameplay (pull request: #1092)
by AReim1982
Tue Dec 19, 2017 10:28 am
Forum: Wii Port
Topic: Scummvm 2.0 for wii?
Replies: 2
Views: 2269

by AReim1982
Tue Dec 19, 2017 10:27 am
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

by AReim1982
Thu Apr 06, 2017 1:43 pm
Forum: Wii Port
Topic: Keyboard support?
Replies: 82
Views: 102004

@rorysl:
Try the following Version (1.9), it uses a newer DevKit + Libs:
-> viewtopic.php?t=13357
by AReim1982
Fri Feb 24, 2017 1:09 pm
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

@Rikcahrd:
Some month ago I wrote a converter for the Sword25 engine to shrink the resolution to 640x480 and convert the pixelformat to RGB565. The video output is not a problem anymore, but I get "out of memory" errors. The WII doesn't have enough ram (~64MB) and the cpu is maybe not fast enough.
by AReim1982
Mon Feb 06, 2017 1:05 pm
Forum: Wii Port
Topic: Test-Candidate of ScummVM 2.0.0 for WII
Replies: 149
Views: 80558

Update! -> !OLD! http://www.mediafire.com/file/y01mvf9yadu9bq9/scummvm-1.9.0-wii-b3.zip News: - updated toolchain: devkitPPC R28 + LibOGC 1.8.16 + LibFAT 1.1.0 - updated libraries: Freetype 2.7, Jpeg 9B, LibPNG 1.5.28, ZLib 1.2.11, FLAC 1.2.1, LibMAD 0.15.1b, Tremor - support for Z-Vision engine (Z...