ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > GP2X/GP2XWiz/Caanoo Port > Problem When Installing To Caanoo
Problem When Installing To Caanoo
  Author    Thread Reply to topic
mike909



Joined: 11 Jan 2011
Posts: 5
Problem When Installing To Caanoo 

Hello,

At first I'd like to say that I'm really thankful that I can play my favorite adventure games on my Caanoo! Thanks a lot DJWillis!

But I'd also like to point out a problem I had when installing it. (Version 1.2.1) When I put the Scummvm folder and .ini file in my "games" folder and tried to boot it up, it did not work at first; it would instead hang at the "Loading" screen and then go back to the main menu.

I found that renaming the file extension of the file "scummvm.gph" to "scummvm.caanoo" made Scummvm finally work. Very Happy

I just wanted to point this out because I have heard that other people have had this problem. I just thought you would like to be aware of this just in case you wanted to re-release the it with the right extension.

Thanks again!

mike909

 Reply with quote  
Post Tue Jan 11, 2011 10:00 pm 
 View user's profile Send private message
DJWillis
ScummVM Porter


Joined: 26 Oct 2005
Posts: 174
 

Damm,

Looks like I managed to mix up the archive, I'll get that fixed up. The binaries are identical but there is a small typo in one of the scripts (as you noticed) Sad. I tested the one with the fixed script and uploaded the one with the broken script Surprised.

Edit: I have now fixed this and the 1.2.1 download for the Caanoo contains the fixed script.

John

 Reply with quote  
Post Wed Jan 12, 2011 9:26 am 
 View user's profile Send private message
lord_garfio



Joined: 12 Jan 2011
Posts: 4
 

Hello:

I've downloaded the scummvm 1.2.1 for the caanoo and it hangs on starstup.

It needs to change something in any file ?

Thanks for your help

 Reply with quote  
Post Wed Jan 12, 2011 4:22 pm 
 View user's profile Send private message
DJWillis
ScummVM Porter


Joined: 26 Oct 2005
Posts: 174
 

If you downloaded the 1.2.1 release before the script was fixed just rename "scummvm.gph" to "scummvm.caanoo" (as suggested in the first post).

You only need to do this if the ScummVM menu is not showing up and it is hanging on the Caanoo loading screen.

The other fix is to just re-download Wink.

 Reply with quote  
Post Wed Jan 12, 2011 6:04 pm 
 View user's profile Send private message
mike909



Joined: 11 Jan 2011
Posts: 5
 

Thanks for the quick response! Smile

edit: I also noticed that I can play Curse of Monkey Island and Touche in version 1.2.0 but not in 1.2.1. Is there a way I can fix this? Sad

 Reply with quote  
Post Thu Jan 13, 2011 12:39 am 
 View user's profile Send private message
lord_garfio



Joined: 12 Jan 2011
Posts: 4
 

Hello:

Many thanks for your quick response. I've tried both options and still hanging on startup. I think i have something wrong on my caanoo.

thanks again,
Juan

 Reply with quote  
Post Thu Jan 13, 2011 11:19 am 
 View user's profile Send private message
DJWillis
ScummVM Porter


Joined: 26 Oct 2005
Posts: 174
 

quote:
Originally posted by lord_garfio
Hello:

Many thanks for your quick response. I've tried both options and still hanging on startup. I think i have something wrong on my caanoo.

thanks again,
Juan


Hi Juan,

Do the files scummvm.stderr.txt or scummvm.stdout.txt in the /game/scummvm folder have any contents. This may give you a clue as to what may be going on.

quote:
Originally posted by mike909
I also noticed that I can play Curse of Monkey Island and Touche in version 1.2.0 but not in 1.2.1. Is there a way I can fix this? Sad


Mike,

I'll look into this, pretty sure I checked COMI in my testing but I'll dig the Caanoo out later and make sure.
 Reply with quote  
Post Thu Jan 13, 2011 6:42 pm 
 View user's profile Send private message
DJWillis
ScummVM Porter


Joined: 26 Oct 2005
Posts: 174
 

mike909, lord_garfio,

I have just tested the 1.2.1 build I made on my Caanoo and it seems to work well for both normal and high resolution games (as well as 1.2.0 did). I did however notice something odd with SF.Net. When I download 1.2.1 from SourceForge I seem to actually get 2 versions of the Caanoo 1.2.1 release depending on the mirror Surprised.

One version is dated (from the main menu) "ScummVM 1.2.1 (Dec 30 2019 20:05:32)" - This version has a small typo that caused the menu not to pop up but also has a tiny bug (read: copy and paste error) that breaks high resolution games.

The other version is dated (from the main menu) "ScummVM 1.2.1 (Dec 30 2019 19:05:55)" - This version is the 'real' 1.2.1 release and works fine with high resolution games and does not have the typo in one of the launch scripts.

I think I have got to the bottom of what happened. If your remotely interested this is what I stuffed up.

I originally uploaded the 20:05:32 build to SF.Net but realised as soon as I had done this that I had uploaded the wrong release (from a development folder). I then replaced that build right away with the 19:05:55 version, checked that it uploaded correctly with a download and test and then carried on with announcing the release.

For some reason when I downloaded the 1.2.1 release from SF.Net yesterday to look at mike909's issue it downloaded the 20:05:32 release from one of the SF.Net mirrors (still not sure what it is doing on mirrors when it has been replaced Surprised). I then fixed the menu typo and re-uploaded the file, replacing the working 19:05:55 version that was on most mirrors with a known buggy release.

I have re-uploaded the 19:05:55 to SF.Net after manually deleting the 20:05:32 version from the file release folder and I hope this will sort out the inconsistency in the mirrors. However it may take a few hours for the mirrors to sort themselves out.

I would suggest you both download the 19:05:55 version (i.e. what I always intended to be the correct 1.2.1 release) from my site in the mean time and extract it to a clean folder on your SD cards. This should work just as you expect, high resolution games and launch scripts all correct Very Happy.

http://djwillis.openpandora.org/gph/scummvm-1.2.1-caanoo.tar.bz2

This is the MD5 hash for the correct 1.2.1 release for the Caanoo
0586f48f1d01737970693d45ae8df67b scummvm-1.2.1-caanoo.tar.bz2


Regards,

John

 Reply with quote  
Post Thu Jan 13, 2011 7:29 pm 
 View user's profile Send private message
mike909



Joined: 11 Jan 2011
Posts: 5
 

It works perfectly now! Smile Thanks so much for realizing and fixing these problems so quickly!

 Reply with quote  
Post Thu Jan 13, 2011 8:49 pm 
 View user's profile Send private message
lord_garfio



Joined: 12 Jan 2011
Posts: 4
 

Hi John:

Thank you very much for your job and for the quick responses.

I don't know what is happening becouse it still hanging on start up. I downloaded Scummvm from your page and it's the 20:05 version, and the same from Source forge.

Don't worry about this, i will search for the good version Wink .

Thanks again for your great job a for your quick responses.

Best regards,
Juan

 Reply with quote  
Post Thu Jan 13, 2011 9:48 pm 
 View user's profile Send private message
Ooglor7



Joined: 19 Jan 2011
Posts: 4
 

This program is currently not working for many Caanoo users. No matter what place it is downloaded from, it just offers a gray loading screen. We have tested it on several different SG cards which are working fine with any of the other Caanoo apps and emus.

 Reply with quote  
Post Wed Jan 19, 2011 12:50 am 
 View user's profile Send private message
Ooglor7



Joined: 19 Jan 2011
Posts: 4
 

I have dowmloaded this program 5 times now from various places. One was a direct link from someone who claims it runs fine for them. That is not the case for many people who have downloaded this. We are still getting a gray loading screen to nowhere.

 Reply with quote  
Post Wed Jan 19, 2011 12:54 am 
 View user's profile Send private message
Ooglor7



Joined: 19 Jan 2011
Posts: 4
 

The problem seems to be how the file is compressed and Windows 7. I downloaded a program called Universal Extractor and used that to open the file and it finally worked. It seemed to keep the file in a Tar format and I think Winzip I was using, was not doing this. If you are just ending up with a gray loading screen, as I was, try opening it with the Universal Extractor. It is free.

 Reply with quote  
Post Thu Jan 20, 2011 5:33 pm 
 View user's profile Send private message
Ooglor7



Joined: 19 Jan 2011
Posts: 4
 

Thanks to mike909 for helping me figure this out.

 Reply with quote  
Post Thu Jan 20, 2011 5:34 pm 
 View user's profile Send private message
lord_garfio



Joined: 12 Jan 2011
Posts: 4
 

Thanks to all for your help and quik responses. Noe Scummvm works fine.

Thanks again

 Reply with quote  
Post Thu Jan 20, 2011 10:03 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge