ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Nintendo DS Port > DSTT Failed scummvm startup - Touch screen blank Goto page 1, 2  Next
DSTT Failed scummvm startup - Touch screen blank
  Author    Thread Reply to topic
kevlarrelic



Joined: 10 Sep 2008
Posts: 2
DSTT Failed scummvm startup - Touch screen blank 

Scummvm hangs on my DSTT before it can start up, leaving the bottom screen blank. What makes this strange is that I've used scummvm with no problems on this same DSTT before.

Just now I tried reinstalling scummvm to play Day of the Tentacle and discovered it would no longer work. Monkey Island and Sam and Max are the two that played fine before, however I've reformatted my card several times since then.

AFAIK scummvm should work on the DSTT without dldi patching, right? I am pretty sure I didn't have to patch it the first time I installed it, but I ain't positive. All of my other homebrew still works fine never having patched them.

All the powers of google and a search of these forums wasn't able to tell me what the problem is, so I was hoping you guys could help.

When I run the scummvm-a.nds file, the last thing that appears on the upper screen before freezing is something along the lines of "Zip file found!". I also tried running it through the scummvm-a.ds.gba file and came up with a much more interesting error:

DLDI Driver not patched!
DLDI initialize failed.
DLDI Driver not patched!
DLDI initialize failed.

No file system was found.
View readme file for more information.

Since the DSTT auto patches DLDI, and scummvm supports that kind of thing, I assume DLDI isn't really the problem?

So I was thinking that maybe it was a recent update of the DSTT firmware that is incompatable with scummvm, so is there another DSTT owner on here who can confirm if scummvm does or does not work with current firmware?

Sorry for being so long winded about the whole thing, I just got done with hours of trying to make it work and am still thinking out loud.

Thanks for your help!

 Reply with quote  
Post Wed Sep 10, 2008 6:12 am 
 View user's profile Send private message
tomten



Joined: 16 Oct 2006
Posts: 139
Re: DSTT Failed scummvm startup - Touch screen blank 

quote:
Originally posted by kevlarrelic
Since the DSTT auto patches DLDI, and scummvm supports that kind of thing, I assume DLDI isn't really the problem?
Depends on how the auto-patching is done. If it's transparent to ScummVM, it won't work. Try patching manually.
 Reply with quote  
Post Wed Sep 10, 2008 6:32 am 
 View user's profile Send private message
iPwnzorz



Joined: 06 Jan 2007
Posts: 301
Location: Hampshire, England
 

Why don't you try patching..?

 Reply with quote  
Post Wed Sep 10, 2008 6:33 am 
 View user's profile Send private message
agentq
ScummVM Porter


Joined: 21 Dec 2005
Posts: 806
Location: London, UK
 

If you get the 'Zip file found!' message, remove the cartridge in your GBA slot and try again.

 Reply with quote  
Post Wed Sep 10, 2008 7:55 am 
 View user's profile Send private message
kevlarrelic



Joined: 10 Sep 2008
Posts: 2
 

quote:
Originally posted by agentq
If you get the 'Zip file found!' message, remove the cartridge in your GBA slot and try again.


Oh thank you Jesus and hallelujah, that fixed it! I got the GBA ez flash expansion after I got scummvm to work the first time, so that would do it I guess.

So it doesn't like GBA cartriges, huh? Is it something to do with my specific hardware combination, or is it for all GBA stuff? Just out of curiosity, of course, now that my problem is solved thanks to agentq.

Time for me to foil the plans of an evil tentacle. Thanks again!
 Reply with quote  
Post Wed Sep 10, 2008 6:32 pm 
 View user's profile Send private message
Jimbob



Joined: 31 Oct 2005
Posts: 305
Location: Somewhere in the UK
 

Apologies for digging up this thread but I received a DSTT card this morning and the second thing I tried on it was ScummVM. I've downloaded the 0.13.0 beta zip file from the first post in the forum but all I get are black screens, the top screen displays: -

DLDI Device:
'TTCARD IO Library '
DLDI Driver Initialised OK!

Now, I'm pretty new to using DS homebrew stuff but ZXDS worked first time.

Can anyone help? The only DLDI patcher available to me is DLDI Drop for OS X and that doesn't have the DSTT card listed. I'm not even sure if I'm able to ask for help with the DSTT card, I don't think it's on the supported cards list.

Thanks,

Jimbob

 Reply with quote  
Post Sat Feb 21, 2009 11:11 am 
 View user's profile Send private message
tomten



Joined: 16 Oct 2006
Posts: 139
 

quote:
Originally posted by Jimbob
DLDI Device:
'TTCARD IO Library '
DLDI Driver Initialised OK!

This looks right. Can you try an older version, like the latest 0.12.x version?
 Reply with quote  
Post Sat Feb 21, 2009 11:18 am 
 View user's profile Send private message
Red_Breast



Joined: 30 Sep 2008
Posts: 785
Location: The Bar Of Gold, Upper Swandam Lane.
 

A similar message comes up on my CycloDS Evo at the top then the classic (memory limitations) menu at the bottom.
So that's how it should be.
Strange.
The builds at the top are Ender's.
Agentq made some builds in a post further down. Maybe try them as well.
http://forums.scummvm.org/viewtopic.php?t=6161
Good luck.

 Reply with quote  
Post Sat Feb 21, 2009 1:48 pm 
 View user's profile Send private message
Jimbob



Joined: 31 Oct 2005
Posts: 305
Location: Somewhere in the UK
 

Yeap, the 0.12.0 beta 4 builds appear to be working (well Indiana Jones and The Fate of Atlantis is working).

Thank you for your help!!

 Reply with quote  
Post Sat Feb 21, 2009 2:32 pm 
 View user's profile Send private message
hyperhaggis



Joined: 08 Mar 2009
Posts: 1
 

I have the same problem with my NDSTT in that it shows the top screen but nothing on the bottom for me to add my games. I've tried the 0.11 and 0.12 builds with no success. Can someone help me please?

 Reply with quote  
Post Sun Mar 08, 2009 1:01 am 
 View user's profile Send private message
Abby90



Joined: 16 May 2009
Posts: 1
 

quote:
Originally posted by hyperhaggis
I have the same problem with my NDSTT in that it shows the top screen but nothing on the bottom for me to add my games. I've tried the 0.11 and 0.12 builds with no success. Can someone help me please?



I get this
DLDI Device:
'TTCARD IO Library '
DLDI Driver Initialised OK!

too.

I have also tried other versions. 12, 11 and the new one. But I see at the bottom of the screen nothing.

I use NDTT..
 Reply with quote  
Post Sat May 16, 2009 9:39 am 
 View user's profile Send private message
marzipan



Joined: 25 Nov 2005
Posts: 301
 

I should point out that it's not really ScummVM DS disliking Slot-2 cartridges, but more about what kind of content is on them. I had this problem before many a moon ago (thread should still exist if you care to find it), and it seems if whatever content you have on your EZ-Flash is zip-compressed, ScummVM DS will notice that and assume you want to load games through the old 'GBA Flash Cart' method. So if you'd prefer to keep your cartridge inside when using the program, overwrite its NOR space with something else.


Simple really!

 Reply with quote  
Post Sun May 17, 2009 12:19 am 
 View user's profile Send private message
Ilpo



Joined: 08 Mar 2010
Posts: 1
 

I have this same black screen problem. Top screen displays:
DLDI Device:
'DSTT DLDI(boyakkey ver.)'
DLDI Driver Initialised OK!

I have tried older versions didnt work. I use DSTT. Can anyone help?

 Reply with quote  
Post Mon Mar 08, 2010 1:50 pm 
 View user's profile Send private message
tanij



Joined: 18 Mar 2010
Posts: 2
 

I'm having a little trouble too sorry..

I'm getting:

DLDI Device
TTCARD IO Library
DLDI Driver Initialised OK

but nothing appears on the touchscreen. The weird part about it is that it worked for about a day with Day of the Tentacle and Monkey Island 2 but now doesn't seem to work at all.

I'm using an R4 and have tried versions 0.13.1 and 1.0.0.

Sorry to post this is an older thread..any help at all though would be awesome : )

 Reply with quote  
Post Thu Mar 18, 2010 7:30 am 
 View user's profile Send private message
Red_Breast



Joined: 30 Sep 2008
Posts: 785
Location: The Bar Of Gold, Upper Swandam Lane.
 

quote:
Originally posted by tanij


I'm using an R4 and have tried versions 0.13.1 and 1.0.0.



So you're not trying with the latest version.
 Reply with quote  
Post Thu Mar 18, 2010 1:07 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 
Goto page 1, 2  Next


Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge