ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Wii Port > Fate of Atlantis: Strange issues with Lost dialogue of Plato
Fate of Atlantis: Strange issues with Lost dialogue of Plato
  Author    Thread Reply to topic
ICEknight



Joined: 07 Jun 2008
Posts: 44
Fate of Atlantis: Strange issues with Lost dialogue of Plato 

I've been trying FoA and I've noticed that sometimes, when I first find the lost dialogue of Plato and read it, after exiting the book screen I'd get "teleported" to some previous scene like I was loading a savestate (with just the same items I had back then and all).

Has anybody else had this weird bug? This happened in the previous version, either if I looked at the book after finding it or when Sophia took a look when talking to her (I had to skip that sequence).


I'll try with the newest version soon, just in case it was already fixed.

 Reply with quote  
Post Sat Jun 07, 2008 4:38 pm 
 View user's profile Send private message
eriktorbjorn
ScummVM Developer


Joined: 31 Oct 2005
Posts: 3300
Re: Fate of Atlantis: Strange issues with Lost dialogue of P 

quote:
Originally posted by ICEknight
I've been trying FoA and I've noticed that sometimes, when I first find the lost dialogue of Plato and read it, after exiting the book screen I'd get "teleported" to some previous scene like I was loading a savestate (with just the same items I had back then and all).


From what I remember, the game actually does make a "secret" save game just before you read the dialog, which it restores afterwards. But I have no idea why it would load the wrong one.
 Reply with quote  
Post Sat Jun 07, 2008 6:24 pm 
 View user's profile Send private message
dhewg
ScummVM Porter


Joined: 04 Jun 2008
Posts: 169
 

yes, please try rev 32565 i posted here: http://wiibrew.org/wiki/Homebrew_apps/ScummVM

there was a savegame issue on the prior version, maybe its related.

 Reply with quote  
Post Sat Jun 07, 2008 6:53 pm 
 View user's profile Send private message
ICEknight



Joined: 07 Jun 2008
Posts: 44
 

I seems to works fine now, thanks.

 Reply with quote  
Post Mon Jun 09, 2008 2:24 pm 
 View user's profile Send private message
msliczniak



Joined: 11 Jul 2008
Posts: 3
I have the same problem 

The thing is I have been using 32565 from the beginning. I just went and downloaded again from the link and did a cmp of the two tar balls and they are identical. (scummvm-20080605233742.tgz)

I have been having other save game issues as well. On time in FoA I saved and then later when I wanted to load the game it said something like invalid save file or some such instead of the usual save #. I loaded it and it worked fine. But when I ran into this problem detailed by ICEknight I thought that was the problem and I started from an earlier save game before the corrupted one and eventually I reached the same lost dialogue part and the same result occurred.

I also remember thinking one time when I was playing Sam & Max that I must have forgotten to save since the save that I loaded was way earlier with respect to the things I had done. Now I think this may have been a save game issue as well, like it loaded not the one I selected but an earlier one. This could have been stupidity of some sort on my part though.

 Reply with quote  
Post Fri Jul 11, 2008 1:47 pm 
 View user's profile Send private message
msliczniak



Joined: 11 Jul 2008
Posts: 3
work around 

I was able to figure-out a work-around and I have some more info that can be useful for fixing this bug.

What I did is I put the SD card in the reader on my Mac. Then I did this:

code:
eMac:scummvm aga$ ls
AUTHORS      atlantis.s02   ft.s00      maniac-v1-1.s00   samnmax.s03
COPYING      atlantis.s03   ft.s01      meta.xml   samnmax.s04
COPYRIGHT   atlantis.s04   ft.s02      modern.ini   samnmax.s05
NEWS      atlantis.s05   icon.png   modern.zip   scummvm.ini
README      atlantis.s06   igor.tbl   queen.tbl   sky.cpt
READMII      atlantis.s07   iq-points   samnmax.c26   tentacle.s00
atlantis.c99   atlantis.s08   kyra.dat   samnmax.s00   tentacle.s01
atlantis.s00   boot.dol   lure.dat   samnmax.s01
atlantis.s01   classic080.ini   m4.dat      samnmax.s02
eMac:scummvm aga$ mv atlantis.s0[01234567] ~/wiihd/
mv: /Users/aga/wiihd/atlantis.s00: set flags (was: 00200000): Operation not permitted
mv: /Users/aga/wiihd/atlantis.s01: set flags (was: 00200000): Operation not permitted
mv: /Users/aga/wiihd/atlantis.s02: set flags (was: 00200000): Operation not permitted
mv: /Users/aga/wiihd/atlantis.s03: set flags (was: 00200000): Operation not permitted
mv: /Users/aga/wiihd/atlantis.s04: set flags (was: 00200000): Operation not permitted
mv: /Users/aga/wiihd/atlantis.s05: set flags (was: 00200000): Operation not permitted
mv: /Users/aga/wiihd/atlantis.s06: set flags (was: 00200000): Operation not permitted
mv: /Users/aga/wiihd/atlantis.s07: set flags (was: 00200000): Operation not permitted




The mv actually did work, now only atlantis.s08 was left. This was the point in the game when I had the "Lost Dialogue of Plato". I started scummvm from the homebrew channel and loaded that save game. It was the only one at the eighth slot in the list.

Then I looked at the "Lost Dialogue of Plato" and when I did the '-' button I was right where I should have been instead of some other save game. Great I thought. I went to the menu and then to the load game screen and now I saw one thing odd. The autosave slot had the same game in it now as the one in save game 8 and even had the same name, save 8 instead of the usual auto save name.

Then I walked to the office and after talking with Sofia it had me look at the book automatically again. This time after pressing '-' I ended-up back at the same save again, ie the problem was back.

So what I think is going on is some earlier save gets picked if you have any saves, probably the auto save one.

I was able to work around it again this time by going to the office and as sofia was talking with me, pressing '-' for ESC and it skipped the whole look at the book go back to an earlier save issue.

I hope there is now enough info here to help solve this problem. I can provide the save file right before the problem if anyone is interested and thinks it may help in solving the bug.
 Reply with quote  
Post Sat Jul 12, 2008 5:10 pm 
 View user's profile Send private message
msliczniak



Joined: 11 Jul 2008
Posts: 3
rev 33083 seems to fix this issue 

Thank you dhewg, I just tried it again with rev 33083 (scummvm-20080716124536.zip) and it seems to fix this issue once and for all.

I was about to make a new post about Sam & Max Hit the Road crashing with rev 32565 at the point when you float in the fiberglass fish but I tried that in rev 33083 and it works! Thank you again to all scummvm devs! There is a slight pause and then the game continues with rev 33083, while with the previous build it crashed back to the Homebrew channel.

 Reply with quote  
Post Fri Jul 18, 2008 4:22 am 
 View user's profile Send private message
dhewg
ScummVM Porter


Joined: 04 Jun 2008
Posts: 169
 

sorry for the massive delay, i was.. uhm... <insert excuse here>

i'm glad the fix worked, enjoy Smile

 Reply with quote  
Post Sat Aug 09, 2008 7:46 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge