ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Nintendo DS Port > ScummVM DS 0.11.1 beta1 released for testing!
ScummVM DS 0.11.1 beta1 released for testing!
  Author    Thread Reply to topic
agentq
ScummVM Porter


Joined: 21 Dec 2005
Posts: 806
Location: London, UK
ScummVM DS 0.11.1 beta1 released for testing! 

Hi Everyone,

Since there were bugs found in a few of the ScummVM engines, ScummVM 0.11.1 will be release to fix them. There are no new features compared to the 0.11.0 release.

Here is the first beta version of the 0.11.1 release of ScummVM DS. It needs lots of testing, since there are so many games that I don't have time to do much of it myself. So please download it. Please post, even it it works fine!

http://scummvm.drunkencoders.com/scummvmds0-11-1beta1.zip


Supported Games


Build A:
Manic Mansion
Zak McKracken and the Alien Mindbenders
Indiana Jones and the Last Crusade
Loom
Passport to Adventure
The Secret of Monkey Island
Monkey Island 2: LeChuck's Revenge
Indiana Jones and the Fate of Atlantis
Day of the Tentacle
Sam & Max Hit the Road
Bear Stormin' (DOS version only)
Fatty Bear's Birthday Surprise (DOS version only)
Fatty Bear's Fun Pack (DOS version only)
Putt-Putt's Fun Pack (DOS version only)
Putt-Putt Goes to the Moon (DOS version only)
Putt-Putt Joins the Parade (DOS version only)

Build B:
Beneath a Steel Sky
Flight of the Amazon Queen

Build C:
Simon the Sorcerer 1/2
Elvira 1/2
Waxworks (Amiga version only)

Build D:
Sierra AGI games
Gobliiins 1 - 3
Bargon Attack
Ween: The Prophecy
Future Wars

Build E:
Inherit the Earth


Edit: Added Waxworks


Last edited by agentq on Thu Feb 21, 2008 6:05 pm; edited 1 time in total

 Reply with quote  
Post Mon Feb 18, 2008 11:14 pm 
 View user's profile Send private message
tomten



Joined: 16 Oct 2006
Posts: 139
Re: ScummVM DS 0.11.1 beta1 released for testing! 

quote:
Originally posted by agentq
Supported Games
Build C:
Simon the Sorcerer 1/2
Elvira 1/2

And Amiga WaxWorks, right?
 Reply with quote  
Post Mon Feb 18, 2008 11:23 pm 
 View user's profile Send private message
agentq
ScummVM Porter


Joined: 21 Dec 2005
Posts: 806
Location: London, UK
Re: ScummVM DS 0.11.1 beta1 released for testing! 

quote:
Originally posted by tomten
quote:
Originally posted by agentq
Supported Games
Build C:
Simon the Sorcerer 1/2
Elvira 1/2

And Amiga WaxWorks, right?


Yes, sorry I forgot that.

So, anyone tested this version? Tagging is on Saturday, so if there are any bugs, I need to know now!
 Reply with quote  
Post Thu Feb 21, 2008 6:05 pm 
 View user's profile Send private message
tomten



Joined: 16 Oct 2006
Posts: 139
Re: ScummVM DS 0.11.1 beta1 released for testing! 

quote:
Originally posted by agentq
So, anyone tested this version? Tagging is on Saturday, so if there are any bugs, I need to know now!
The main menu still says "0.11.0".

I've had some strange experiences... the Start button stopped functioning in simon2, and simon1 and waxworks wouldn't load. I'll do more testing and get back.

EDIT: The start button has never functioned in simon2. I was confused.

Last edited by tomten on Fri Feb 22, 2008 7:23 pm; edited 1 time in total
 Reply with quote  
Post Thu Feb 21, 2008 6:57 pm 
 View user's profile Send private message
johnzo



Joined: 03 Dec 2007
Posts: 20
Location: PA, USA
 

I did a quick round of testing with the new version, 1 from each build.

samnmax, boots fine, loads save, everything normal.

Beneath a steel sky, everything good, played around for 10 minutes, loads and saves fine.

Simon1, didn't load, I tried 2 times and waiting 5-10 seconds, tried to get the menu to come up, but nothing happened. I have been able to boot this version in previous versions.

bargon attack, watched intro everything seems good

kyrandia, boots and loads fine

 Reply with quote  
Post Fri Feb 22, 2008 12:09 am 
 View user's profile Send private message Visit poster's website AIM Address
agentq
ScummVM Porter


Joined: 21 Dec 2005
Posts: 806
Location: London, UK
 

Just tried Simon1, and it works fine for me. Which version of the game do you have? Mine is the Windows CD version.

 Reply with quote  
Post Fri Feb 22, 2008 6:32 pm 
 View user's profile Send private message
tomten



Joined: 16 Oct 2006
Posts: 139
 

quote:
Originally posted by agentq
Just tried Simon1, and it works fine for me. Which version of the game do you have? Mine is the Windows CD version.
How long does it take to load? For me, there's almost half a minute from "Start" until the mouse key icon appears on the top screen. I can't remember whether it's always been like this.

EDIT: Simon 1 DOS VGA non-talkie, DS-Xtreme.
 Reply with quote  
Post Fri Feb 22, 2008 6:53 pm 
 View user's profile Send private message
agentq
ScummVM Porter


Joined: 21 Dec 2005
Posts: 806
Location: London, UK
 

12 seconds for me on GBAMP CF. If was definately faster before though.

 Reply with quote  
Post Fri Feb 22, 2008 7:18 pm 
 View user's profile Send private message
tomten



Joined: 16 Oct 2006
Posts: 139
 

The start button doesn't do anything (except skipping) in Simon1/2. Isn't it supposed to bring up the ScummVM menu?

EDIT: Sorry, I realize I've been playing too much Monkey Island... =] Simon1/2 seem to work, they just take long to load. I'll try Waxworks some more, I felt it behaved strangely last I tried.


Last edited by tomten on Fri Feb 22, 2008 7:21 pm; edited 1 time in total

 Reply with quote  
Post Fri Feb 22, 2008 7:20 pm 
 View user's profile Send private message
agentq
ScummVM Porter


Joined: 21 Dec 2005
Posts: 806
Location: London, UK
 

No, it doesn't. You need to use the postcard to save or load.

 Reply with quote  
Post Fri Feb 22, 2008 7:21 pm 
 View user's profile Send private message
johnzo



Joined: 03 Dec 2007
Posts: 20
Location: PA, USA
 

That's my bad, I waited longer and it did come up. I tried it twice earlier and let it go for like 5-10 seconds with no luck, guess I was just impatient. I don't remember it taking that long before, but it's no big deal, once it loads the game runs fine.

fyi, I'm using an R4.

 Reply with quote  
Post Fri Feb 22, 2008 10:24 pm 
 View user's profile Send private message Visit poster's website AIM Address
tomten



Joined: 16 Oct 2006
Posts: 139
 

quote:
Originally posted by tomten
I'll try Waxworks some more, I felt it behaved strangely last I tried.
Setting the mouse to hover and then using dpad left/right to click doesn't work in the AGOS games (tried Waxworks and Elvira1). (This is was caused me to think the game had "hung" etc.) I don't know whether this worked in earlier versions. In WW left-clicking using the dpad seems to do something, just not left-clicking. In E1, it seems to do nothing.

EDIT: The AGOS games are very hard to control on the NDS without the hover mode (there's a lot of pixel-hunting involved, which means you must see the exactly where the cursor is before you click), which is why I didn't even try the "normal" mode first.

EDIT: Other than this, I haven't noticed anything strange.

EDIT: Could someone with a cardreader other than DS-Xtreme comment on the speed of the AGOS games? WW is so sluggish for me at times that it's hard to play (there can be almost a second from a forward click until you move forward). I'd like to know if the cardreader make makes any difference. (Since for the loading time for Simon1 it obviously does)
 Reply with quote  
Post Sat Feb 23, 2008 9:22 am 
 View user's profile Send private message
another world



Joined: 23 Feb 2008
Posts: 117
 

I've pulled my amiga disk files out (10 for waxworks) and loaded them onto my Micro SD. The latest "C" build of ScummVM DS does not seem to find the files. It tells me that no game files can be found.

Not sure if its my copy or what, or if I'm missing something. Can anyone confirm that it does indeed load?

-AW

 Reply with quote  
Post Mon Feb 25, 2008 10:42 pm 
 View user's profile Send private message
tomten



Joined: 16 Oct 2006
Posts: 139
 

quote:
Originally posted by another world
Not sure if its my copy or what, or if I'm missing something. Can anyone confirm that it does indeed load?
I've tried both using the floppy version and the HD version, and they both work.

http://wiki.scummvm.org/index.php/Datafiles#Waxworks

It's about 420 files. I don't know if there's any difference between the HD and floppy versions; after copying all the floppy files into one directory it looks very similar to the contents of the HD version.
 Reply with quote  
Post Mon Feb 25, 2008 10:49 pm 
 View user's profile Send private message
Maturion



Joined: 21 Nov 2007
Posts: 11
 

This is an awesome port! Thank you!

 Reply with quote  
Post Sat Mar 15, 2008 6:13 pm 
 View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge