ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > PocketPC/WinCE Port > No speech in Broken Sword 1 in 0.10.0
No speech in Broken Sword 1 in 0.10.0
  Author    Thread Reply to topic
fenix



Joined: 09 Apr 2006
Posts: 3
No speech in Broken Sword 1 in 0.10.0 

I was using ScummVM 0.9.1 before which was able to play BS1 with sound speech and music. With 0.10.0 only the sound effects works. I am using exactly the same datafiles.

 Reply with quote  
Post Sun Jul 22, 2007 8:25 am 
 View user's profile Send private message
eriktorbjorn
ScummVM Developer


Joined: 31 Oct 2005
Posts: 3303
Re: No speech in Broken Sword 1 in 0.10.0 

quote:
Originally posted by fenix
I was using ScummVM 0.9.1 before which was able to play BS1 with sound speech and music. With 0.10.0 only the sound effects works. I am using exactly the same datafiles.


Did you arrange the files into sub-folders inside the main game data folder? One thing that changed - I think it was between 0.9.x and 0.10.x - is that ScummVM no longer looks inside every sub-folder, only the ones the engine itself specifies. In the case of Broken Sword 1 that's clusters, music, speech and video.

Does that help?
 Reply with quote  
Post Sun Jul 22, 2007 8:35 am 
 View user's profile Send private message
fenix



Joined: 09 Apr 2006
Posts: 3
Re: No speech in Broken Sword 1 in 0.10.0 

quote:
Originally posted by eriktorbjorn
quote:
Originally posted by fenix
I was using ScummVM 0.9.1 before which was able to play BS1 with sound speech and music. With 0.10.0 only the sound effects works. I am using exactly the same datafiles.


Did you arrange the files into sub-folders inside the main game data folder? One thing that changed - I think it was between 0.9.x and 0.10.x - is that ScummVM no longer looks inside every sub-folder, only the ones the engine itself specifies. In the case of Broken Sword 1 that's clusters, music, speech and video.

Does that help?


The speech files are located in the SPEECH subfolder under the game data folder. Wouldn't that work?
 Reply with quote  
Post Sun Jul 22, 2007 8:59 am 
 View user's profile Send private message
eriktorbjorn
ScummVM Developer


Joined: 31 Oct 2005
Posts: 3303
Re: No speech in Broken Sword 1 in 0.10.0 

quote:
Originally posted by fenix

The speech files are located in the SPEECH subfolder under the game data folder. Wouldn't that work?


It should. In fact, it does for me. Does it make any difference if you move the speech files out of the SPEECH folder and into the main data folder? (If so, is it possible that the folder name has some spaces in it, or something like that? Those can be hard to notice.)
 Reply with quote  
Post Sun Jul 22, 2007 9:40 am 
 View user's profile Send private message
knakos
ScummVM Porter


Joined: 02 Nov 2005
Posts: 424
Location: Athens, Greece
 

Make sure that the "path" variable under section "[sword1]" in your scummvm.ini points to the parent folder (which contains the folder substucture eriktorbjorn suggests). e.g. it should be "path=\Storage Card\scummvm-games\bsword1\" and not "path=\Storage Card\scummvm-games\bsword1\Clusters".

 Reply with quote  
Post Sun Jul 22, 2007 10:03 am 
 View user's profile Send private message
eriktorbjorn
ScummVM Developer


Joined: 31 Oct 2005
Posts: 3303
Re: No speech in Broken Sword 1 in 0.10.0 

quote:
Originally posted by eriktorbjorn
It should. In fact, it does for me.


I should, perhaps, clarify that I'm trying this with the Linux version, since I don't have a PocketPC. I'm just assuming it works more or less the same.
 Reply with quote  
Post Sun Jul 22, 2007 10:22 am 
 View user's profile Send private message
TeknoJuce



Joined: 23 Dec 2007
Posts: 10
 

quote:
Originally posted by knakos
Make sure that the "path" variable under section "[sword1]" in your scummvm.ini points to the parent folder (which contains the folder substucture eriktorbjorn suggests). e.g. it should be "path=\Storage Card\scummvm-games\bsword1\" and not "path=\Storage Card\scummvm-games\bsword1\Clusters".


Thanks was having this problem in WinCE SCUMM 0.10.0, that fixed it now I have video and speech Very Happy but I just used the internal edit SCUMM path, there like 2 different cutscene packs does one format use less resources then another as the mp2/ogg stalls a bunch on a 4ooMhz processor would the dxa use less or more resources?
 Reply with quote  
Post Thu Dec 27, 2007 1:44 am 
 View user's profile Send private message
TeknoJuce



Joined: 23 Dec 2007
Posts: 10
 

I changed to the DXA video pack and it runs smooth now.

 Reply with quote  
Post Thu Dec 27, 2007 4:00 am 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge