ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Help and Support > Mouse cursor jumps randomly to corners of the screen, win10 Goto page Previous  1, 2
Mouse cursor jumps randomly to corners of the screen, win10
  Author    Thread Reply to topic
infoseek2304



Joined: 13 Nov 2017
Posts: 4
 

Does opengl (no iltering) work?

 Reply with quote  
Post Sat Nov 25, 2017 4:43 pm 
 View user's profile Send private message
mictand



Joined: 14 Nov 2017
Posts: 5
 

I can also confirm that the Kirben build fixes the mouse cursor issue.

 Reply with quote  
Post Sat Nov 25, 2017 8:32 pm 
 View user's profile Send private message
harcalion



Joined: 29 Nov 2017
Posts: 1
 

Hello, nice people of this forum. This is my first post and of course it has to be a problem even if I have happily used ScummVM for many years. Thank you to everyone who has contributed.

Now the rant.

Using Kirben builds doesn't work for me. The behaviour is exactly the same whether I use ScummVM 1.8 (the build that comes with Kyrandia 3 from GOG) or any of the latest builds (Kirben or dailybot).

This is the INI file for the latest game, Kyrandia 3 - Malcolm's Revenge, displaying the issue (only custom option is the gfx_mode set to opengl_linear, no filtering):

code:

[scummvm]
last_fullscreen_mode_height=2880
speech_volume=192
native_mt32=false
midi_gain=100
last_fullscreen_mode_width=5120
talkspeed=60
gfx_mode=opengl_nearest
subtitles=false
multi_midi=false
fullscreen=true
themepath=E:\GOG Games\Legend of Kyrandia - Malcolms Revenge\ScummVM\
sfx_volume=192
music_volume=192
speech_mute=false
lastselectedgame=kyra3
music_driver=auto
aspect_ratio=true
versioninfo=1.9.0
autosave_period=300
enable_gs=false

[kyra3]
description=The Legend of Kyrandia: Malcolm's Revenge (DOS/English)
skip_support=true
savepath=E:\GOG Games\Legend of Kyrandia - Malcolms Revenge
path=E:\GOG Games\Legend of Kyrandia - Malcolms Revenge
helium_mode=false
gameid=kyra3
language=en
platform=pc
studio_audience=true
guioptions=sndNoMIDI vga gameOption1 gameOption2 gameOption3 lang_English




In windowed mode it works fine.
Additional info: it happens in computers with and without touchscreen or touchpad. It happens switching among several mice. I also place the start of the problem around the time when Windows 10 FCU was installed.

I will try to debug the problem if I manage to set up a ScummVM development environment.

EDIT: Launching the game from the ScummVM GUI makes the problem go away with any configuration that I have tested. It seems it is the GOG shortcut (scummvm -c path/to/ini.file game_name) which causes the issue for some reason. I have also realised that OpenGL nearest is no longer required for a non-filtered experience. Great!
 Reply with quote  
Post Wed Nov 29, 2017 2:03 pm 
 View user's profile Send private message
DX3M



Joined: 05 Nov 2017
Posts: 4
Solved with Kirden build 

I can also confirm the Kirden build fixed the mouse jumping issue, thanks for all the responses!

 Reply with quote  
Post Sun Dec 31, 2017 2:02 am 
 View user's profile Send private message
DjDiabolik



Joined: 02 Feb 2006
Posts: 47
 

mmmmmmmm... i have the same issue at today.......

I have try "Curse Of Monkey Island ITALIAN" on a windows 10 whit the latest daily build 64bit and the mouse jump around the screen randomly whitout any sense.

The Daily 32 bit download from main site not resolve the issue... how i can try ?

 Reply with quote  
Post Wed Jan 03, 2018 12:26 pm 
 View user's profile Send private message
DX3M



Joined: 05 Nov 2017
Posts: 4
 

quote:
Originally posted by DjDiabolik
mmmmmmmm... i have the same issue at today.......

I have try "Curse Of Monkey Island ITALIAN" on a windows 10 whit the latest daily build 64bit and the mouse jump around the screen randomly whitout any sense.

The Daily 32 bit download from main site not resolve the issue... how i can try ?


try this Kirben build, not the buildbot ones it worked for me Wink

quote:
Originally posted by rootfather
For everybody who is still having this issue or frequent crashes: Please try the Win32 builds provided by Kirben instead of the ones made by the buildbot.

You can find them at http://scummvm.org/downloads/scummvm-win32.exe

I could reproduce the issues with the buildbot dailys, but not with the Kirben builds. The thing is that the buildbot still uses SDL 1.2.15 which has a lot of issues with the current Windows version while the builds made by Kirben have SDL2. SDL1 is not maintained anymore and severly outdated, while SDL2 is the current version. (SDL is the library we use for video, sound and input handling on most of our supported platforms).

 Reply with quote  
Post Wed Jan 03, 2018 6:31 pm 
 View user's profile Send private message
DjDiabolik



Joined: 02 Feb 2006
Posts: 47
 

mmmmmmmmmmm... i have download this:
http://www.scummvm.org/downloads/scummvm-win32.exe

But it's at win32......... i prefer to use the w64 but there's no Kirben build.......

 Reply with quote  
Post Sun Jan 14, 2018 3:59 pm 
 View user's profile Send private message
blam666



Joined: 30 Jan 2018
Posts: 3
Any new vs. that fixes mouse problems AND bilinear f.? 

Hmm, I have been looking for weeks now for a scummvm version that includes all the 2.0 game compatibilities, but doesn't have these two problems:

Mouse Jumping (as described in this thread) & graphical artefacts with bilinear filtering turned on.

The second problem I encountered on two different freshly updated Win 10 systems by now. The last line of the picture gets depicted on the opposite side of the screen, leading to quite annoying artefacts/glitches.

I noticed the other daily builds seem to have gotten rid of that problem by now, but they all let the mouse jump around to almost unplayability of many games at my systems. Now the Kirben build has proper mouse, but the bilinear artefacts are there again.

I know I could just turn off bilinear filtering or choose OpenGL to avoid artefacts, but all other picture modes seem to be either too sharp/edgy or too blurry to be enjoyable.

Have I missed some proper ScummVM version that's already around? Or shall I have to wait for further updates. Right now, unfortunately both problems are simply too severe to really enjoy the otherwise great and holy ScummVM platform at the moment...

 Reply with quote  
Post Tue Jan 30, 2018 5:36 pm 
 View user's profile Send private message
criezy
ScummVM Developer


Joined: 23 Sep 2006
Posts: 516
Location: West Sussex, UK
Re: Any new vs. that fixes mouse problems AND bilinear f.? 

quote:
Originally posted by blam666
The second problem I encountered on two different freshly updated Win 10 systems by now. The last line of the picture gets depicted on the opposite side of the screen, leading to quite annoying artefacts/glitches.
That sounds like https://bugs.scummvm.org/ticket/9643, which was a bug in SDL, and has been fixed, but too late for the ScummVM 2.0.0 release. There is no SDL release with this fix yet (I guess this will be available in SDL 2.0.8, whenever it is released).

Builds that use the older SDL 1.2 do not have this issue because they do not let SDL do the scaling. But they will indeed have the mouse issue described here.

Something that might work (according to the SDL documentation) is to use the Kirben build and set the SDL_RENDER_DRIVER windows environment variable to direct3d11 or opengl. Otherwise, until SDL 2.0.8 is available, you might need to compile ScummVM (or find somebody who can do it) after modifying the ScummVM source code as described in the link I gave above to work around the bug in SDL.
 Reply with quote  
Post Wed Jan 31, 2018 12:03 am 
 View user's profile Send private message
blam666



Joined: 30 Jan 2018
Posts: 3
 

Thanks a lot for the reply.

Modding the SDL environment to DX3d11 sounds good. I would like to give that a try.

Is there a link to a short tutorial how to do this?

(I actually don't even know what SDL really is, I just read about the term here in the forum. So compiling anything by myself actually scares the non-technical noob in me right now...)

 Reply with quote  
Post Wed Jan 31, 2018 5:39 am 
 View user's profile Send private message
criezy
ScummVM Developer


Joined: 23 Sep 2006
Posts: 516
Location: West Sussex, UK
 

SDL is a third party software library we use to create and manage the scummvm window, including the rendering of the window content to the screen.

Setting an environment variable is actually not specific to SDL. On Windows you would do it by going to the System control panel, then go to the Advanced system settings, and in the Advanced tab click on the Environment Variables... button. You can then edit, or add if it does not yet exist, the SDL_RENDER_DRIVER variable. Those instructions are based on Windows 7, they may differ for other versions of Windows.

 Reply with quote  
Post Wed Jan 31, 2018 10:38 am 
 View user's profile Send private message
blam666



Joined: 30 Jan 2018
Posts: 3
 

Ok, I found the windows panel and created SDL_RENDER_DRIVER entry.

But I'm not so sure which value to insert there. I just tried typing in "direct3d11", but nothing changes, I still get the artefacts when bilinear f. is selected.

What is the value to type in for setting the SDL driver to driect3d11?

 Reply with quote  
Post Wed Jan 31, 2018 2:50 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 
Goto page Previous  1, 2


Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge