ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Other Ports > Rasp3 retropie - Cursor working but trapped in bounding box
Rasp3 retropie - Cursor working but trapped in bounding box
  Author    Thread Reply to topic
Adfield



Joined: 17 May 2017
Posts: 1
Rasp3 retropie - Cursor working but trapped in bounding box 

Hi all,

I'm hoping somebody might be able to shed some light on why this is happening, i've posted it on the retropie forums too but haven't had much luck yet.

My plan was to use an air mouse as a sort of 'pointer' to control the point and click interface on my raspberry pi, similar to how Scummvm functions on the wii.

So i got hold of an old wiimote and a mayflash dolphin sensor bar which plugs in via USB. With the bar set to mode 2 (mouse and keyboard), the sensor bar translates the wiimote's IR signal into mouse movement.
I got this working to an extent, when in the scumm menu or with a game booted, the cursor moves freely (and surprisingly well!) but with one huge caveat: the cursor is confined to a small box in the upper left corner of the screen, and hits an invisible wall if you try and move it across the full width of the screen.

Strangely if i plug a regular mouse back in, the problem disappears and I regain full control of the screen again.

Pretty close to working but no dice, I'm hoping there's potentially a setting that needs altering somewhere?

Any ideas?

The help is hugely appreciated!

Thanks,

 Reply with quote  
Post Thu May 18, 2017 1:00 pm 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 802
 

Might need to modify xinput parameters for the Mayflash Dolphin Sensor Bar, which I assume acts to provide a Bluetooth host and protocol convertor which makes this appear as a USB mouse:
https://www.reddit.com/r/linux_gaming/comments/3nxnzg/mouse_stuck_in_topleft_corner_please_help/

Apart from that, we use libSDL to abstract mouse input so you may want to try with DOSBox (which also uses it or similar libSDL based application in Fullscreen) to see if you see the same behaviour.

Apart from that, you could try changing some of the mouse related libSDL environment variables which can fix issues with slightly "odd" mice and HID devices:
https://www.libsdl.org/release/SDL-1.2.15/docs/html/sdlenvvars.html
http://www.crutzi.info/xbmc-fullscreen-pointer-issues

 Reply with quote  
Post Fri May 19, 2017 11:41 am 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge