ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Other Ports > Keyboard hyper sensitive
Keyboard hyper sensitive
  Author    Thread Reply to topic
Tvel4



Joined: 26 Apr 2016
Posts: 3
Keyboard hyper sensitive 

Hello! Been trying to figure this out-- maybe someone might know the answer. I have scummVM running on my raspberry pi-- I have a wireless keyboard hooked up through USB but when I type-- say for instance in King's Quest 3- keystrokes are extremely sensitive-- so if I type a letter "h" -- 5 h's may pop up in my text box. It makes it really annoying trying to play txt based games. It doesn't always type multiple letters per keystroke but it does a lot of the time. Sometimes it depends how quick I hit a key. Any thoughts on why it might be doing this? Any solutions, suggestions or fixes? I appreciate the help!

Tom

 Reply with quote  
Post Tue Apr 26, 2016 6:20 pm 
 View user's profile Send private message
Tvel4



Joined: 26 Apr 2016
Posts: 3
 

I tried a different keyboard and a bunch of other games but didn't have much luck there. Could it be a setting in ScummVm maybe? Maybe a resolution problem? My ScummVM games look and sound perfect but as soon as you start typing things go downhill. Has anyone had his problem? If I write "look" it comes out "lllllooooooooooookkkk" heh, not fun-!

 Reply with quote  
Post Thu Apr 28, 2016 5:02 pm 
 View user's profile Send private message
LegendforHire



Joined: 04 May 2016
Posts: 3
 

Hi there.

I don't know much about Raspberry Pi, haven't used one yet, but the problem you describe sounds like either the software or the os isn't allowing a delay for the keyboard input.

Do you have the same problem elsewhere in other software on your Pi? If so then there must be a setting or command somewhere that will adjust the keyboard delay (I remember that there was/is such a setting in Windows).

 Reply with quote  
Post Thu May 05, 2016 6:01 pm 
 View user's profile Send private message
Tvel4



Joined: 26 Apr 2016
Posts: 3
 

Hi, thanks for the response! I haven't had keyboard problems in other applications i'm using on the Pi-- but perhaps there is an option to control the keyboard delay within the scumm settings. That gives me something to go on at least-- I'll see what I can find. Thanks again for weighing in.

Tom

 Reply with quote  
Post Fri May 06, 2016 3:11 am 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 813
 

Tvel4: The issue you are describing is the keyboard "Typematic Delay and Rate". On PCs, the default was configured in the BIOS (and then overridden by OS settings), but the RPi does not have that kind of BIOS.

Assuming you have Stock Raspbian Jessie with X and you haven't been fiddling with any of the low level bootloader settings, I would suggest that you may need to check the X.Org Keyboard Settings if you running ScummVM under X, rather than with SDL to the Framebuffer.

See:
https://wiki.archlinux.org/index.php?title=Keyboard_configuration_in_console&redirect=no#Adjusting_typematic_delay_and_rate

https://www.raspberrypi.org/forums/viewtopic.php?f=91&t=69467

I should say that I doubt the issue is within ScummVM directly, although it may be associated with the SDL Keyboard settings requested in the RPi backend. If you are comfortable with C++, I suggest you take a look at the code in scummvm/backend/events.

 Reply with quote  
Post Sun May 08, 2016 6:19 am 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge