ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > PocketPC/WinCE Port > Issues on IPAQ HX4700
Issues on IPAQ HX4700
  Author    Thread Reply to topic
mrpijey



Joined: 08 May 2006
Posts: 3
Issues on IPAQ HX4700 

I recently installed the newest version of ScummVM (v0.8.2) for my WM5-equipped HP Ipaq HX4700. And I noticed three issues that perhaps someone can shed some light on:

1: Sound lag.

In every game there is a slight sound delay, perhaps 1/3 second or so. For every animation where sound is synced (for example the fish jumping out of the water in the DOTT intro) the audio is delayed. It's quite noticable. Any way to change the audio sync?


2: Video refresh.

The video lags quite badly. One can actually see the screen refresh lines. If an entire screen moves there is a very noticable tearing in the image.


3: 1x vs 2x.

If using 0.8.2 with 1x the entire game selection menu and game covers less than 1/4 of the screen estate. If i put it on 1x then it fills the screen, but I can't rotate the image. When doing the same with 0.8.0CVS the 1x worked perfecty in fullscreen (with rotation possible) and with a lot less tearing of the animated images. Seems 0.8.2 and 2x slows down the graphics a lot. I tested to run it at 1x to see if the audio skips because of hardware speed limitation (fullscreen rendering) but the sound delay remained no matter what resolution it was rendered at. I used Adlib emulation for all tests (I don't believe anything else works anyway?). Sound skips happened in every PScummVM version I could find for the PocketPC platform.


3: Quitting.

Some games (like Flight Of The Amazon Queen) doesn't let me quit the game/app. If i tap the icon where the in-game popup comes up nothing happens. Is this anything specific for some games only or is it a bug? If the games themselves doesn't allow it then why not remove the icon for the games affected?

Anyone got any clues for any of this?

 Reply with quote  
Post Mon May 08, 2006 6:17 pm 
 View user's profile Send private message MSN Messenger
SirDave



Joined: 05 Nov 2005
Posts: 33
 

My guess is this has something to do with WM5 on the HP4700 (since my HP4705 with WM3 has no problems). Since many regular PocketPC games have required updates to include WM5 compatibility, the same may be true with PocketScumm. Or maybe this varies with WM5 on any particular model. Or both.

 Reply with quote  
Post Mon May 08, 2006 11:39 pm 
 View user's profile Send private message
knakos
ScummVM Porter


Joined: 02 Nov 2005
Posts: 424
Location: Athens, Greece
 

First of all, the issues (1) + (2) are related to (3). Also, please note that there is no perfect way to update the screen in wince in order to avoid tearing, one just hopes to do it as quickly as possible and that no-one notices. You have to live with a little bit of tearing and this is more obvious in the vga devices due to the increased screen data.

The 4700 has a vga display. The fact that you ran earlier versions using the 1x filter means that the vga display was not detected correctly, so scummvm ran in a special "qvga-to-vga" emulated mode. This is quite dodgy and is known to produce unexpeted results depending on the device vendor. Actually things should be slower in this case, but lets leave this out for the moment.

Now, newer versions correctly detect the vga display, requesting the use of the 2x filter. It may be that your processor cannot handle the real time stretching routines or it may be a bug in the vga code. Most probably it's the former case, as you experience performance loss all over the place.

Finally (3) must be something overlooked and should be straitforward to fix.

Hopefully, I'll be having a 9-round fight with scummvm this weekend and will be addressing these issues as well.

 Reply with quote  
Post Tue May 09, 2006 6:48 am 
 View user's profile Send private message
mrpijey



Joined: 08 May 2006
Posts: 3
 

I downgraded the HX to PocketPC 2003SE and had the same problems. Even if i managed to make the emulator run smoother (with less tearing) the sound skip was still as bad as with heavy screen tearing. So it looks to me there is some kind of late buffering or delay in the audio generation not related to slow display update. But then again I am not that skilled in programming engines like you guys =D

I can live with screen tearing and perhaps there will be a fix in the future. But the sound skip is quite annoying. And it happened on PPC2003SE also. Otherwise the PScummVM is excellent and I am amazed how much it can do on a platform such as PocketPC. So I hope these issues will be fixed in the near future so one can enjoy a perfect game of DOTT or MI2.

If i can help in any way (test unstable versions etc) let me know, I would love PScummVM to run flawlessly on my device =D

 Reply with quote  
Post Tue May 09, 2006 2:11 pm 
 View user's profile Send private message MSN Messenger
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge