ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Wii Port > Test-Candidate of ScummVM 1.9.0 for WII Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next
Test-Candidate of ScummVM 1.9.0 for WII
  Author    Thread Reply to topic
KillDashNin9



Joined: 11 Oct 2014
Posts: 3
 

I don't know if it is anything on my end, but I am trying to use a USB keyboard play some of the older Sierra agi/sci based games and noticed the enter key does nothing. To "press enter" I hit the 2 on the wii remote.

Anyone have any suggestions?

Thanks.

 Reply with quote  
Post Sun Oct 12, 2014 1:28 am 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 806
 

KillDashNin9: That sounds odd. I'd suggest trying earlier Wii releases of ScummVM to see if this is a regression, but I suspect it will probably be an issue with the AGI engine code for keyboard handling interacting with the Wii backend events code. If so, I should be able to debug and fix.

edit: I suggest you file a bug on the tracker about this and we can investigate:
http://sourceforge.net/p/scummvm/bugs/

 Reply with quote  
Post Sun Oct 12, 2014 10:49 am 
 View user's profile Send private message
KillDashNin9



Joined: 11 Oct 2014
Posts: 3
 

digitall: I did a few tests and will submit a bug report. Below are my findings. It looks like everything works under AGI but not SCI. I used Space Quest 1 as my agi sample and Space Quest 3 as my SCI sample.

Scummvm wii 1.5.0:
AGI: Enter key works
SCI: Wii crashes

Scummvm wii 1.6.0:
AGI: Enter key works
SCI: Enter key does not work (2 on the wii remote does).

Scummvm wii 1.7.0:
AGI: Enter key works
SCI: Enter key does not work (2 on the wii remote does).

Let me know if any further information could help.

 Reply with quote  
Post Sun Oct 12, 2014 7:20 pm 
 View user's profile Send private message
MusicallyInspired



Joined: 02 Mar 2007
Posts: 946
Location: Manitoba, Canada
 

I've finally found my homebrew SD card for my Wii and want to start using it again. Are any of the latest bugs mentioned here (close to being) ironed out as yet or...?

 Reply with quote  
Post Mon Oct 20, 2014 3:56 pm 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 806
 

MusicallyInspired: Not sure what bug exactly you are referring to. http://sourceforge.net/p/scummvm/bugs/6740/ is still open. I have yet to get time to look at it... busy IRL. Should get to it later today.

 Reply with quote  
Post Tue Oct 21, 2014 1:00 pm 
 View user's profile Send private message
AReim1982



Joined: 10 Dec 2013
Posts: 24
Location: Germany
 

@KillDashNin9:
I made some changes on the code. But I don't own some SCI Games. Could you please try this binary out:
-> http://www.mediafire.com/download/q2rbziq01emciqa/scummvm-1.7.0-wii-b2.zip


Last edited by AReim1982 on Wed Oct 22, 2014 1:50 pm; edited 2 times in total

 Reply with quote  
Post Tue Oct 21, 2014 2:31 pm 
 View user's profile Send private message
md5
ScummVM Developer


Joined: 03 Nov 2005
Posts: 2256
Location: Athens, Greece
 

quote:
Originally posted by AReim1982
@KillDashNin9:
I made some changes on the code. But I don't own some SCI Games. Could you please try this binary out:
-> http://www.mediafire.com/download/l1ge05hacg54r4d/scummvm-1.7.0-wii-b2.zip


Thanks for the changes. However, according to ScummVM's GPL licence, you also need to attach your changes to the code.
 Reply with quote  
Post Tue Oct 21, 2014 7:35 pm 
 View user's profile Send private message
AReim1982



Joined: 10 Dec 2013
Posts: 24
Location: Germany
 

quote:
Originally posted by md5
quote:
Originally posted by AReim1982
@KillDashNin9:
I made some changes on the code. But I don't own some SCI Games. Could you please try this binary out:
-> http://www.mediafire.com/download/q2rbziq01emciqa/scummvm-1.7.0-wii-b2.zip


Thanks for the changes. However, according to ScummVM's GPL licence, you also need to attach your changes to the code.

Changes to the code:
-> https://github.com/AReim1982/scummvm/commit/e738de70e51a1b348759d38756660e161567f991

If somebody confirms that my changes solves the bug above I will open a pull request.

Last edited by AReim1982 on Thu Oct 23, 2014 7:38 am; edited 1 time in total
 Reply with quote  
Post Wed Oct 22, 2014 7:05 am 
 View user's profile Send private message
AReim1982



Joined: 10 Dec 2013
Posts: 24
Location: Germany
 

Yesterday evening I tested my changes on King's Quest V and King's Quest VI. Now all keys seems to work. Later I will open a pull request on GitHub.

Last edited by AReim1982 on Thu Oct 23, 2014 8:11 am; edited 1 time in total

 Reply with quote  
Post Thu Oct 23, 2014 6:31 am 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 806
 

AReim1982: Thanks for doing this. Your change looks sensible and clear, so the PR should be merged quickly.

 Reply with quote  
Post Thu Oct 23, 2014 6:45 am 
 View user's profile Send private message
KillDashNin9



Joined: 11 Oct 2014
Posts: 3
 

@AReim1982

Sorry it has taken me awhile to get back. I have tested functionality with Space Quest 3 and things work great. Thank you for your work!

 Reply with quote  
Post Sat Oct 25, 2014 6:44 pm 
 View user's profile Send private message
MusicallyInspired



Joined: 02 Mar 2007
Posts: 946
Location: Manitoba, Canada
 

MT-32 emulation seems to be much more resource intensive than in previous versions. The sound stutters and slows down the game considerably while there is any animation going on on the screen. At least for SCI games. That's too bad. Sad

 Reply with quote  
Post Mon Oct 27, 2014 2:09 pm 
 View user's profile Send private message Send e-mail Visit poster's website AIM Address
AReim1982



Joined: 10 Dec 2013
Posts: 24
Location: Germany
 

@MusicallyInspired:
MT-32 emulation has only worked before ScummVM version 1.5. That was already discussed in that thread:
-> http://forums.scummvm.org/viewtopic.php?p=72441&sid=8953c7999127b4644792cb62a3f85281

 Reply with quote  
Post Mon Dec 15, 2014 3:17 pm 
 View user's profile Send private message
md5
ScummVM Developer


Joined: 03 Nov 2005
Posts: 2256
Location: Athens, Greece
 

There's not much we can do about this - the MT-32 emulator we use is munt, here:

http://github.com/munt/munt/

It would be better if you asked the people in the munt project about your issues, by opening a bug report in that project.

 Reply with quote  
Post Mon Dec 15, 2014 3:59 pm 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 806
 

As an addendum from me... AReim1982: You have the source code for both releases. You could try building them with some debug output and do some profiling on the MT32 Emulator to try to work out why it has become so slow.

I think at one point Munt had switched to float for high accuracy, but at a massive performance penalty, but that should not be the case with the latest releases which we have intergrated, but we may need to set a define to force high performance vs. accuracy?

 Reply with quote  
Post Tue Dec 16, 2014 2:12 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next


Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge