ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > Wii Port > Test-Candidate of ScummVM 1.9.0 for WII Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next
Test-Candidate of ScummVM 1.9.0 for WII
  Author    Thread Reply to topic
47iscool



Joined: 12 May 2014
Posts: 48
Location: United States
 

Well the red and black background was only in the ScummVM background, not in any games that I know of.

 Reply with quote  
Post Tue May 13, 2014 4:42 pm 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 829
 

The bug name is slightly misleading. The effect was observed in several FM-TOWNS games with the mouse cursor, but it turned out to be a backend bug related to certain graphics surfaces with color keying. Anyway, *shrug* it is fixed now and seems to have fixed your observed issues.

 Reply with quote  
Post Tue May 13, 2014 5:16 pm 
 View user's profile Send private message
47iscool



Joined: 12 May 2014
Posts: 48
Location: United States
 

The only problem I have now is that SOMI ultimate talkie edition has no voice overs, also flac doesn't work but mp3 does.

 Reply with quote  
Post Tue May 13, 2014 7:48 pm 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 829
 

That is probably because libflac is not compiled on the buildbot for the Wii toolchain. I will take a look at that.

 Reply with quote  
Post Tue May 13, 2014 8:02 pm 
 View user's profile Send private message
47iscool



Joined: 12 May 2014
Posts: 48
Location: United States
 

quote:
Originally posted by digitall
That is probably because libflac is not compiled on the buildbot for the Wii toolchain. I will take a look at that.


Thanks
 Reply with quote  
Post Tue May 13, 2014 8:51 pm 
 View user's profile Send private message
AReim1982



Joined: 10 Dec 2013
Posts: 24
Location: Germany
 

@digitall: My inofficial ScummVM 1.6-Release already contains libflac. Please ask me if you need help with compiling libflac.

 Reply with quote  
Post Wed May 14, 2014 9:15 am 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 829
 

@AReim1982: Thanks. Any major pitfalls?

Did you use v1.2.1 and the patches from here? http://wiki.scummvm.org/index.php/Compiling_ScummVM/Wii#FLAC

 Reply with quote  
Post Wed May 14, 2014 9:24 am 
 View user's profile Send private message
47iscool



Joined: 12 May 2014
Posts: 48
Location: United States
 

Hopefully I'm not confusing anyone here, 1.6.0 does have flac support, just not the 1.7 git revisions.

 Reply with quote  
Post Wed May 14, 2014 1:58 pm 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 829
 

47iscool: That is probably because the v1.6.0 build on the buildbot was made prior to the toolchain being updated (and thus the libraries were rebuilt).

The stable nightly builds are only performed if there has been a code change within the last 24 hours. As the stable release branch has not had any backports recently, a rebuild is not performed.

 Reply with quote  
Post Wed May 14, 2014 2:30 pm 
 View user's profile Send private message
AReim1982



Joined: 10 Dec 2013
Posts: 24
Location: Germany
 

@digitall:
yes, if you follow that tutorial, libflac should compile fine.
p.s.: somebody should update that tutorial [ not me, because my english is too bad... Smile ]

 Reply with quote  
Post Wed May 14, 2014 6:58 pm 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 829
 

libflac should now be installed on the buildbot Wii toolchain. Will need to check the next nightly.

 Reply with quote  
Post Sat May 17, 2014 9:41 pm 
 View user's profile Send private message
47iscool



Joined: 12 May 2014
Posts: 48
Location: United States
 

Not sure if it's considered a problem or but, pressing shift plus another button on the virtual keyboard doesn't work. It just presses the second button instead and removes the shift from the line at the top which displays which buttons you want to press.

Also, does a USB keyboard and/or mouse work with ScummVM?

 Reply with quote  
Post Sun May 18, 2014 3:46 am 
 View user's profile Send private message
47iscool



Joined: 12 May 2014
Posts: 48
Location: United States
 

Start game,edit game options or trying to edit the default settings for every game gives a DSI error.

Version: wii-master-bee54dc0

 Reply with quote  
Post Sun May 18, 2014 8:29 am 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 829
 

Hmm.. libflac doesn't seem to have been picked up the nightly. Will have to check how it was built and whether there is any issue with the location for detecting it.

47iscool: As far as I know, a USB keyboard and mouse should work. Not sure why that occurs with the Virtual Keyboard. I don't think I saw that or the DSI error when I last tested. Will check here on my Wii.

 Reply with quote  
Post Sun May 18, 2014 10:32 am 
 View user's profile Send private message
digitall
ScummVM Developer


Joined: 02 Aug 2012
Posts: 829
 

Tested with a slightly older v1.7.0git6276 "known good" build.

This supports USB hubs and USB keyboards within ScummVM for text input. However, USB mice don't seem to work. They also don't work in the System Menu or HBC.

 Reply with quote  
Post Sun May 18, 2014 4:45 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next


Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge