ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > GP2X/GP2XWiz/Caanoo Port > Pointer won't move on 1.4.1 (GP2X-F100)
Pointer won't move on 1.4.1 (GP2X-F100)
  Author    Thread Reply to topic
Bunny



Joined: 15 Feb 2012
Posts: 1
Pointer won't move on 1.4.1 (GP2X-F100) 

I've installed 1.4.1 on my GP2X-F100, running 3.0.0 firmware. When I launch it, the main menu screen appears, but I can't get the pointer to budge from the top left hand corner, no matter what I press. Therefore, I can't add any games.

I've read the wiki page here, which simply says that the joystick moves the pointer. I've looked at the GP2X wiki, which is no use as it's out of date. I've read the readme files (both generic and GPH-specific) in the archive, and couldn't find anything.

I did notice one difference in the actual scummvm.gpe file, which was the way the game is launched:

In 1.2.0, it's simply:

code:
./scummvm.gph


In 1.4.1, it's:
code:
./scummvm.gph --fullscreen --gfx-mode=1x --config=$(pwd)/.scummvmrc



I tried editing the one in 1.4.1 to the simpler version used in 1.2.0, but the problem persisted.

I don't have this problem in 1.2.0, so I can use that for almost all the games I own, but I would like to play Backyard Baseball, and that's one of the few games that has significantly improved compatibility between the two versions. Can anyone help, please?
 Reply with quote  
Post Wed Feb 15, 2012 1:11 am 
 View user's profile Send private message
DJWillis
ScummVM Porter


Joined: 26 Oct 2005
Posts: 174
 

Hi,

Sorry for the late reply, I'll dig out one of my GP2X's and have a look. Can't say I noticed such an issue in testing.

You may also want to try a daily build and see if you still have the problem there - http://buildbot.scummvm.org/builds.html

Note, the daily builds WILL be slower as they contain debug information and are not optemised.

 Reply with quote  
Post Sat Mar 10, 2012 10:42 am 
 View user's profile Send private message
elboato



Joined: 03 Jun 2012
Posts: 2
same problem 

Hi!

I have the same Problem with my GP2x F200. Did anybody solve the problem?

All the best,
elboato

 Reply with quote  
Post Sun Jun 03, 2012 5:42 pm 
 View user's profile Send private message
elboato



Joined: 03 Jun 2012
Posts: 2
hmm - maybe not 

Hmm. Maybe not. The problem seemed to be related with a recent firmware update of my GP2x... (i changed back to 4.0 now --- it seems i have an old GP2x F200 (even though it says "F200(B)" on the back) --- and on this old F200 the touchpad is a different one)

Back to ScummVM: In 1.2.1 it works fine now. In 1.4.1 the curser drifts to the left all the time (its the same, whether i use the touchpad or the curser keys....)

Is there a bug-tracking system somewhere to raise a bug?

All the best,
Martin

 Reply with quote  
Post Sun Jun 03, 2012 8:07 pm 
 View user's profile Send private message
DJWillis
ScummVM Porter


Joined: 26 Oct 2005
Posts: 174
 

Hi,

Can you try the newer 1.5.0 release as these sort of problems should have been fixed up.

Thanks,

John

 Reply with quote  
Post Thu Aug 02, 2012 6:10 pm 
 View user's profile Send private message
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge