ScummVM logo Forum Index - ScummVM website - Contact us - Buy Supported Games: GOG.com Rules - Search - Register - Login curved edge
Folder Forum Index > PSP Port > SVN FW 2.0
SVN FW 2.0
  Author    Thread Reply to topic
erwan



Joined: 31 Oct 2005
Posts: 40
Location: Bretagne, France
SVN FW 2.0 

Hello
You can test last version SVN for the FW 2.0 ( and 1.0, 1.5)
http://scummvm.dc-france.com/scummvm-psp.html

Support "the Lure of the Temptress engine" and "the Cinematique engine evo 1"

 Reply with quote  
Post Thu Mar 16, 2006 8:41 pm 
 View user's profile Send private message Visit poster's website MSN Messenger
joostp
ScummVM Developer


Joined: 21 Sep 2005
Posts: 490
 

Euhm, what's the difference between the 1.00 and 2.00 builds?

 Reply with quote  
Post Thu Mar 16, 2006 9:15 pm 
 View user's profile Send private message
erwan



Joined: 31 Oct 2005
Posts: 40
Location: Bretagne, France
 

Hello,
No, that depends on the version of your FIRWARE

1.0 Binairie for FW 1.00
2.0 Binairie for Loader (FW: 2.00 and +)

 Reply with quote  
Post Thu Mar 16, 2006 9:56 pm 
 View user's profile Send private message Visit poster's website MSN Messenger
joostp
ScummVM Developer


Joined: 21 Sep 2005
Posts: 490
 

Yes, but what is the difference between those binaries?

Since 0.8.2 ScummVM runs in usermode by default, so the 1.00 EBOOT should run on 2.00+ via a loader and there should no longer be a need to build a seperate '2.00' version.
Your 1.00 and 2.00 versions seem to differ, so I want to know what you changed (and why).

 Reply with quote  
Post Thu Mar 16, 2006 10:21 pm 
 View user's profile Send private message
erwan



Joined: 31 Oct 2005
Posts: 40
Location: Bretagne, France
 

code:

//#define   USERSPACE_ONLY


/**
 * Define the module info section
 *
 * 2nd arg must 0x1000 so __init is executed in
 * kernelmode for our loaderInit function
 */
#ifndef USERSPACE_ONLY
PSP_MODULE_INFO("SCUMMVM-PSP", 0x1000, 1, 1);
#else
PSP_MODULE_INFO("SCUMMVM-PSP", 0, 1, 1);
#endif



 Reply with quote  
Post Fri Mar 17, 2006 6:15 am 
 View user's profile Send private message Visit poster's website MSN Messenger
joostp
ScummVM Developer


Joined: 21 Sep 2005
Posts: 490
 

Well, USERSPACE_ONLY is defined by default in SVN now, since I've never received a valueable bug-report with info from the exception handler anyway and it makes it easier for the end-users (they can use any version, the only difference is the 1.00 vs. 1.50 EBOOT packaging).

 Reply with quote  
Post Fri Mar 17, 2006 10:37 am 
 View user's profile Send private message
erwan



Joined: 31 Oct 2005
Posts: 40
Location: Bretagne, France
 

does version "1.00" function on a FW 2.00 ?

Last edited by erwan on Fri Mar 17, 2006 12:00 pm; edited 1 time in total

 Reply with quote  
Post Fri Mar 17, 2006 11:29 am 
 View user's profile Send private message Visit poster's website MSN Messenger
joostp
ScummVM Developer


Joined: 21 Sep 2005
Posts: 490
 

quote:
Originally posted by erwan
does version "1.OO" function on a FW 2.00 ?

Yep, it should.
I don't have a 2.00+ PSP myself, but the 1.00FW 0.8.2 release seemingly works fine for most people with the loader.
 Reply with quote  
Post Fri Mar 17, 2006 11:58 am 
 View user's profile Send private message
erwan



Joined: 31 Oct 2005
Posts: 40
Location: Bretagne, France
 

ok, thank you

 Reply with quote  
Post Fri Mar 17, 2006 12:01 pm 
 View user's profile Send private message Visit poster's website MSN Messenger
  Display posts from previous:      
Reply to topic

Forum Jump:
 



Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

 

Powered by phpBB © 2001, 2006 phpBB Group
Forum design by ScummVM team, icons by raina
curved edge   curved edge